Patchwork qemu: Allow building without X11 support

login
register
mail settings
Submitter Jonas Eriksson
Date Jan. 29, 2014, 9:38 a.m.
Message ID <1390988324-15471-1-git-send-email-jonas.eriksson@enea.com>
Download mbox | patch
Permalink /patch/66017/
State Accepted
Commit 245ee1643fdcdc4ae03b9e5ad3b53991d0620edb
Headers show

Comments

Jonas Eriksson - Jan. 29, 2014, 9:38 a.m.
To enable the construction of minimal hypervisors based on OE, it is
important to be able to build qemu without it requiring X support. By
checking that the distro is built with the x11 feature before adding
virtual/x11 to the dependencies, this is made possible.
---
 meta/recipes-devtools/qemu/qemu.inc | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)
David Nyström - Jan. 29, 2014, 1:59 p.m.
On 2014-01-29 10:38, Jonas Eriksson wrote:
> To enable the construction of minimal hypervisors based on OE, it is
> important to be able to build qemu without it requiring X support. By
> checking that the distro is built with the x11 feature before adding
> virtual/x11 to the dependencies, this is made possible.
> ---
>   meta/recipes-devtools/qemu/qemu.inc | 3 ++-
>   1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/meta/recipes-devtools/qemu/qemu.inc b/meta/recipes-devtools/qemu/qemu.inc
> index 8705dc7..76119c0 100644
> --- a/meta/recipes-devtools/qemu/qemu.inc
> +++ b/meta/recipes-devtools/qemu/qemu.inc
> @@ -1,7 +1,8 @@
>   SUMMARY = "Fast open source processor emulator"
>   HOMEPAGE = "http://qemu.org"
>   LICENSE = "GPLv2 & LGPLv2.1"
> -DEPENDS = "glib-2.0 zlib alsa-lib virtual/libx11 pixman dtc libsdl"
> +DEPENDS = "glib-2.0 zlib alsa-lib pixman dtc libsdl \
> +           ${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', '', d)}"
>   DEPENDS_class-native = "zlib-native alsa-lib-native glib-2.0-native pixman-native dtc-native"
>   DEPENDS_class-nativesdk = "nativesdk-zlib nativesdk-libsdl nativesdk-glib-2.0 nativesdk-pixman nativesdk-dtc"
>   RDEPENDS_${PN}_class-nativesdk = "nativesdk-libsdl"
>

Reviewed-by: David Nyström <david.nystrom@enea.com>

Patch

diff --git a/meta/recipes-devtools/qemu/qemu.inc b/meta/recipes-devtools/qemu/qemu.inc
index 8705dc7..76119c0 100644
--- a/meta/recipes-devtools/qemu/qemu.inc
+++ b/meta/recipes-devtools/qemu/qemu.inc
@@ -1,7 +1,8 @@ 
 SUMMARY = "Fast open source processor emulator"
 HOMEPAGE = "http://qemu.org"
 LICENSE = "GPLv2 & LGPLv2.1"
-DEPENDS = "glib-2.0 zlib alsa-lib virtual/libx11 pixman dtc libsdl"
+DEPENDS = "glib-2.0 zlib alsa-lib pixman dtc libsdl \
+           ${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', '', d)}"
 DEPENDS_class-native = "zlib-native alsa-lib-native glib-2.0-native pixman-native dtc-native"
 DEPENDS_class-nativesdk = "nativesdk-zlib nativesdk-libsdl nativesdk-glib-2.0 nativesdk-pixman nativesdk-dtc"
 RDEPENDS_${PN}_class-nativesdk = "nativesdk-libsdl"