Patchwork [PATCHv3,5/6] ltp: fix comment to refer to oe-core instead of poky

login
register
mail settings
Submitter Fathi Boudra
Date Jan. 28, 2014, 12:41 p.m.
Message ID <1390912914-31576-6-git-send-email-fathi.boudra@linaro.org>
Download mbox | patch
Permalink /patch/65919/
State New
Headers show

Comments

Fathi Boudra - Jan. 28, 2014, 12:41 p.m.
Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
---
 meta/recipes-extended/ltp/ltp_20140115.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Khem Raj - Jan. 28, 2014, 11:10 p.m.
On Tue, Jan 28, 2014 at 4:41 AM, Fathi Boudra <fathi.boudra@linaro.org> wrote:
> Signed-off-by: Fathi Boudra <fathi.boudra@linaro.org>
> ---
>  meta/recipes-extended/ltp/ltp_20140115.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/meta/recipes-extended/ltp/ltp_20140115.bb b/meta/recipes-extended/ltp/ltp_20140115.bb
> index d9c707b..4e20f24 100644
> --- a/meta/recipes-extended/ltp/ltp_20140115.bb
> +++ b/meta/recipes-extended/ltp/ltp_20140115.bb
> @@ -43,7 +43,7 @@ do_install(){
>      # Copy POSIX test suite into ${D}/opt/ltp/testcases by manual
>      cp -r testcases/open_posix_testsuite ${D}/opt/ltp/testcases
>
> -    # We need to remove all scripts which depend on /usr/bin/expect, since expect is not supported in poky
> +    # We need to remove all scripts which depend on /usr/bin/expect, since expect is not supported in oe-core

Could expect is added as packageconfig instead of punting it out so
folks who have expect in their layermix can use it ? I know this
comment is not exact match for this patch however while you are at it
may be its  a good to consider that

>      # We will add expect for enhancement in future
>      find ${D} -type f -print | xargs grep "\!.*\/usr\/bin\/expect" | awk -F":" '{print $1}' | xargs rm -f
>  }
> --
> 1.8.1.2
>
> _______________________________________________
> Openembedded-core mailing list
> Openembedded-core@lists.openembedded.org
> http://lists.openembedded.org/mailman/listinfo/openembedded-core

Patch

diff --git a/meta/recipes-extended/ltp/ltp_20140115.bb b/meta/recipes-extended/ltp/ltp_20140115.bb
index d9c707b..4e20f24 100644
--- a/meta/recipes-extended/ltp/ltp_20140115.bb
+++ b/meta/recipes-extended/ltp/ltp_20140115.bb
@@ -43,7 +43,7 @@  do_install(){
     # Copy POSIX test suite into ${D}/opt/ltp/testcases by manual
     cp -r testcases/open_posix_testsuite ${D}/opt/ltp/testcases
 
-    # We need to remove all scripts which depend on /usr/bin/expect, since expect is not supported in poky
+    # We need to remove all scripts which depend on /usr/bin/expect, since expect is not supported in oe-core
     # We will add expect for enhancement in future
     find ${D} -type f -print | xargs grep "\!.*\/usr\/bin\/expect" | awk -F":" '{print $1}' | xargs rm -f
 }