Patchwork [meta-qt5] qtmultimedia: Use PACKAGECONFIG for gstremer-0.10 and change it to disabled by default

login
register
mail settings
Submitter Martin Jansa
Date Jan. 19, 2014, 11:28 a.m.
Message ID <1390130890-10775-1-git-send-email-Martin.Jansa@gmail.com>
Download mbox | patch
Permalink /patch/65195/
State Accepted, archived
Headers show

Comments

Martin Jansa - Jan. 19, 2014, 11:28 a.m.
* it doesn't support gst-1.x like qtwebkit yet, disable it by default to
  build images without gst-0.10 where possible.

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
 recipes-qt/qt5/qtmultimedia.inc | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Patch

diff --git a/recipes-qt/qt5/qtmultimedia.inc b/recipes-qt/qt5/qtmultimedia.inc
index 8726985..66133f4 100644
--- a/recipes-qt/qt5/qtmultimedia.inc
+++ b/recipes-qt/qt5/qtmultimedia.inc
@@ -1,13 +1,17 @@ 
 require qt5.inc
 
-DEPENDS += "qtdeclarative gstreamer gst-plugins-base alsa-lib "
+DEPENDS += "qtdeclarative alsa-lib"
 
 PACKAGECONFIG ??= ""
 PACKAGECONFIG[openal] = ",,openal-soft"
+PACKAGECONFIG[gstreamer010] = ",,gstreamer gst-plugins-base"
 
 do_configure_prepend() {
     # disable openal test if it isn't enabled by PACKAGECONFIG
     sed -i 's/^qtCompileTest(openal)/OE_OPENAL_ENABLED:qtCompileTest(openal)/g' ${S}/qtmultimedia.pro
+    # disable gstreamer-0.10 test if it isn't enabled by PACKAGECONFIG
+    sed -i 's/^\( *\)qtCompileTest(gstreamer)/\1OE_GSTREAMER010_ENABLED:qtCompileTest(gstreamer) {/g' ${S}/qtmultimedia.pro
 }
 
 EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'openal', 'CONFIG+=OE_OPENAL_ENABLED', '', d)}"
+EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'gstreamer010', 'CONFIG+=OE_GSTREAMER010_ENABLED', '', d)}"