Patchwork [meta-oe,5/5] libsyncml: move build dependencies from RRECOMMENDS to DEPENDS

login
register
mail settings
Submitter Ross Burton
Date Jan. 15, 2014, 11:37 a.m.
Message ID <1389785832-3120-5-git-send-email-ross.burton@intel.com>
Download mbox | patch
Permalink /patch/64891/
State Accepted, archived
Headers show

Comments

Ross Burton - Jan. 15, 2014, 11:37 a.m.
Putting build dependencies into RRECOMMENDS isn't going to work, so move them to
DEPENDS.

Signed-off-by: Ross Burton <ross.burton@intel.com>
---
 meta-oe/recipes-support/opensync/libsyncml_0.5.4.bb |    3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)
Otavio Salvador - Jan. 15, 2014, 11:45 a.m.
On Wed, Jan 15, 2014 at 9:37 AM, Ross Burton <ross.burton@intel.com> wrote:

> Putting build dependencies into RRECOMMENDS isn't going to work, so move
> them to
> DEPENDS.
>
> Signed-off-by: Ross Burton <ross.burton@intel.com>
>

Reviewed-by: Otavio Salvador <otavio@ossystems.com.br>

Patch

diff --git a/meta-oe/recipes-support/opensync/libsyncml_0.5.4.bb b/meta-oe/recipes-support/opensync/libsyncml_0.5.4.bb
index 9cf9243..8053eda 100644
--- a/meta-oe/recipes-support/opensync/libsyncml_0.5.4.bb
+++ b/meta-oe/recipes-support/opensync/libsyncml_0.5.4.bb
@@ -4,8 +4,7 @@  SECTION = "libs"
 LICENSE = "LGPLv2.1"
 LIC_FILES_CHKSUM = "file://COPYING;md5=fad9b3332be894bab9bc501572864b29"
 
-DEPENDS = "libxml2 glib-2.0"
-RRECOMMENDS_${PN} = "wbxml2 openobex libsoup-2.4"
+DEPENDS = "libxml2 glib-2.0 libsoup-2.4 openobex wbxml2"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/libsyncml/libsyncml-${PV}.tar.gz"
 SRC_URI[md5sum] = "84879ed7cb94618530fbcb801a1a4f95"