Patchwork [1/3] opkg-utils: Upgrade to latest git HEAD

login
register
mail settings
Submitter Paul Barker
Date Jan. 15, 2014, 2:17 a.m.
Message ID <1389752246-4296-2-git-send-email-paul@paulbarker.me.uk>
Download mbox | patch
Permalink /patch/64767/
State New
Headers show

Comments

Paul Barker - Jan. 15, 2014, 2:17 a.m.
The latest version of opkg-utils PROVIDES virtual/update-alternatives via a
script copied from opkg.

Signed-off-by: Paul Barker <paul@paulbarker.me.uk>
---
 meta/recipes-devtools/opkg-utils/opkg-utils_git.bb | 7 ++++++-
 1 file changed, 6 insertions(+), 1 deletion(-)
Koen Kooi - Jan. 15, 2014, 10:04 a.m.
Op 15 jan. 2014, om 03:17 heeft Paul Barker <paul@paulbarker.me.uk> het volgende geschreven:

> The latest version of opkg-utils PROVIDES virtual/update-alternatives via a
> script copied from opkg.
> 
> Signed-off-by: Paul Barker <paul@paulbarker.me.uk>
> ---
> meta/recipes-devtools/opkg-utils/opkg-utils_git.bb | 7 ++++++-
> 1 file changed, 6 insertions(+), 1 deletion(-)
> 
> diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
> index 714fc51..4ae6970 100644
> --- a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
> +++ b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
> @@ -4,8 +4,10 @@ HOMEPAGE = "http://code.google.com/p/opkg/"
> LICENSE = "GPLv2+"
> LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
>                     file://opkg.py;beginline=1;endline=18;md5=15917491ad6bf7acc666ca5f7cc1e083"
> +PROVIDES += "virtual/update-alternatives"
> +RPROVIDES_update-alternatives-opkg = "update-alternatives"

R* variables do below do_install since they deal with packaging

> 
> -SRCREV = "757a1664a440c60e8126443bf984e4bdf374c327"
> +SRCREV = "fd4a3a4c20ada47b19e89849ddb6ff87904f01d2"
> PV = "0.1.8+git${SRCPV}"
> 
> SRC_URI = "git://git.yoctoproject.org/opkg-utils"
> @@ -21,6 +23,9 @@ do_install() {
> # Avoid circular dependencies from package_ipk.bbclass
> PACKAGES_class-native = ""
> 
> +PACKAGES =+ "update-alternatives-opkg"
> +FILES_update-alternatives-opkg = "${bindir}/update-alternatives"
> +
> RDEPENDS_${PN} = "python python-shell python-io python-math python-crypt python-logging python-fcntl python-subprocess python-pickle python-compression python-textutils python-stringold"
> RDEPENDS_${PN}_class-native = ""
> 
> -- 
> 1.8.5.2
> 
> _______________________________________________
> Openembedded-core mailing list
> Openembedded-core@lists.openembedded.org
> http://lists.openembedded.org/mailman/listinfo/openembedded-core
>
Paul Barker - Jan. 15, 2014, 4:16 p.m.
On 15 January 2014 10:04, Koen Kooi <koen@dominion.thruhere.net> wrote:
>
> Op 15 jan. 2014, om 03:17 heeft Paul Barker <paul@paulbarker.me.uk> het volgende geschreven:
>

>> LICENSE = "GPLv2+"
>> LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
>>                     file://opkg.py;beginline=1;endline=18;md5=15917491ad6bf7acc666ca5f7cc1e083"
>> +PROVIDES += "virtual/update-alternatives"
>> +RPROVIDES_update-alternatives-opkg = "update-alternatives"
>
> R* variables do below do_install since they deal with packaging
>

I was following the list in
http://www.openembedded.org/wiki/Styleguide which is probably out of
date. I'll re-order it to follow the list in
https://wiki.yoctoproject.org/wiki/Recipe_%26_Patch_Style_Guide.

Patch

diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
index 714fc51..4ae6970 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
@@ -4,8 +4,10 @@  HOMEPAGE = "http://code.google.com/p/opkg/"
 LICENSE = "GPLv2+"
 LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
                     file://opkg.py;beginline=1;endline=18;md5=15917491ad6bf7acc666ca5f7cc1e083"
+PROVIDES += "virtual/update-alternatives"
+RPROVIDES_update-alternatives-opkg = "update-alternatives"
 
-SRCREV = "757a1664a440c60e8126443bf984e4bdf374c327"
+SRCREV = "fd4a3a4c20ada47b19e89849ddb6ff87904f01d2"
 PV = "0.1.8+git${SRCPV}"
 
 SRC_URI = "git://git.yoctoproject.org/opkg-utils"
@@ -21,6 +23,9 @@  do_install() {
 # Avoid circular dependencies from package_ipk.bbclass
 PACKAGES_class-native = ""
 
+PACKAGES =+ "update-alternatives-opkg"
+FILES_update-alternatives-opkg = "${bindir}/update-alternatives"
+
 RDEPENDS_${PN} = "python python-shell python-io python-math python-crypt python-logging python-fcntl python-subprocess python-pickle python-compression python-textutils python-stringold"
 RDEPENDS_${PN}_class-native = ""