[v2,6/6] poky-tiny: enable qemuarmv5/qemuarm64 and cleanups

Message ID 20220408192521.1608764-7-jdmason@kudzu.us
State Accepted, archived
Commit 9bd21e1130155ad1ec704e0151a22e9f84bfaa78
Headers show
Series poky-tiny clean-ups and qemuarm fixes | expand

Commit Message

Jon Mason April 8, 2022, 7:25 p.m. UTC
Add support for qemuarmv5 and qemuarm64, and remove qemuarm specific
entries, as it should be generic now.

Signed-off-by: Jon Mason <jdmason@kudzu.us>
---
 meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

Comments

Khem Raj April 8, 2022, 7:38 p.m. UTC | #1
On 4/8/22 12:25 PM, Jon Mason wrote:
> Add support for qemuarmv5 and qemuarm64, and remove qemuarm specific
> entries, as it should be generic now.
> 
> Signed-off-by: Jon Mason <jdmason@kudzu.us>
> ---
>   meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb | 4 +---
>   1 file changed, 1 insertion(+), 3 deletions(-)
> 
> diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
> index d8ce5dc518d5..43a5ad728a5d 100644
> --- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
> +++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
> @@ -1,5 +1,4 @@
>   KBRANCH ?= "v5.15/standard/tiny/base"
> -KBRANCH:qemuarm  ?= "v5.15/standard/tiny/arm-versatile-926ejs"
>   
>   LINUX_KERNEL_TYPE = "tiny"
>   KCONFIG_MODE = "--allnoconfig"
> @@ -15,7 +14,6 @@ DEPENDS += "openssl-native util-linux-native"
>   KMETA = "kernel-meta"
>   KCONF_BSP_AUDIT_LEVEL = "2"
>   
> -SRCREV_machine:qemuarm ?= "cc9e92e826af229b841fcaf8c645e638a86eba43"
>   SRCREV_machine ?= "c3d54a67cbf3fb8e6df2d88c80e9d2c74f69aba4"
>   SRCREV_meta ?= "63e25b5717751b4b33685bd5991d10c52934a4c6"
>   
> @@ -24,7 +22,7 @@ PV = "${LINUX_VERSION}+git${SRCPV}"
>   SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
>              git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.15;destsuffix=${KMETA}"
>   
> -COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm|qemuarmv5"
> +COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm64|qemuarm|qemuarmv5"

why are we dropping qemuarm ?

>   
>   # Functionality flags
>   KERNEL_FEATURES = ""
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#164168): https://lists.openembedded.org/g/openembedded-core/message/164168
> Mute This Topic: https://lists.openembedded.org/mt/90343240/1997914
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Jon Mason April 8, 2022, 7:53 p.m. UTC | #2
On Fri, Apr 8, 2022 at 3:38 PM Khem Raj <raj.khem@gmail.com> wrote:
>
>
>
> On 4/8/22 12:25 PM, Jon Mason wrote:
> > Add support for qemuarmv5 and qemuarm64, and remove qemuarm specific
> > entries, as it should be generic now.
> >
> > Signed-off-by: Jon Mason <jdmason@kudzu.us>
> > ---
> >   meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb | 4 +---
> >   1 file changed, 1 insertion(+), 3 deletions(-)
> >
> > diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
> > index d8ce5dc518d5..43a5ad728a5d 100644
> > --- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
> > +++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
> > @@ -1,5 +1,4 @@
> >   KBRANCH ?= "v5.15/standard/tiny/base"
> > -KBRANCH:qemuarm  ?= "v5.15/standard/tiny/arm-versatile-926ejs"
> >
> >   LINUX_KERNEL_TYPE = "tiny"
> >   KCONFIG_MODE = "--allnoconfig"
> > @@ -15,7 +14,6 @@ DEPENDS += "openssl-native util-linux-native"
> >   KMETA = "kernel-meta"
> >   KCONF_BSP_AUDIT_LEVEL = "2"
> >
> > -SRCREV_machine:qemuarm ?= "cc9e92e826af229b841fcaf8c645e638a86eba43"
> >   SRCREV_machine ?= "c3d54a67cbf3fb8e6df2d88c80e9d2c74f69aba4"
> >   SRCREV_meta ?= "63e25b5717751b4b33685bd5991d10c52934a4c6"
> >
> > @@ -24,7 +22,7 @@ PV = "${LINUX_VERSION}+git${SRCPV}"
> >   SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
> >              git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.15;destsuffix=${KMETA}"
> >
> > -COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm|qemuarmv5"
> > +COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm64|qemuarm|qemuarmv5"
>
> why are we dropping qemuarm ?

What?  It's adding qemuarm64, which looks like a change of qemuarm to
qemuarm64, but you can see qemuarm after qemuarm64.

>
> >
> >   # Functionality flags
> >   KERNEL_FEATURES = ""
> >
> >
> >
> >
> >
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#164169): https://lists.openembedded.org/g/openembedded-core/message/164169
> Mute This Topic: https://lists.openembedded.org/mt/90343240/3616920
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [jdmason@kudzu.us]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj April 8, 2022, 7:55 p.m. UTC | #3
On 4/8/22 12:53 PM, Jon Mason wrote:
> On Fri, Apr 8, 2022 at 3:38 PM Khem Raj <raj.khem@gmail.com> wrote:
>>
>>
>>
>> On 4/8/22 12:25 PM, Jon Mason wrote:
>>> Add support for qemuarmv5 and qemuarm64, and remove qemuarm specific
>>> entries, as it should be generic now.
>>>
>>> Signed-off-by: Jon Mason <jdmason@kudzu.us>
>>> ---
>>>    meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb | 4 +---
>>>    1 file changed, 1 insertion(+), 3 deletions(-)
>>>
>>> diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
>>> index d8ce5dc518d5..43a5ad728a5d 100644
>>> --- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
>>> +++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
>>> @@ -1,5 +1,4 @@
>>>    KBRANCH ?= "v5.15/standard/tiny/base"
>>> -KBRANCH:qemuarm  ?= "v5.15/standard/tiny/arm-versatile-926ejs"
>>>
>>>    LINUX_KERNEL_TYPE = "tiny"
>>>    KCONFIG_MODE = "--allnoconfig"
>>> @@ -15,7 +14,6 @@ DEPENDS += "openssl-native util-linux-native"
>>>    KMETA = "kernel-meta"
>>>    KCONF_BSP_AUDIT_LEVEL = "2"
>>>
>>> -SRCREV_machine:qemuarm ?= "cc9e92e826af229b841fcaf8c645e638a86eba43"
>>>    SRCREV_machine ?= "c3d54a67cbf3fb8e6df2d88c80e9d2c74f69aba4"
>>>    SRCREV_meta ?= "63e25b5717751b4b33685bd5991d10c52934a4c6"
>>>
>>> @@ -24,7 +22,7 @@ PV = "${LINUX_VERSION}+git${SRCPV}"
>>>    SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
>>>               git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.15;destsuffix=${KMETA}"
>>>
>>> -COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm|qemuarmv5"
>>> +COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm64|qemuarm|qemuarmv5"


>>
>> why are we dropping qemuarm ?
> 
> What?  It's adding qemuarm64, which looks like a change of qemuarm to
> qemuarm64, but you can see qemuarm after qemuarm64.

heh, not enough sleep.

> 
>>
>>>
>>>    # Functionality flags
>>>    KERNEL_FEATURES = ""
>>>
>>>
>>>
>>>
>>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#164169): https://lists.openembedded.org/g/openembedded-core/message/164169
>> Mute This Topic: https://lists.openembedded.org/mt/90343240/3616920
>> Group Owner: openembedded-core+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [jdmason@kudzu.us]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>

Patch

diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
index d8ce5dc518d5..43a5ad728a5d 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_5.15.bb
@@ -1,5 +1,4 @@ 
 KBRANCH ?= "v5.15/standard/tiny/base"
-KBRANCH:qemuarm  ?= "v5.15/standard/tiny/arm-versatile-926ejs"
 
 LINUX_KERNEL_TYPE = "tiny"
 KCONFIG_MODE = "--allnoconfig"
@@ -15,7 +14,6 @@  DEPENDS += "openssl-native util-linux-native"
 KMETA = "kernel-meta"
 KCONF_BSP_AUDIT_LEVEL = "2"
 
-SRCREV_machine:qemuarm ?= "cc9e92e826af229b841fcaf8c645e638a86eba43"
 SRCREV_machine ?= "c3d54a67cbf3fb8e6df2d88c80e9d2c74f69aba4"
 SRCREV_meta ?= "63e25b5717751b4b33685bd5991d10c52934a4c6"
 
@@ -24,7 +22,7 @@  PV = "${LINUX_VERSION}+git${SRCPV}"
 SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=machine \
            git://git.yoctoproject.org/yocto-kernel-cache;type=kmeta;name=meta;branch=yocto-5.15;destsuffix=${KMETA}"
 
-COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm|qemuarmv5"
+COMPATIBLE_MACHINE = "qemux86|qemux86-64|qemuarm64|qemuarm|qemuarmv5"
 
 # Functionality flags
 KERNEL_FEATURES = ""