Patchwork libsoup: Remove libproxy from DEPENDS

login
register
mail settings
Submitter Phil Blundell
Date Jan. 9, 2014, 11:16 a.m.
Message ID <1389266170.9182.122.camel@phil-desktop.brightsign>
Download mbox | patch
Permalink /patch/64473/
State New
Headers show

Comments

Phil Blundell - Jan. 9, 2014, 11:16 a.m.
Although libsoup did use to support direct usage of libproxy, it hasn't
done so for some time.  Worse, if libsoup depends on libproxy then it
is impossible to build libproxy against webkit since webkit itself
depends on libsoup in some configurations.  Fix this by removing the
extraneous entry from DEPENDS.

Signed-off-by: Phil Blundell <pb@pbcl.net>
---
 meta/recipes-support/libsoup/libsoup-2.4_2.44.2.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Otavio Salvador - Jan. 9, 2014, 2:10 p.m.
On Thu, Jan 9, 2014 at 9:16 AM, Phil Blundell <pb@pbcl.net> wrote:

> Although libsoup did use to support direct usage of libproxy, it hasn't
> done so for some time.  Worse, if libsoup depends on libproxy then it
> is impossible to build libproxy against webkit since webkit itself
> depends on libsoup in some configurations.  Fix this by removing the
> extraneous entry from DEPENDS.
>
> Signed-off-by: Phil Blundell <pb@pbcl.net>
>

Does it need a --disable-libproxy or so?
Phil Blundell - Jan. 10, 2014, 11:44 a.m.
On Thu, 2014-01-09 at 12:10 -0200, Otavio Salvador wrote:

> On Thu, Jan 9, 2014 at 9:16 AM, Phil Blundell <pb@pbcl.net> wrote:
> 
>         Although libsoup did use to support direct usage of libproxy,
>         it hasn't
>         done so for some time.  Worse, if libsoup depends on libproxy
>         then it
>         is impossible to build libproxy against webkit since webkit
>         itself
>         depends on libsoup in some configurations.  Fix this by
>         removing the
>         extraneous entry from DEPENDS.
>         
>         Signed-off-by: Phil Blundell <pb@pbcl.net>
>         
> 
> 
> Does it need a --disable-libproxy or so? 

No.   See the (old) NEWS:


        Changes in libsoup from 2.33.90 to 2.33.92:
        
                * LIBSOUP NO LONGER DEPENDS ON GCONF OR LIBPROXY.
                  (see below).
        
               * Updated SoupProxyResolverGNOME to be based on
                  SoupProxyResolverDefault, but explicitly requesting
        the
                  "gnome" GProxyResolver if it is available [#625898],
        and
                  removed the old code that used GConf and libproxy
        directly.
        

p.

Patch

diff --git a/meta/recipes-support/libsoup/libsoup-2.4_2.44.2.bb b/meta/recipes-support/libsoup/libsoup-2.4_2.44.2.bb
index a7ea106..b245f68 100644
--- a/meta/recipes-support/libsoup/libsoup-2.4_2.44.2.bb
+++ b/meta/recipes-support/libsoup/libsoup-2.4_2.44.2.bb
@@ -7,7 +7,7 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
 
 SECTION = "x11/gnome/libs"
 
-DEPENDS = "glib-2.0 gnutls libxml2 libproxy sqlite3 intltool-native"
+DEPENDS = "glib-2.0 gnutls libxml2 sqlite3 intltool-native"
 
 # libsoup-gnome is entirely deprecated and just stubs in 2.42 onwards.  Enable
 # by default but let it be easily disabled.