[01/17] connman-conf: ignore eth0 in qemu in a way that is not sysvinit-specific

Message ID 20220407170029.3500874-1-alex@linutronix.de
State Accepted, archived
Commit 9e2cb139fabf302fb85c292a8848d6fb66851d07
Headers show
Series [01/17] connman-conf: ignore eth0 in qemu in a way that is not sysvinit-specific | expand

Commit Message

Alexander Kanavin April 7, 2022, 5 p.m. UTC
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
---
 meta/recipes-connectivity/connman/connman-conf.bb        | 7 +++++--
 meta/recipes-connectivity/connman/connman-conf/main.conf | 2 ++
 2 files changed, 7 insertions(+), 2 deletions(-)
 create mode 100644 meta/recipes-connectivity/connman/connman-conf/main.conf

Comments

Steve Sakoman April 20, 2022, 8:05 p.m. UTC | #1
I still occasionally get the ping error on dunfell autobuilder runs,
so I suspect it needs something similar to this patch.

I'm not conman literate, so if someone who is can create a patch for
dunfell I would be most appreciative!  The recipe differences between
master and dunfell are great enough that I don't trust myself :-)

Steve

On Thu, Apr 7, 2022 at 7:00 AM Alexander Kanavin <alex.kanavin@gmail.com> wrote:
>
> Signed-off-by: Alexander Kanavin <alex@linutronix.de>
> ---
>  meta/recipes-connectivity/connman/connman-conf.bb        | 7 +++++--
>  meta/recipes-connectivity/connman/connman-conf/main.conf | 2 ++
>  2 files changed, 7 insertions(+), 2 deletions(-)
>  create mode 100644 meta/recipes-connectivity/connman/connman-conf/main.conf
>
> diff --git a/meta/recipes-connectivity/connman/connman-conf.bb b/meta/recipes-connectivity/connman/connman-conf.bb
> index 6b9207c4cb..7959ed8e50 100644
> --- a/meta/recipes-connectivity/connman/connman-conf.bb
> +++ b/meta/recipes-connectivity/connman/connman-conf.bb
> @@ -6,6 +6,9 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;m
>
>  PR = "r2"
>
> +SRC_URI = "file://main.conf \
> +          "
> +
>  S = "${WORKDIR}"
>
>  PACKAGE_ARCH = "${MACHINE_ARCH}"
> @@ -14,6 +17,6 @@ FILES:${PN} = "${sysconfdir}/*"
>
>  # Kernel IP-Config is perfectly capable of setting up networking passed in via ip=
>  do_install:append:qemuall() {
> -    mkdir -p ${D}${sysconfdir}/default
> -    echo "export EXTRA_PARAM=\"-I eth0\"" > ${D}${sysconfdir}/default/connman
> +    mkdir -p ${D}${sysconfdir}/connman
> +    cp ${S}/main.conf ${D}${sysconfdir}/connman/main.conf
>  }
> diff --git a/meta/recipes-connectivity/connman/connman-conf/main.conf b/meta/recipes-connectivity/connman/connman-conf/main.conf
> new file mode 100644
> index 0000000000..a394e8f25b
> --- /dev/null
> +++ b/meta/recipes-connectivity/connman/connman-conf/main.conf
> @@ -0,0 +1,2 @@
> +[General]
> +NetworkInterfaceBlacklist = eth0
> --
> 2.30.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#164117): https://lists.openembedded.org/g/openembedded-core/message/164117
> Mute This Topic: https://lists.openembedded.org/mt/90317717/3620601
> Group Owner: openembedded-core+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-core/unsub [steve@sakoman.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Richard Purdie April 20, 2022, 9 p.m. UTC | #2
On Wed, 2022-04-20 at 10:05 -1000, Steve Sakoman wrote:
> I still occasionally get the ping error on dunfell autobuilder runs,
> so I suspect it needs something similar to this patch.
> 
> I'm not conman literate, so if someone who is can create a patch for
> dunfell I would be most appreciative!  The recipe differences between
> master and dunfell are great enough that I don't trust myself :-)

Also note that this did require meta-agl to make changes to their layer to adapt
to what core did...

Cheers,

Richard

Patch

diff --git a/meta/recipes-connectivity/connman/connman-conf.bb b/meta/recipes-connectivity/connman/connman-conf.bb
index 6b9207c4cb..7959ed8e50 100644
--- a/meta/recipes-connectivity/connman/connman-conf.bb
+++ b/meta/recipes-connectivity/connman/connman-conf.bb
@@ -6,6 +6,9 @@  LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0-only;m
 
 PR = "r2"
 
+SRC_URI = "file://main.conf \
+          "
+
 S = "${WORKDIR}"
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -14,6 +17,6 @@  FILES:${PN} = "${sysconfdir}/*"
 
 # Kernel IP-Config is perfectly capable of setting up networking passed in via ip=
 do_install:append:qemuall() {
-    mkdir -p ${D}${sysconfdir}/default
-    echo "export EXTRA_PARAM=\"-I eth0\"" > ${D}${sysconfdir}/default/connman
+    mkdir -p ${D}${sysconfdir}/connman
+    cp ${S}/main.conf ${D}${sysconfdir}/connman/main.conf
 }
diff --git a/meta/recipes-connectivity/connman/connman-conf/main.conf b/meta/recipes-connectivity/connman/connman-conf/main.conf
new file mode 100644
index 0000000000..a394e8f25b
--- /dev/null
+++ b/meta/recipes-connectivity/connman/connman-conf/main.conf
@@ -0,0 +1,2 @@ 
+[General]
+NetworkInterfaceBlacklist = eth0