Patchwork [meta-oe] udisks: Don't enable acl PACKAGECONFIG by default

login
register
mail settings
Submitter Martin Jansa
Date Jan. 1, 2014, 11:58 a.m.
Message ID <1388577530-4557-1-git-send-email-Martin.Jansa@gmail.com>
Download mbox | patch
Permalink /patch/63951/
State Superseded, archived
Headers show

Comments

Martin Jansa - Jan. 1, 2014, 11:58 a.m.
* libacl isn't available in oe-core/meta-oe

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
 meta-oe/recipes-support/udisks/udisks_2.1.1.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Martin Jansa - Jan. 1, 2014, 9:12 p.m.
On Wed, Jan 01, 2014 at 12:58:50PM +0100, Martin Jansa wrote:
> * libacl isn't available in oe-core/meta-oe
> 
> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
> ---
>  meta-oe/recipes-support/udisks/udisks_2.1.1.bb | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/meta-oe/recipes-support/udisks/udisks_2.1.1.bb b/meta-oe/recipes-support/udisks/udisks_2.1.1.bb
> index d4c6eff..a0bf148 100644
> --- a/meta-oe/recipes-support/udisks/udisks_2.1.1.bb
> +++ b/meta-oe/recipes-support/udisks/udisks_2.1.1.bb
> @@ -14,7 +14,7 @@ SRC_URI[sha256sum] = "013b09ff38aa256b89c01525771f4565cb088724d5c8c79b32e9f811e8

newer udisks also breaks 
| configure: error: Package requirements (udisks  >= 1.0.0 udisks < 1.1.0) were not met:

NOTE: recipe gnome-disk-utility-2.32.0-r4: task do_configure: Failed
ERROR: Task 366
(/home/jenkins/oe/shr-core-branches/shr-core/meta-openembedded/meta-gnome/recipes-gnome/gnome-disk-utility/gnome-disk-utility_2.32.0.bb,
do_configure) failed with exit code '1'

so newer udisks needs to wait for gnome-disk-utility update.

>  
>  inherit autotools systemd
>  
> -PACKAGECONFIG ??= "atasmart polkit acl ${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd-login', '', d)}"
> +PACKAGECONFIG ??= "atasmart polkit ${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd-login', '', d)}"
>  PACKAGECONFIG[atasmart] = "--enable-libatasmart,--disable-libatasmart,libatasmart"
>  PACKAGECONFIG[polkit] = "--enable-polkit,--disable-polkit,polkit"
>  PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,libacl"
> -- 
> 1.8.4.3
>
Koen Kooi - Jan. 2, 2014, 12:56 p.m.
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Martin Jansa schreef op 01-01-14 12:58:
> * libacl isn't available in oe-core/meta-oe

Yes it is:
https://github.com/openembedded/oe-core/blob/master/meta/recipes-support/attr/acl_2.2.52.bb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (Darwin)
Comment: GPGTools - http://gpgtools.org

iD8DBQFSxWHwMkyGM64RGpERAvmGAKCzy6nSaxbWBhe9/VaXl439dfWRiwCfa3vp
ez5rPMtceGixyAcVTm2XEUE=
=rj77
-----END PGP SIGNATURE-----
Martin Jansa - Jan. 2, 2014, 1:38 p.m.
Ah ok, so packageconfig needs to be fixed..

 PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,libacl"


On Thu, Jan 2, 2014 at 1:56 PM, Koen Kooi <koen@dominion.thruhere.net>wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Martin Jansa schreef op 01-01-14 12:58:
> > * libacl isn't available in oe-core/meta-oe
>
> Yes it is:
>
> https://github.com/openembedded/oe-core/blob/master/meta/recipes-support/attr/acl_2.2.52.bb
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.5 (Darwin)
> Comment: GPGTools - http://gpgtools.org
>
> iD8DBQFSxWHwMkyGM64RGpERAvmGAKCzy6nSaxbWBhe9/VaXl439dfWRiwCfa3vp
> ez5rPMtceGixyAcVTm2XEUE=
> =rj77
> -----END PGP SIGNATURE-----
>
> _______________________________________________
> Openembedded-devel mailing list
> Openembedded-devel@lists.openembedded.org
> http://lists.openembedded.org/mailman/listinfo/openembedded-devel
>

Patch

diff --git a/meta-oe/recipes-support/udisks/udisks_2.1.1.bb b/meta-oe/recipes-support/udisks/udisks_2.1.1.bb
index d4c6eff..a0bf148 100644
--- a/meta-oe/recipes-support/udisks/udisks_2.1.1.bb
+++ b/meta-oe/recipes-support/udisks/udisks_2.1.1.bb
@@ -14,7 +14,7 @@  SRC_URI[sha256sum] = "013b09ff38aa256b89c01525771f4565cb088724d5c8c79b32e9f811e8
 
 inherit autotools systemd
 
-PACKAGECONFIG ??= "atasmart polkit acl ${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd-login', '', d)}"
+PACKAGECONFIG ??= "atasmart polkit ${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd-login', '', d)}"
 PACKAGECONFIG[atasmart] = "--enable-libatasmart,--disable-libatasmart,libatasmart"
 PACKAGECONFIG[polkit] = "--enable-polkit,--disable-polkit,polkit"
 PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,libacl"