[1/1] libimobiledevice-glue: update recipe

Message ID 20220406082456.20813-1-potin.lai@quantatw.com
State New
Headers show
Series [1/1] libimobiledevice-glue: update recipe | expand

Commit Message

Potin Lai April 6, 2022, 8:24 a.m. UTC
remove patch 0001-fix-undefined-bswap32-and-bswap64-errors-for-MIPS-ma.patch
  Upstream Status: Accepted [https://github.com/libimobiledevice/libimobiledevice-glue/commit/17a2b964ca9c94f6615994ba2179bf4228e31236]

subtree update: ecb0996fd2..bc6c44b920

Nikias Bassen (4):
  [github-actions] Use windows-2019 instead of windows-latest for now
  socket: Add socket_get_socket_port function
  utils: Close file if buffer allocation fails in
    buffer_read_from_filename()
  Updated README with pkg-config requirement

Potin Lai (1):
  Fix undefined bswap32 and bswap64 for MIPS machine

Signed-off-by: Potin Lai <potin.lai@quantatw.com>
---
 ...wap32-and-bswap64-errors-for-MIPS-ma.patch | 32 -------------------
 .../libimobiledevice-glue_git.bb              |  7 ++--
 2 files changed, 2 insertions(+), 37 deletions(-)
 delete mode 100644 meta-oe/recipes-connectivity/libimobiledevice-glue/files/0001-fix-undefined-bswap32-and-bswap64-errors-for-MIPS-ma.patch

Patch

diff --git a/meta-oe/recipes-connectivity/libimobiledevice-glue/files/0001-fix-undefined-bswap32-and-bswap64-errors-for-MIPS-ma.patch b/meta-oe/recipes-connectivity/libimobiledevice-glue/files/0001-fix-undefined-bswap32-and-bswap64-errors-for-MIPS-ma.patch
deleted file mode 100644
index cff37fb5d..000000000
--- a/meta-oe/recipes-connectivity/libimobiledevice-glue/files/0001-fix-undefined-bswap32-and-bswap64-errors-for-MIPS-ma.patch
+++ /dev/null
@@ -1,32 +0,0 @@ 
-From 73fcf0b54f4c1fc07a2aa003dddaeb5a97177cce Mon Sep 17 00:00:00 2001
-From: Potin Lai <potin.lai@quantatw.com>
-Date: Thu, 31 Mar 2022 08:44:31 +0800
-Subject: [PATCH 1/1] fix undefined bswap32 and bswap64 errors for MIPS machine
-
-Replace bswap32 and bswap64 with internal defined version (__bswap_X)
-
-Upstream Status: Submitted [libimobiledevice-devel@libimobiledevice.org]
-
-Signed-off-by: Potin Lai <potin.lai@quantatw.com>
----
- include/endianness.h | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/include/endianness.h b/include/endianness.h
-index 099877a..88b63db 100644
---- a/include/endianness.h
-+++ b/include/endianness.h
-@@ -113,8 +113,8 @@
-      && !defined(__FLOAT_WORD_ORDER__)) \
-  || (defined(__FLOAT_WORD_ORDER__) \
-      && __FLOAT_WORD_ORDER__ == __ORDER_BIG_ENDIAN__)
--#define float_bswap64(x) bswap64(x)
--#define float_bswap32(x) bswap32(x)
-+#define float_bswap64(x) __bswap_64(x)
-+#define float_bswap32(x) __bswap_32(x)
- #else
- #define float_bswap64(x) (x)
- #define float_bswap32(x) (x)
--- 
-2.17.1
-
diff --git a/meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb b/meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb
index d5d90ea13..6d872b9f8 100644
--- a/meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb
+++ b/meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb
@@ -10,11 +10,8 @@  DEPENDS = "libplist"
 
 PV = "1.0.0+git${SRCPV}"
 
-SRCREV = "ecb0996fd2a3b0539153dd3ef901d137bf498ffe"
-SRC_URI = "\
-    git://github.com/libimobiledevice/libimobiledevice-glue;protocol=https;branch=master \
-    file://0001-fix-undefined-bswap32-and-bswap64-errors-for-MIPS-ma.patch \
-"
+SRCREV = "bc6c44b92091c9587a9bed0ed3f2c3248bfd13b3"
+SRC_URI = "git://github.com/libimobiledevice/libimobiledevice-glue;protocol=https;branch=master"
 
 S = "${WORKDIR}/git"
 inherit autotools pkgconfig