Patchwork [V3,1/1] libav: Add v9.10

login
register
mail settings
Submitter Andrei Gherzan
Date Dec. 7, 2013, 6:12 p.m.
Message ID <1386439921-11748-1-git-send-email-andrei@gherzan.ro>
Download mbox | patch
Permalink /patch/63023/
State New
Headers show

Comments

Andrei Gherzan - Dec. 7, 2013, 6:12 p.m.
This version includes libavresample needed for packages like xbmc.
To use this version add:
PREFERRED_VERSION_libav = "9.10".
Removed git version as being an older version of a 9.X release.

Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
---
 meta/recipes-multimedia/libav/{libav_git.bb => libav_9.10.bb} | 11 ++++-------
 1 file changed, 4 insertions(+), 7 deletions(-)
 rename meta/recipes-multimedia/libav/{libav_git.bb => libav_9.10.bb} (65%)
Otavio Salvador - Dec. 8, 2013, 11:42 a.m.
On Sat, Dec 7, 2013 at 4:12 PM, Andrei Gherzan <andrei@gherzan.ro> wrote:
> This version includes libavresample needed for packages like xbmc.
> To use this version add:
> PREFERRED_VERSION_libav = "9.10".
> Removed git version as being an older version of a 9.X release.
>
> Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>

Any reason to keep the old version? why not move to this release?
Andrei Gherzan - Dec. 8, 2013, 12:07 p.m.
On Sun, Dec 8, 2013 at 1:42 PM, Otavio Salvador <otavio@ossystems.com.br>wrote:

> On Sat, Dec 7, 2013 at 4:12 PM, Andrei Gherzan <andrei@gherzan.ro> wrote:
> > This version includes libavresample needed for packages like xbmc.
> > To use this version add:
> > PREFERRED_VERSION_libav = "9.10".
> > Removed git version as being an older version of a 9.X release.
> >
> > Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
>
> Any reason to keep the old version? why not move to this release?
>
>
In upstream they keep maintaining two versions: 0.X and 9.X. Probably
because of some incompatibilities - don't have any tests that would sustain
this statement. So until somebody really uses 9.X and confirms that
everything works I would suggest keeping this setup.
Paul Eggleton - Dec. 8, 2013, 8:47 p.m.
On Sunday 08 December 2013 09:42:19 Otavio Salvador wrote:
> On Sat, Dec 7, 2013 at 4:12 PM, Andrei Gherzan <andrei@gherzan.ro> wrote:
> > This version includes libavresample needed for packages like xbmc.
> > To use this version add:
> > PREFERRED_VERSION_libav = "9.10".
> > Removed git version as being an older version of a 9.X release.
> > 
> > Signed-off-by: Andrei Gherzan <andrei@gherzan.ro>
> 
> Any reason to keep the old version? why not move to this release?

If nothing else, I think we have to keep 0.8.x around until we remove 
gstreamer 0.10 (or we revert back to gst-ffmpeg's internal ffmpeg copy, but that 
doesn't seem like a good idea).

Cheers,
Paul

Patch

diff --git a/meta/recipes-multimedia/libav/libav_git.bb b/meta/recipes-multimedia/libav/libav_9.10.bb
similarity index 65%
rename from meta/recipes-multimedia/libav/libav_git.bb
rename to meta/recipes-multimedia/libav/libav_9.10.bb
index 951baa9..48bab7d 100644
--- a/meta/recipes-multimedia/libav/libav_git.bb
+++ b/meta/recipes-multimedia/libav/libav_9.10.bb
@@ -5,12 +5,9 @@  LIC_FILES_CHKSUM = "file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
                     file://COPYING.LGPLv2.1;md5=bd7a443320af8c812e4c18d1b79df004 \
                     file://COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02"
 
-PV = "9.8+git${SRCPV}"
+SRC_URI = "http://libav.org/releases/${BP}.tar.xz"
 
-DEFAULT_PREFERENCE = "-1"
-
-SRCREV = "9aaca159bd220582c698f13d081a455f398c9975"
-SRC_URI = "git://git.libav.org/libav.git"
-
-S = "${WORKDIR}/git"
+SRC_URI[md5sum] = "4b49d1d8734815ca095bb0600d41c5cb"
+SRC_URI[sha256sum] = "83dbe640779da1c1e8d8836c99575f57f749d18407494ebca451578afee9300d"
 
+DEFAULT_PREFERENCE = "-1"