[master] wl18xx-fw: Make it support usrmerge

Message ID 20220330104511.19292-1-alessio.bogani@elettra.eu
State Accepted
Delegated to: Ryan Eatmon
Headers show
Series [master] wl18xx-fw: Make it support usrmerge | expand

Commit Message

Alessio Igor Bogani March 30, 2022, 10:45 a.m. UTC
Signed-off-by: Alessio Igor Bogani <alessio.bogani@elettra.eu>
---
 .../recipes-bsp/wl18xx-fw/wl18xx-fw_8.9.0.0.86.bb         | 8 ++++++--
 1 file changed, 6 insertions(+), 2 deletions(-)

Comments

Denys Dmytriyenko April 5, 2022, 3:54 a.m. UTC | #1
On Wed, Mar 30, 2022 at 12:45:11PM +0200, Alessio Igor Bogani wrote:
> Signed-off-by: Alessio Igor Bogani <alessio.bogani@elettra.eu>

Reviewed-by: Denys Dmytriyenko <denys@konsulko.com>


> ---
>  .../recipes-bsp/wl18xx-fw/wl18xx-fw_8.9.0.0.86.bb         | 8 ++++++--
>  1 file changed, 6 insertions(+), 2 deletions(-)
> 
> diff --git a/meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw_8.9.0.0.86.bb b/meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw_8.9.0.0.86.bb
> index 48b500a8..09968993 100644
> --- a/meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw_8.9.0.0.86.bb
> +++ b/meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw_8.9.0.0.86.bb
> @@ -19,7 +19,11 @@ do_compile() {
>  }
>  
>  do_install() {
> -    oe_runmake 'DEST_DIR=${D}' install
> +    if ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','true','false',d)}; then
> +        oe_runmake 'DEST_DIR=${D}/usr' install
> +    else
> +        oe_runmake 'DEST_DIR=${D}' install
> +    fi
>  }
>  
> -FILES:${PN} = "/lib/firmware/ti-connectivity/*"
> +FILES:${PN} = "${nonarch_base_libdir}/firmware/ti-connectivity/*"
> -- 
> 2.17.1
Ryan Eatmon April 5, 2022, 3:51 p.m. UTC | #2
On 4/4/2022 22:54, Denys Dmytriyenko wrote:
> On Wed, Mar 30, 2022 at 12:45:11PM +0200, Alessio Igor Bogani wrote:
>> Signed-off-by: Alessio Igor Bogani <alessio.bogani@elettra.eu>
> 
> Reviewed-by: Denys Dmytriyenko <denys@konsulko.com>

Signed-off-by: Ryan Eatmon <reatmon@ti.com>

Applied patch to master.

> 
>> ---
>>   .../recipes-bsp/wl18xx-fw/wl18xx-fw_8.9.0.0.86.bb         | 8 ++++++--
>>   1 file changed, 6 insertions(+), 2 deletions(-)
>>
>> diff --git a/meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw_8.9.0.0.86.bb b/meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw_8.9.0.0.86.bb
>> index 48b500a8..09968993 100644
>> --- a/meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw_8.9.0.0.86.bb
>> +++ b/meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw_8.9.0.0.86.bb
>> @@ -19,7 +19,11 @@ do_compile() {
>>   }
>>   
>>   do_install() {
>> -    oe_runmake 'DEST_DIR=${D}' install
>> +    if ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','true','false',d)}; then
>> +        oe_runmake 'DEST_DIR=${D}/usr' install
>> +    else
>> +        oe_runmake 'DEST_DIR=${D}' install
>> +    fi
>>   }
>>   
>> -FILES:${PN} = "/lib/firmware/ti-connectivity/*"
>> +FILES:${PN} = "${nonarch_base_libdir}/firmware/ti-connectivity/*"
>> -- 
>> 2.17.1
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#14590): https://lists.yoctoproject.org/g/meta-ti/message/14590
>> Mute This Topic: https://lists.yoctoproject.org/mt/90128496/6551054
>> Group Owner: meta-ti+owner@lists.yoctoproject.org
>> Unsubscribe: https://lists.yoctoproject.org/g/meta-ti/unsub [reatmon@ti.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>

Patch

diff --git a/meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw_8.9.0.0.86.bb b/meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw_8.9.0.0.86.bb
index 48b500a8..09968993 100644
--- a/meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw_8.9.0.0.86.bb
+++ b/meta-ti-extras/recipes-bsp/wl18xx-fw/wl18xx-fw_8.9.0.0.86.bb
@@ -19,7 +19,11 @@  do_compile() {
 }
 
 do_install() {
-    oe_runmake 'DEST_DIR=${D}' install
+    if ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','true','false',d)}; then
+        oe_runmake 'DEST_DIR=${D}/usr' install
+    else
+        oe_runmake 'DEST_DIR=${D}' install
+    fi
 }
 
-FILES:${PN} = "/lib/firmware/ti-connectivity/*"
+FILES:${PN} = "${nonarch_base_libdir}/firmware/ti-connectivity/*"