[meta-python] python3-evdev: fix host header contamination

Message ID 20220330072258.GD52115@codepurple
State Under Review
Headers show
Series [meta-python] python3-evdev: fix host header contamination | expand

Commit Message

S. Lockwood-Childs March 30, 2022, 7:22 a.m. UTC
The attempt to pass in correct headers was being ignored,
because it never got updated after distutils class was removed.
Switch to SETUPTOOLS_BUILD_ARGS, which setuptools3 class does
pay attention to.

Signed-off-by: S. Lockwood-Childs <sjl@vctlabs.com>
---
 meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb b/meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb
index 97a8aedd7..ca324c9ae 100644
--- a/meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb
+++ b/meta-python/recipes-devtools/python/python3-evdev_1.4.0.bb
@@ -11,7 +11,7 @@  do_compile:prepend() {
     rm -rf ${S}/evdev/ecodes.c
 }
 
-DISTUTILS_BUILD_ARGS = "build_ecodes --evdev-headers ${STAGING_DIR_TARGET}/usr/include/linux/input.h:${STAGING_DIR_TARGET}/usr/include/linux/input-event-codes.h"
+SETUPTOOLS_BUILD_ARGS = "build_ecodes --evdev-headers ${STAGING_DIR_TARGET}/usr/include/linux/input.h:${STAGING_DIR_TARGET}/usr/include/linux/input-event-codes.h"
 
 RDEPENDS:${PN} += "\
     ${PYTHON_PN}-ctypes \