Patchwork qtwebkit-examples: add missing RDEPENDS for qmlplugins

login
register
mail settings
Submitter Nicolas Dechesne
Date Oct. 22, 2013, 3:38 p.m.
Message ID <1382456281-16216-1-git-send-email-nicolas.dechesne@linaro.org>
Download mbox | patch
Permalink /patch/60385/
State Accepted, archived
Headers show

Comments

Nicolas Dechesne - Oct. 22, 2013, 3:38 p.m.
Some examples require qtwebkit-qmlplugins (flickerview, youtubeview),
and this dependency is not automatically added. Without this patch,
and without manually adding qtwekbit-qmlplugins, we get errors like
this:

qrc:///flickrview.qml:42:1: module "QtWebKit" is not installed

Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org>
---
 recipes-qt/qt5/qtwebkit-examples.inc | 1 +
 1 file changed, 1 insertion(+)
Nicolas Dechesne - Oct. 22, 2013, 3:50 p.m.
On Tue, Oct 22, 2013 at 5:38 PM, Nicolas Dechesne
<nicolas.dechesne@linaro.org> wrote:
> Some examples require qtwebkit-qmlplugins (flickerview, youtubeview),
> and this dependency is not automatically added. Without this patch,
> and without manually adding qtwekbit-qmlplugins, we get errors like
> this:
>
> qrc:///flickrview.qml:42:1: module "QtWebKit" is not installed
>
> Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org>
> ---

hmm. sorry, i messed up with my git alias and with --subject-prefix...
the subject i meant to have for this email is

[meta-qt5 master&dora][PATCH] qtwebkit-examples: add missing RDEPENDS
for qmlplugins

let me know if i need to resend. the key thing here is that I'd like
this patch to be applied on master and dora branch.

thanks
Martin Jansa - Oct. 22, 2013, 9:31 p.m.
It's OK, but it will take a while until I'm back to actually merge it.


On Tue, Oct 22, 2013 at 4:50 PM, Nicolas Dechesne <
nicolas.dechesne@linaro.org> wrote:

> On Tue, Oct 22, 2013 at 5:38 PM, Nicolas Dechesne
> <nicolas.dechesne@linaro.org> wrote:
> > Some examples require qtwebkit-qmlplugins (flickerview, youtubeview),
> > and this dependency is not automatically added. Without this patch,
> > and without manually adding qtwekbit-qmlplugins, we get errors like
> > this:
> >
> > qrc:///flickrview.qml:42:1: module "QtWebKit" is not installed
> >
> > Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org>
> > ---
>
> hmm. sorry, i messed up with my git alias and with --subject-prefix...
> the subject i meant to have for this email is
>
> [meta-qt5 master&dora][PATCH] qtwebkit-examples: add missing RDEPENDS
> for qmlplugins
>
> let me know if i need to resend. the key thing here is that I'd like
> this patch to be applied on master and dora branch.
>
> thanks
>
Nicolas Dechesne - Oct. 23, 2013, 7:54 a.m.
On Tue, Oct 22, 2013 at 11:31 PM, Martin Jansa <martin.jansa@gmail.com> wrote:
> It's OK, but it will take a while until I'm back to actually merge it.

ok. no hurry... it's a patch for a minor issue ;-)
thx

Patch

diff --git a/recipes-qt/qt5/qtwebkit-examples.inc b/recipes-qt/qt5/qtwebkit-examples.inc
index 38b2a7c..50c28cd 100644
--- a/recipes-qt/qt5/qtwebkit-examples.inc
+++ b/recipes-qt/qt5/qtwebkit-examples.inc
@@ -9,3 +9,4 @@  SRC_URI += " \
 "
 
 DEPENDS += "qtwebkit"
+RDEPENDS_${PN}-examples += "qtwebkit-qmlplugins"