libdnf: Add a dependency on util-linux

Message ID 20220327014718.10627-1-pkj@axis.com
State Accepted, archived
Commit e9bbbe72221e56a82892981a5ff254e559795ac6
Headers show
Series libdnf: Add a dependency on util-linux | expand

Commit Message

Peter Kjellerstedt March 27, 2022, 1:47 a.m. UTC
This avoids the following configuration error:

  -- Checking for module 'smartcols'
  --   No package 'smartcols' found
  CMake Error at .../usr/share/cmake-3.22/Modules/FindPkgConfig.cmake:603 (message):
   A required package was not found

which happens if glib-2.0 is configured without the libmount
PACKAGECONFIG that otherwise depends on util-linux.

Signed-off-by: Peter Kjellerstedt <pkj@axis.com>
---
 meta/recipes-devtools/libdnf/libdnf_0.66.0.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/meta/recipes-devtools/libdnf/libdnf_0.66.0.bb b/meta/recipes-devtools/libdnf/libdnf_0.66.0.bb
index 1bfe901c8a..2558f96851 100644
--- a/meta/recipes-devtools/libdnf/libdnf_0.66.0.bb
+++ b/meta/recipes-devtools/libdnf/libdnf_0.66.0.bb
@@ -18,7 +18,7 @@  UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>(?!4\.90)\d+(\.\d+)+)"
 
 S = "${WORKDIR}/git"
 
-DEPENDS = "glib-2.0 libsolv libcheck librepo rpm gtk-doc libmodulemd json-c swig-native"
+DEPENDS = "glib-2.0 libsolv libcheck librepo rpm gtk-doc libmodulemd json-c swig-native util-linux"
 
 inherit gtk-doc gobject-introspection cmake pkgconfig setuptools3-base