Patchwork [1/1] LSB 4.1 Library Check: fix unable to find library libqt-mt.so.3

login
register
mail settings
Submitter Hongxu Jia
Date Sept. 13, 2013, 12:02 p.m.
Message ID <a8596b9162366df23d07ad8206ddb0ce8863b699.1379073449.git.hongxu.jia@windriver.com>
Download mbox | patch
Permalink /patch/57961/
State New
Headers show

Comments

Hongxu Jia - Sept. 13, 2013, 12:02 p.m.
The libqt-mt is tested by lsb-dist-checker and lsb-test-desktop,
and it locates in meta-qt3 layer.
So if meta-qt3 is not added, there should be a warning to call
attention; if added, it will add libqt-mt to RDEPENDS.

[YOCTO #5153]

Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
---
 meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb | 10 ++++++++++
 1 file changed, 10 insertions(+)
Saul Wold - Sept. 13, 2013, 5:40 p.m.
On 09/13/2013 05:02 AM, Hongxu Jia wrote:
> The libqt-mt is tested by lsb-dist-checker and lsb-test-desktop,
> and it locates in meta-qt3 layer.
> So if meta-qt3 is not added, there should be a warning to call
> attention; if added, it will add libqt-mt to RDEPENDS.
>
> [YOCTO #5153]
>
> Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
> ---
>   meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb | 10 ++++++++++
>   1 file changed, 10 insertions(+)
>
> diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
> index 1c1a8d1..f83c5d7 100644
> --- a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
> +++ b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
> @@ -193,6 +193,15 @@ RDEPENDS_packagegroup-core-lsb-python = "\
>       python-misc \
>   "
>
> +def get_libqt3(d):
> +    if 'qt3' in d.getVar('BBFILE_COLLECTIONS') or "":
> +        return 'libqt-mt3'
> +
I think this should have a check for linuxstdbase so it does not print 
out at other times.

Sau!

> +    bb.warn('The meta-qt3 layer should be added, this layer provides Qt 3.x')
> +    bb.warn('libraries. Its intended use is for passing LSB tests as Qt3 is')
> +    bb.warn('a requirement for LSB')
> +    return ''
> +
>   SUMMARY_packagegroup-core-lsb-desktop = "LSB Desktop"
>   DESCRIPTION_packagegroup-core-lsb-desktop = "Packages required to support libraries \
>       specified in the LSB Desktop specification"
> @@ -221,6 +230,7 @@ RDEPENDS_packagegroup-core-lsb-desktop = "\
>       atk \
>       libasound \
>       ${@base_contains("DISTRO_FEATURES", "opengl", "libqtopengl4", "", d)} \
> +    ${@get_libqt3(d)} \
>   "
>
>   RDEPENDS_packagegroup-core-lsb-runtime-add = "\
>

Patch

diff --git a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
index 1c1a8d1..f83c5d7 100644
--- a/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
+++ b/meta/recipes-extended/packagegroups/packagegroup-core-lsb.bb
@@ -193,6 +193,15 @@  RDEPENDS_packagegroup-core-lsb-python = "\
     python-misc \
 "
 
+def get_libqt3(d):
+    if 'qt3' in d.getVar('BBFILE_COLLECTIONS') or "":
+        return 'libqt-mt3'
+
+    bb.warn('The meta-qt3 layer should be added, this layer provides Qt 3.x')
+    bb.warn('libraries. Its intended use is for passing LSB tests as Qt3 is')
+    bb.warn('a requirement for LSB')
+    return ''
+
 SUMMARY_packagegroup-core-lsb-desktop = "LSB Desktop"
 DESCRIPTION_packagegroup-core-lsb-desktop = "Packages required to support libraries \
     specified in the LSB Desktop specification"
@@ -221,6 +230,7 @@  RDEPENDS_packagegroup-core-lsb-desktop = "\
     atk \
     libasound \
     ${@base_contains("DISTRO_FEATURES", "opengl", "libqtopengl4", "", d)} \
+    ${@get_libqt3(d)} \
 "
 
 RDEPENDS_packagegroup-core-lsb-runtime-add = "\