[3/5,meta-python] python3-cachetools: upgrade 4.2.4 -> 5.0.0

Message ID 1648113480-29846-3-git-send-email-xuhuan.fnst@fujitsu.com
State New
Headers show
Series [1/5,meta-python] python3-alembic: upgrade 1.7.6 -> 1.7.7 | expand

Commit Message

XU Huan March 24, 2022, 9:17 a.m. UTC
From: Xu Huan <xuhuan.fnst@fujitsu.com>

changelog:
===============================================================================
-Require Python 3.7 or later (breaking change).
-Remove deprecated submodules (breaking change).

The cache, fifo, lfu, lru, mru, rr and ttl submodules have been deleted.
Therefore, statements like from cachetools.ttl import TTLCache will no longer
work. Use from cachetools import TTLCacheinstead.

-Pass self to @cachedmethod key function (breaking change).

The key function passed to the @cachedmethod decorator is now called as key
(self, *args, **kwargs).
The default key function has been changed to ignore its first argument, so
this should only affect applications using custom key functions with the
@cachedmethod decorator.

-Change exact time of expiration in TTLCache (breaking change).

TTLCache items now get expired if their expiration time is less than or equal
to timer(). For applications using the default timer(), this should be barely
noticable, but it may affect the use of custom timers with larger tick
intervals. Note that this also implies that a TTLCache with ttl=0 can no longer
hold any items, since they will expire immediately.

-Change Cache.__repr__() format (breaking change).

String representations of cache instances now use a more compact and efficient
format, e.g.LRUCache({1: 1, 2: 2}, maxsize=10, currsize=2)

-Add TLRU cache implementation.
-Documentation improvements.

Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com>
---
 ...{python3-cachetools_4.2.4.bb => python3-cachetools_5.0.0.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-cachetools_4.2.4.bb => python3-cachetools_5.0.0.bb} (89%)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-cachetools_4.2.4.bb b/meta-python/recipes-devtools/python/python3-cachetools_5.0.0.bb
similarity index 89%
rename from meta-python/recipes-devtools/python/python3-cachetools_4.2.4.bb
rename to meta-python/recipes-devtools/python/python3-cachetools_5.0.0.bb
index bf225e60e0..f2974f7e34 100644
--- a/meta-python/recipes-devtools/python/python3-cachetools_4.2.4.bb
+++ b/meta-python/recipes-devtools/python/python3-cachetools_5.0.0.bb
@@ -27,6 +27,6 @@  do_install_ptest() {
 	cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
 }
 
-SRC_URI[sha256sum] = "89ea6f1b638d5a73a4f9226be57ac5e4f399d22770b92355f92dcb0f7f001693"
+SRC_URI[sha256sum] = "486471dfa8799eb7ec503a8059e263db000cdda20075ce5e48903087f79d5fd6"
 
 BBCLASSEXTEND = "native nativesdk"