Patchwork dbus-ptest: fix populate_sdk error

login
register
mail settings
Submitter Maxin B. John
Date Sept. 9, 2013, 5:47 p.m.
Message ID <1378748850-41558-1-git-send-email-maxin.john@enea.com>
Download mbox | patch
Permalink /patch/57713/
State Accepted
Commit a59b7341d136bf8ee4a22c2968ca95dc17be3947
Headers show

Comments

Maxin B. John - Sept. 9, 2013, 5:47 p.m.
From: "Maxin B. John" <maxin.john@enea.com>

 When we enable "ptest", populate_sdk fails with the following error:
 # bitbake core-image-minimal -c populate_sdk
 ..
 Collected errors:
  * satisfy_dependencies_for: Cannot satisfy the following dependencies
    for dbus-ptest-dev:
  *    dbus-ptest (= 1.6.10-r0) *
  * opkg_install_cmd: Cannot install package dbus-ptest-dev.

Disable that dependency.

Signed-off-by: Maxin B. John <maxin.john@enea.com>
---
 meta/recipes-core/dbus/dbus-ptest_1.6.10.bb |    1 +
 1 file changed, 1 insertion(+)

Patch

diff --git a/meta/recipes-core/dbus/dbus-ptest_1.6.10.bb b/meta/recipes-core/dbus/dbus-ptest_1.6.10.bb
index a8e82ef..84ed287 100644
--- a/meta/recipes-core/dbus/dbus-ptest_1.6.10.bb
+++ b/meta/recipes-core/dbus/dbus-ptest_1.6.10.bb
@@ -8,6 +8,7 @@  LIC_FILES_CHKSUM = "file://COPYING;md5=10dded3b58148f3f1fd804b26354af3e \
 DEPENDS = "python-pygobject dbus dbus-glib"
 
 RDEPENDS_${PN} += "make"
+RDEPENDS_${PN}-dev = ""
 
 SRC_URI = "http://dbus.freedesktop.org/releases/dbus/dbus-${PV}.tar.gz \
            file://tmpdir.patch \