Patchwork [bitbake-devel,0/1] check whether multiple versions of the same PN are due

login
register
mail settings
Submitter Robert Yang
Date Sept. 2, 2013, 1:47 p.m.
Message ID <cover.1378129369.git.liezhi.yang@windriver.com>
Download mbox
Permalink /patch/57229/
State New
Headers show

Pull-request

git://git.pokylinux.org/poky-contrib robert/same_pn

Comments

Robert Yang - Sept. 2, 2013, 1:47 p.m.
This is used for fixing such a race issue:

$ bitbake make-3.81 make-3.82

There would be unexpected errors in the past, now, it will print the error
message and exit:

ERROR: Multiple .bb files are due to be built which each provide make (xxx)
 This usually means one provides something the other doesn't and should.
ERROR: Multiple versions of make are due to be built.

Summary: There were 2 ERROR messages shown, returning a non-zero exit code.

// Robert

The following changes since commit c7994f83baa678a4670472e1f037bfc16cb1e3be:

  bitbake: runqueue: Fix scenequeue to pass file descriptors, not a float (2013-09-02 09:16:24 +0100)

are available in the git repository at:

  git://git.pokylinux.org/poky-contrib robert/same_pn
  http://git.pokylinux.org/cgit.cgi/poky-contrib/log/?h=robert/same_pn

Robert Yang (1):
  runqueue.py: check whether multiple versions of the same PN are due to be built

 bitbake/lib/bb/runqueue.py |   12 +++++++++++-
 1 file changed, 11 insertions(+), 1 deletion(-)