[meta-ti,dunfell,v2,3/7] recipes: Pick up correct image and build DM to boot images

Message ID 20220322181558.20684-4-reatmon@ti.com
State Superseded
Headers show
Series Adding support for am62xx | expand

Commit Message

Ryan Eatmon March 22, 2022, 6:15 p.m. UTC
From: Nishanth Menon <nm@ti.com>

Make sure we have bootable wic images.

Signed-off-by: Nishanth Menon <nm@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
---
 recipes-bsp/u-boot/u-boot-ti.inc           | 1 +
 recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb | 2 +-
 2 files changed, 2 insertions(+), 1 deletion(-)

Comments

Denys Dmytriyenko March 22, 2022, 8:02 p.m. UTC | #1
On Tue, Mar 22, 2022 at 01:15:54PM -0500, Ryan Eatmon via lists.yoctoproject.org wrote:
> From: Nishanth Menon <nm@ti.com>
> 
> Make sure we have bootable wic images.

First of all, can this be squashed with the previous patch?


> Signed-off-by: Nishanth Menon <nm@ti.com>
> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
> ---
>  recipes-bsp/u-boot/u-boot-ti.inc           | 1 +
>  recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb | 2 +-
>  2 files changed, 2 insertions(+), 1 deletion(-)
> 
> diff --git a/recipes-bsp/u-boot/u-boot-ti.inc b/recipes-bsp/u-boot/u-boot-ti.inc
> index 6098f989..231b7647 100644
> --- a/recipes-bsp/u-boot/u-boot-ti.inc
> +++ b/recipes-bsp/u-boot/u-boot-ti.inc
> @@ -41,6 +41,7 @@ PACKAGECONFIG[dm] = "DM=${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/pdk-i
>  
>  PACKAGECONFIG_append_aarch64 = " atf optee"
>  PACKAGECONFIG_append_j7 = " dm"
> +PACKAGECONFIG_append_am62xx = " dm"
>  
>  COMPATIBLE_MACHINE = "(ti-soc)"
>  
> diff --git a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
> index 431c13da..4cd08a36 100644
> --- a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
> +++ b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
> @@ -19,7 +19,7 @@ PLAT_SFX_j7200-hs-evm = "j7200"
>  PLAT_SFX_j721s2-evm = "j721s2"
>  PLAT_SFX_am65xx = "am65xx"
>  PLAT_SFX_am64xx = "am64xx"
> -PLAT_SFX_am62xx-evm = "am62xx"
> +PLAT_SFX_am62xx-evm = "am62x"

am62xx SOC_FAMILY in the override?


>  FILESEXTRAPATHS_prepend := "${METATIBASE}/recipes-bsp/ti-sci-fw/files/:"
>  require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
> -- 
> 2.17.1
>

Patch

diff --git a/recipes-bsp/u-boot/u-boot-ti.inc b/recipes-bsp/u-boot/u-boot-ti.inc
index 6098f989..231b7647 100644
--- a/recipes-bsp/u-boot/u-boot-ti.inc
+++ b/recipes-bsp/u-boot/u-boot-ti.inc
@@ -41,6 +41,7 @@  PACKAGECONFIG[dm] = "DM=${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/pdk-i
 
 PACKAGECONFIG_append_aarch64 = " atf optee"
 PACKAGECONFIG_append_j7 = " dm"
+PACKAGECONFIG_append_am62xx = " dm"
 
 COMPATIBLE_MACHINE = "(ti-soc)"
 
diff --git a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
index 431c13da..4cd08a36 100644
--- a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
+++ b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
@@ -19,7 +19,7 @@  PLAT_SFX_j7200-hs-evm = "j7200"
 PLAT_SFX_j721s2-evm = "j721s2"
 PLAT_SFX_am65xx = "am65xx"
 PLAT_SFX_am64xx = "am64xx"
-PLAT_SFX_am62xx-evm = "am62xx"
+PLAT_SFX_am62xx-evm = "am62x"
 
 FILESEXTRAPATHS_prepend := "${METATIBASE}/recipes-bsp/ti-sci-fw/files/:"
 require recipes-bsp/ti-linux-fw/ti-linux-fw.inc