Patchwork pulseaudio: Fix up configure options and use gtk+3

login
register
mail settings
Submitter Saul Wold
Date Aug. 22, 2013, 7:56 p.m.
Message ID <1377201393-16778-1-git-send-email-sgw@linux.intel.com>
Download mbox | patch
Permalink /patch/56301/
State Accepted
Commit 2526a172bde60b2fa55e2d23a5169e44a5661e8d
Headers show

Comments

Saul Wold - Aug. 22, 2013, 7:56 p.m.
Pulseaudio 4.0 switch from gtk+ to gtk+3, a floating dependency
had occurred during a build which made me check into this.

Signed-off-by: Saul Wold <sgw@linux.intel.com>
---
 meta/recipes-multimedia/pulseaudio/pulseaudio.inc |   11 ++---------
 1 file changed, 2 insertions(+), 9 deletions(-)

Patch

diff --git a/meta/recipes-multimedia/pulseaudio/pulseaudio.inc b/meta/recipes-multimedia/pulseaudio/pulseaudio.inc
index f1b346c..afe8410 100644
--- a/meta/recipes-multimedia/pulseaudio/pulseaudio.inc
+++ b/meta/recipes-multimedia/pulseaudio/pulseaudio.inc
@@ -20,14 +20,7 @@  inherit autotools pkgconfig useradd gettext perlnative
 USE_NLS = "yes"
 
 EXTRA_OECONF = "\
-		--disable-lynx \
-		--disable-polkit \
-		--without-jack \
-		--with-glib \
-		--with-alsa \
-		--with-oss \
-		--without-hal \
-		--disable-hal \
+		--disable-hal-compat \
 		--disable-orc \
 		--enable-tcpwrap=no \
 		--with-access-group=audio \
@@ -44,7 +37,7 @@  PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '',
                    ${@base_contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)} \
                    ${@base_contains('DISTRO_FEATURES', 'x11', 'gtk x11', '', d)}"
 PACKAGECONFIG[bluez] = "--enable-bluez,--disable-bluez,bluez4 sbc"
-PACKAGECONFIG[gtk] = "--enable-gtk2,--disable-gtk2,gtk+"
+PACKAGECONFIG[gtk] = "--enable-gtk3,--disable-gtk3,gtk+3"
 PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd"
 PACKAGECONFIG[x11] = "--enable-x11,--disable-x11,virtual/libx11 libxtst libice libsm libxcb"
 PACKAGECONFIG[avahi] = "--enable-avahi,--disable-avahi,avahi"