Patchwork [11/11] package_ipk: Add support for PACKAGE_EXCLUDE

login
register
mail settings
Submitter Mark Hatle
Date Aug. 14, 2013, 8:30 p.m.
Message ID <1376512209-11622-12-git-send-email-mark.hatle@windriver.com>
Download mbox | patch
Permalink /patch/55645/
State Accepted
Commit 6d7f5581bbfaf174edb77d92846e720e8057481c
Headers show

Comments

Mark Hatle - Aug. 14, 2013, 8:30 p.m.
This uses the new --add-exclude arguments in opkg-cl, to list the excluded
packages.

If an excluded package is needed for the install to resolve,
an error will be generated.  Recommended packages will not
generate an error.

Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
---
 meta/classes/package_ipk.bbclass | 1 +
 1 file changed, 1 insertion(+)

Patch

diff --git a/meta/classes/package_ipk.bbclass b/meta/classes/package_ipk.bbclass
index 69a6d95..68ffc62 100644
--- a/meta/classes/package_ipk.bbclass
+++ b/meta/classes/package_ipk.bbclass
@@ -12,6 +12,7 @@  OPKGBUILDCMD ??= "opkg-build"
 
 OPKG_ARGS = "-f $INSTALL_CONF_IPK -o $INSTALL_ROOTFS_IPK --force_postinstall --prefer-arch-to-version"
 OPKG_ARGS += "${@['', '--no-install-recommends'][d.getVar("NO_RECOMMENDATIONS", True) == "1"]}"
+OPKG_ARGS += "${@['', '--add-exclude ' + ' --add-exclude '.join((d.getVar('PACKAGE_EXCLUDE', True) or "").split())][(d.getVar("PACKAGE_EXCLUDE", True) or "") != ""]}"
 
 OPKGLIBDIR = "${localstatedir}/lib"