[dunfell/master,V2,10/12] recipes-core: images: Introduce tisdk-bootstrap-image

Message ID 20220318143735.17642-11-nm@ti.com
State Superseded
Delegated to: Ryan Eatmon
Headers show
Series recipes-core: Add a bootstrap Linux image | expand

Commit Message

Nishanth Menon March 18, 2022, 2:37 p.m. UTC
Lets introduce tisdk-bootstrap-image which now consists of a
completely bootable system with minimal initramfs that can be used
to boot up a system. We also will create a rootfs that matches with
the initramfs to allow users who use mmc and other boot media to have
access to the same debug tools for a new platform bringup

Signed-off-by: Nishanth Menon <nm@ti.com>
---
Changes since v1:
* review comments (s/kernel/kernel-base)

V1: https://lore.kernel.org/all/20220309021316.28370-7-nm@ti.com/
 .../images/tisdk-bootstrap-image.bb           | 20 +++++++++++++++++++
 1 file changed, 20 insertions(+)
 create mode 100644 meta-arago-distro/recipes-core/images/tisdk-bootstrap-image.bb

Patch

diff --git a/meta-arago-distro/recipes-core/images/tisdk-bootstrap-image.bb b/meta-arago-distro/recipes-core/images/tisdk-bootstrap-image.bb
new file mode 100644
index 000000000000..ce7a80c8a56e
--- /dev/null
+++ b/meta-arago-distro/recipes-core/images/tisdk-bootstrap-image.bb
@@ -0,0 +1,20 @@ 
+# Arago TI SDK bootstrap image usable for board bringup
+#
+# This image is a complete package containing a rootfs and an initrd
+# with platform test utilities that can be used for new platform
+# bringup activities. Typically one would use the bootstrap initrd
+# till the storage media access is debugged, following which one would
+# switch over to using the storage media of choice with the same content.
+
+require arago-tiny-image.inc
+
+ARAGO_BOOTSTRAP_IMAGE_EXTRA_INSTALL ?= ""
+
+IMAGE_INSTALL += " \
+	packagegroup-arago-bootstrap \
+	kernel-base \
+	bootstrap-initrd \
+	${ARAGO_BOOTSTRAP_IMAGE_EXTRA_INSTALL} \
+"
+
+export IMAGE_BASENAME = "tisdk-bootstrap-image"