python3-lz4: use system lz4 library

Message ID 20220317191316.411114-1-ross.burton@arm.com
State Under Review
Headers show
Series python3-lz4: use system lz4 library | expand

Commit Message

Ross Burton March 17, 2022, 7:13 p.m. UTC
Instead of using the copy of lz4 that is embedded in the python3-lz4
source code, use the system lz4 library.

python3-lz4: PKGSIZE changed from 718282 to 165043 (-77%)
python3-lz4: RDEPENDS: added "lz4 (['>= 1.9.3'])"

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Patch

diff --git a/meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb b/meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb
index 40b2186b2c..5e6741c680 100644
--- a/meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-lz4_4.0.0.bb
@@ -4,12 +4,13 @@  LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=6231efa4dd4811e62407314d90a57573"
 
 DEPENDS += " \
+    lz4 \
     ${PYTHON_PN}-setuptools-scm-native \
     ${PYTHON_PN}-pkgconfig-native \
 "
 
 SRC_URI[sha256sum] = "57c5dfd3b7dae833b0d2b2c1aafd7f9d0dfcab40683d183d010c67c9fd1beca3"
 
-inherit pypi setuptools_build_meta
+inherit pkgconfig pypi setuptools_build_meta
 
 BBCLASSEXTEND = "native nativesdk"