[1/1] arm-bsp/corstone1000: remove the need for meta-arm-image

Message ID 20220317161033.3099761-2-emekcan.aras@arm.com
State New
Headers show
Series arm-bsp/corstone1000: remove the need for meta-arm-image | expand

Commit Message

Emekcan Aras March 17, 2022, 4:10 p.m. UTC
From: Emekcan Aras <Emekcan.Aras@arm.com>

This commit remove meta-arm-image from the yml file and adds
necessary image configuration to meta-arm-bsp/recipes-bsp/images.

Signed-off-by: Emekcan Aras <emekcan.aras@arm.com>
---
 ci/corstone1000-common.yml                    | 10 ++-----
 .../recipes-bsp/images/corstone1000-image.bb  | 11 ++++++++
 .../images/corstone1000-initramfs-image.bb    | 28 +++++++++++++++++++
 .../wic/corstone1000-image.corstone1000.wks   | 15 ++++++++++
 4 files changed, 57 insertions(+), 7 deletions(-)
 create mode 100644 meta-arm-bsp/recipes-bsp/images/corstone1000-image.bb
 create mode 100644 meta-arm-bsp/recipes-bsp/images/corstone1000-initramfs-image.bb
 create mode 100644 meta-arm-bsp/wic/corstone1000-image.corstone1000.wks

Patch

diff --git a/ci/corstone1000-common.yml b/ci/corstone1000-common.yml
index faa1d08..6599d97 100644
--- a/ci/corstone1000-common.yml
+++ b/ci/corstone1000-common.yml
@@ -3,15 +3,11 @@  header:
   includes:
     - ci/base.yml
     - ci/meta-openembedded.yml
-
 local_conf_header:
-  image: |
-    INITRAMFS_IMAGE_BUNDLE = "0"
-    INITRAMFS_IMAGE:remove = "corstone1000-initramfs-image"
-    CORE_IMAGE_EXTRA_INSTALL += "optee-client"
-    CORE_IMAGE_EXTRA_INSTALL += "ffa-debugfs-mod"
+    perf: |
 
 distro: poky-tiny
 
 target:
-  - core-image-minimal
+  - perf
+  - corstone1000-image
diff --git a/meta-arm-bsp/recipes-bsp/images/corstone1000-image.bb b/meta-arm-bsp/recipes-bsp/images/corstone1000-image.bb
new file mode 100644
index 0000000..d91d457
--- /dev/null
+++ b/meta-arm-bsp/recipes-bsp/images/corstone1000-image.bb
@@ -0,0 +1,11 @@ 
+SUMARY = "Corstone1000 platform Image"
+DESCRIPTION = "This is the main image which is the container of all the binaries \
+               generated for the Corstone1000 platform."
+LICENSE = "MIT"
+
+inherit image
+inherit wic_nopt
+
+PACKAGE_INSTALL = ""
+
+IMAGE_FSTYPES += "wic wic.nopt"
diff --git a/meta-arm-bsp/recipes-bsp/images/corstone1000-initramfs-image.bb b/meta-arm-bsp/recipes-bsp/images/corstone1000-initramfs-image.bb
new file mode 100644
index 0000000..a11de1e
--- /dev/null
+++ b/meta-arm-bsp/recipes-bsp/images/corstone1000-initramfs-image.bb
@@ -0,0 +1,28 @@ 
+SUMARY = "Corstone1000 platform Initramfs Image"
+DESCRIPTION = "This is the main Linux image which includes an initramfs kernel/rootfs bundle."
+
+LICENSE = "MIT"
+
+IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+
+inherit core-image
+
+# By default all basic packages required for a bootable system are installed
+# by core-image . These packages are: packagegroup-core-boot and
+# packagegroup-base-extended
+
+inherit image-buildinfo
+
+IMAGE_FEATURES += "debug-tweaks"
+
+#package management is not supported in corstone1000
+IMAGE_FEATURES:remove = "package-management"
+
+# all optee packages
+IMAGE_INSTALL += "optee-client"
+
+# FF-A Debugfs driver
+IMAGE_INSTALL += "ffa-debugfs-mod"
+
+# psa-arch-tests linux userspace application
+IMAGE_INSTALL += "secure-partitions-psa-api-tests"
diff --git a/meta-arm-bsp/wic/corstone1000-image.corstone1000.wks b/meta-arm-bsp/wic/corstone1000-image.corstone1000.wks
new file mode 100644
index 0000000..c58d7d6
--- /dev/null
+++ b/meta-arm-bsp/wic/corstone1000-image.corstone1000.wks
@@ -0,0 +1,15 @@ 
+# WIC partitioning for corstone1000
+# Layout and maximum sizes (to be defined):
+#
+
+part --source rawcopy --sourceparams="file=bl2_signed.bin" --align 1 --no-table --fixed-size 100k
+part --source rawcopy --sourceparams="file=bl2_signed.bin" --align 1 --no-table --fixed-size 100k
+
+part --source rawcopy --sourceparams="file=tfm_s_signed.bin" --align 1 --no-table --fixed-size 376k
+part --source rawcopy --sourceparams="file=tfm_s_signed.bin" --align 1 --no-table --fixed-size 376k
+
+# Rawcopy of the FIP binary
+part --source rawcopy --sourceparams="file=signed_fip-corstone1000.bin" --align 1 --no-table --fixed-size 2
+
+# Rawcopy of kernel with initramfs
+part --source rawcopy --sourceparams="file=Image-initramfs-${MACHINE}.bin" --no-table --fixed-size 12