[22/26] python3-sphinx: Add a new recipe

Message ID 20220317115700.993924-23-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit 15b623e74846b7c7cd2f5e5b309e1379af86cf3f
Headers show
Series Add support for sphinx documentation generation | expand

Commit Message

Richard Purdie March 17, 2022, 11:56 a.m. UTC
Needed to build the sphinx based yocto-docs

Based on a recipe from Armin Kuster <akuster808@gmail.com>

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 .../python/python3-sphinx_4.4.0.bb            | 22 +++++++++++++++++++
 1 file changed, 22 insertions(+)
 create mode 100644 meta/recipes-devtools/python/python3-sphinx_4.4.0.bb

Patch

diff --git a/meta/recipes-devtools/python/python3-sphinx_4.4.0.bb b/meta/recipes-devtools/python/python3-sphinx_4.4.0.bb
new file mode 100644
index 00000000000..225e7737f60
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-sphinx_4.4.0.bb
@@ -0,0 +1,22 @@ 
+DESCRIPTION = "Python documentation generator"
+HOMEPAGE = "http://sphinx-doc.org/"
+SECTION = "devel/python"
+LICENSE = "BSD-2-Clause & MIT & BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=de4349dda741c550eb8b20f6b92f38d7"
+
+PYPI_PACKAGE = "Sphinx"
+
+SRC_URI[sha256sum] = "6caad9786055cb1fa22b4a365c1775816b876f91966481765d7d50e9f0dd35cc"
+
+inherit setuptools3 pypi
+
+RDEPENDS:${PN} = "\
+    python3-packaging python3-docutils python3-requests \
+    python3-imagesize python3-alabaster python3-jinja2 \
+    python3-babel python3-pygments python3-snowballstemmer \
+    python3-sphinxcontrib-applehelp python3-sphinxcontrib-devhelp \
+    python3-sphinxcontrib-jsmath python3-sphinxcontrib-htmlhelp \
+    python3-sphinxcontrib-serializinghtml python3-sphinxcontrib-qthelp \
+    "
+
+BBCLASSEXTEND = "native nativesdk"