[2/8] classes/python_pep517: implement a standard do_compile

Message ID 20220316183243.876234-2-ross.burton@arm.com
State Accepted, archived
Commit 862f68f3a05ce48834f4903d9f9a213684061779
Headers show
Series [1/8] python3-packaging: remove duplicate python3-setuptools-native DEPENDS | expand

Commit Message

Ross Burton March 16, 2022, 6:32 p.m. UTC
As all PEP517-compliant build systems have a universal API, we can ask
that users of this class set PEP517_BUILD_API to the class that implements
this API and call it ourselves, instead of users needing to implement
near-identical do_compile tasks themselves.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/classes/python_pep517.bbclass | 13 ++++++++++++-
 1 file changed, 12 insertions(+), 1 deletion(-)

Patch

diff --git a/meta/classes/python_pep517.bbclass b/meta/classes/python_pep517.bbclass
index ac7c1e44c6..83c6dcb5c7 100644
--- a/meta/classes/python_pep517.bbclass
+++ b/meta/classes/python_pep517.bbclass
@@ -6,6 +6,9 @@  DEPENDS:append = " python3-installer-native"
 # Where to execute the build process from
 PEP517_SOURCE_PATH ?= "${S}"
 
+# The PEP517 build API entry point
+PEP517_BUILD_API ?= "unset"
+
 # The directory where wheels should be written too. Build classes
 # will ideally [cleandirs] this but we don't do that here in case
 # a recipe wants to install prebuilt wheels.
@@ -16,6 +19,14 @@  PEP517_INSTALL_PYTHON:class-native = "nativepython3"
 
 INSTALL_WHEEL_COMPILE_BYTECODE ?= "--compile-bytecode=0"
 
+# When we have Python 3.11 we can parse pyproject.toml to determine the build
+# API entry point directly
+python_pep517_do_compile () {
+    cd ${PEP517_SOURCE_PATH}
+    nativepython3 -c "import ${PEP517_BUILD_API} as api; api.build_wheel('${PEP517_WHEEL_PATH}')"
+}
+do_compile[cleandirs] += "${PEP517_WHEEL_PATH}"
+
 python_pep517_do_install () {
     COUNT=$(find ${PEP517_WHEEL_PATH} -name '*.whl' | wc -l)
     if test $COUNT -eq 0; then
@@ -33,4 +44,4 @@  python_pep517_do_bootstrap_install () {
     unzip -d ${D}${PYTHON_SITEPACKAGES_DIR} ${PEP517_WHEEL_PATH}/*.whl
 }
 
-EXPORT_FUNCTIONS do_install
+EXPORT_FUNCTIONS do_compile do_install