libucontext: Upgrade to 1.2 release

Message ID 20220316173741.3089169-1-raj.khem@gmail.com
State Accepted, archived
Commit d51592e4eb2bc951f0c33a6e69be22aa8ea84d6f
Headers show
Series libucontext: Upgrade to 1.2 release | expand

Commit Message

Khem Raj March 16, 2022, 5:37 p.m. UTC
License-Update: Copyright years changed [1]

aarch64 implements simd register save/restore

loongarch64 supported added

[1] https://github.com/kaniini/libucontext/commit/9943d4f5fc31a23a591e74caf24ce4effd887501
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../0001-meson-Add-option-to-pass-cpu.patch   | 49 -------------------
 ...{libucontext_git.bb => libucontext_1.2.bb} |  6 +--
 2 files changed, 2 insertions(+), 53 deletions(-)
 delete mode 100644 meta/recipes-core/musl/libucontext/0001-meson-Add-option-to-pass-cpu.patch
 rename meta/recipes-core/musl/{libucontext_git.bb => libucontext_1.2.bb} (89%)

Patch

diff --git a/meta/recipes-core/musl/libucontext/0001-meson-Add-option-to-pass-cpu.patch b/meta/recipes-core/musl/libucontext/0001-meson-Add-option-to-pass-cpu.patch
deleted file mode 100644
index 1fdc9f739d9..00000000000
--- a/meta/recipes-core/musl/libucontext/0001-meson-Add-option-to-pass-cpu.patch
+++ /dev/null
@@ -1,49 +0,0 @@ 
-From a530eed9e7e6872e10fe92efaf1e9739471c30ca Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sun, 30 May 2021 08:30:28 -0700
-Subject: [PATCH] meson: Add option to pass cpu
-
-This helps with cross compile setups, where host_cpu != target_cpu
-therefore detecting it on the fly will end up with wrong cpu to build
-for
-
-Upstream-Status: Submitted [https://github.com/kaniini/libucontext/pull/28]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- meson.build       | 6 +++++-
- meson_options.txt | 4 +++-
- 2 files changed, 8 insertions(+), 2 deletions(-)
-
-diff --git a/meson.build b/meson.build
-index e863780..2b4bdbd 100644
---- a/meson.build
-+++ b/meson.build
-@@ -6,7 +6,11 @@ project(
-   version : run_command('head', files('VERSION')).stdout()
- )
- 
--cpu = host_machine.cpu_family()
-+cpu = get_option('cpu')
-+if cpu == ''
-+  cpu = host_machine.cpu_family()
-+endif
-+
- if cpu == 'sh4'
-   cpu = 'sh'
- endif
-diff --git a/meson_options.txt b/meson_options.txt
-index d4201d1..864d83c 100644
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -1,4 +1,6 @@
- option('freestanding', type : 'boolean', value : false,
-        description: 'Do not use system headers')
- option('export_unprefixed', type : 'boolean', value : true,
--       description: 'Export POSIX 2004 ucontext names as alises')
-\ No newline at end of file
-+       description: 'Export POSIX 2004 ucontext names as alises')
-+option('cpu', type : 'string', value : '',
-+       description: 'Target CPU architecture for cross compile')
--- 
-2.31.1
-
diff --git a/meta/recipes-core/musl/libucontext_git.bb b/meta/recipes-core/musl/libucontext_1.2.bb
similarity index 89%
rename from meta/recipes-core/musl/libucontext_git.bb
rename to meta/recipes-core/musl/libucontext_1.2.bb
index 9061cf0b1b5..4e34df14392 100644
--- a/meta/recipes-core/musl/libucontext_git.bb
+++ b/meta/recipes-core/musl/libucontext_1.2.bb
@@ -4,14 +4,12 @@ 
 SUMMARY = "ucontext implementation featuring glibc-compatible ABI"
 HOMEPAGE = "https://github.com/kaniini/libucontext"
 LICENSE = "ISC"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=6eed01fa0e673c76f5a5715438f65b1d"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ebea527af0602d509b7f4c49533fb1bd"
 SECTION = "libs"
 DEPENDS = ""
 
-PV = "1.1+${SRCPV}"
-SRCREV = "335ee864ef6f4a5d4b525453fd9dbfb3507cfecc"
+SRCREV = "4dde3417b4bb4b1b1545bd913be337680b5e28c3"
 SRC_URI = "git://github.com/kaniini/libucontext;branch=master;protocol=https \
-           file://0001-meson-Add-option-to-pass-cpu.patch \
            "
 
 S = "${WORKDIR}/git"