Patchwork [RFC,2/4] package.bbclass: show warning when package is trying to provide already provided shlib

login
register
mail settings
Submitter Martin Jansa
Date July 6, 2013, 11:13 p.m.
Message ID <1373152387-19393-2-git-send-email-Martin.Jansa@gmail.com>
Download mbox | patch
Permalink /patch/53237/
State New
Headers show

Comments

Martin Jansa - July 6, 2013, 11:13 p.m.
* move read_shlib_providers before registering package as provider
  and don't change provider if it already exists, show warning instead

[YOCTO #4628]

Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
 meta/classes/package.bbclass | 11 +++++++++--
 1 file changed, 9 insertions(+), 2 deletions(-)
Martin Jansa - July 10, 2013, 11:51 a.m.
On Sun, Jul 07, 2013 at 01:13:05AM +0200, Martin Jansa wrote:
> * move read_shlib_providers before registering package as provider
>   and don't change provider if it already exists, show warning instead
> 
> [YOCTO #4628]
> 
> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>

List of WARNINGs about multiple providers for the same shlib from world
build follows:

I'll take care of meta-efl recipes where modules.so is always installed
in separate directory and shouldn't be included in shlibs providers at
all.

WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-engine-gl-x11-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-engine-software-16-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-engine-software-16-x11-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-engine-software-x11-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-engine-wayland-shm-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-cserve2-bmp-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-cserve2-eet-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-cserve2-ico-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-cserve2-jpeg-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-cserve2-pmaps-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-cserve2-png-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-cserve2-psd-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-cserve2-tga-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-cserve2-tiff-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-cserve2-wbmp-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-cserve2-xpm-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-loader-bmp-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-loader-generic-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-loader-gif-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-loader-ico-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-loader-jpeg-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-loader-pmaps-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-loader-png-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-loader-psd-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-loader-tga-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-loader-tiff-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-loader-wbmp-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-loader-xpm-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-saver-jpeg-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-saver-png-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring evas-saver-tiff-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring emotion-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring elementary-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring elementary-tests-1.7.7 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring elementary-accessibility-1.7.7 trying to register the same
WARNING: gtk-immodule-am-et-2.24.18 is already registered as shlib provider for im-am-et.so, ignoring gtk3-immodule-am-et-3.8.2 trying to register the same
WARNING: gtk-immodule-cedilla-2.24.18 is already registered as shlib provider for im-cedilla.so, ignoring gtk3-immodule-cedilla-3.8.2 trying to register the same
WARNING: gtk-immodule-cyrillic-translit-2.24.18 is already registered as shlib provider for im-cyrillic-translit.so, ignoring gtk3-immodule-cyrillic-translit-3.8.2 trying to register the same
WARNING: gtk-immodule-inuktitut-2.24.18 is already registered as shlib provider for im-inuktitut.so, ignoring gtk3-immodule-inuktitut-3.8.2 trying to register the same
WARNING: gtk-immodule-ipa-2.24.18 is already registered as shlib provider for im-ipa.so, ignoring gtk3-immodule-ipa-3.8.2 trying to register the same
WARNING: gtk-immodule-multipress-2.24.18 is already registered as shlib provider for im-multipress.so, ignoring gtk3-immodule-multipress-3.8.2 trying to register the same
WARNING: gtk-immodule-thai-2.24.18 is already registered as shlib provider for im-thai.so, ignoring gtk3-immodule-thai-3.8.2 trying to register the same
WARNING: gtk-immodule-ti-er-2.24.18 is already registered as shlib provider for im-ti-er.so, ignoring gtk3-immodule-ti-er-3.8.2 trying to register the same
WARNING: gtk-immodule-ti-et-2.24.18 is already registered as shlib provider for im-ti-et.so, ignoring gtk3-immodule-ti-et-3.8.2 trying to register the same
WARNING: gtk-immodule-viqr-2.24.18 is already registered as shlib provider for im-viqr.so, ignoring gtk3-immodule-viqr-3.8.2 trying to register the same
WARNING: gtk-immodule-xim-2.24.18 is already registered as shlib provider for im-xim.so, ignoring gtk3-immodule-xim-3.8.2 trying to register the same
WARNING: gtk-printbackend-file-2.24.18 is already registered as shlib provider for libprintbackend-file.so, ignoring gtk3-printbackend-file-3.8.2 trying to register the same
WARNING: gtk-printbackend-lpr-2.24.18 is already registered as shlib provider for libprintbackend-lpr.so, ignoring gtk3-printbackend-lpr-3.8.2 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring e-wm-0.17.3 trying to register the same
WARNING: gstreamer-0.10.36 is already registered as shlib provider for libgstcoreelements.so, ignoring gstreamer1.0-1.0.7 trying to register the same
WARNING: xfce4-panel-plugin-launcher-4.10.1 is already registered as shlib provider for liblauncher.so, ignoring matchbox-panel-2-2.0+git3+26a3a67b41 trying to register the same
WARNING: xfce4-panel-plugin-systray-4.10.1 is already registered as shlib provider for libsystray.so, ignoring matchbox-panel-2-2.0+git3+26a3a67b41 trying to register the same
WARNING: xfce4-panel-plugin-clock-4.10.1 is already registered as shlib provider for libclock.so, ignoring matchbox-panel-2-2.0+git3+26a3a67b41 trying to register the same
WARNING: xfce4-panel-plugin-showdesktop-4.10.1 is already registered as shlib provider for libshowdesktop.so, ignoring matchbox-panel-2-2.0+git3+26a3a67b41 trying to register the same
WARNING: gst-plugins-base-adder-0.10.36 is already registered as shlib provider for libgstadder.so, ignoring gstreamer1.0-plugins-base-adder-1.0.7 trying to register the same
WARNING: gst-plugins-base-alsa-0.10.36 is already registered as shlib provider for libgstalsa.so, ignoring gstreamer1.0-plugins-base-alsa-1.0.7 trying to register the same
WARNING: gst-plugins-base-app-0.10.36 is already registered as shlib provider for libgstapp.so, ignoring gstreamer1.0-plugins-base-app-1.0.7 trying to register the same
WARNING: gst-plugins-base-audioconvert-0.10.36 is already registered as shlib provider for libgstaudioconvert.so, ignoring gstreamer1.0-plugins-base-audioconvert-1.0.7 trying to register the same
WARNING: gst-plugins-base-audiorate-0.10.36 is already registered as shlib provider for libgstaudiorate.so, ignoring gstreamer1.0-plugins-base-audiorate-1.0.7 trying to register the same
WARNING: gst-plugins-base-audioresample-0.10.36 is already registered as shlib provider for libgstaudioresample.so, ignoring gstreamer1.0-plugins-base-audioresample-1.0.7 trying to register the same
WARNING: gst-plugins-base-audiotestsrc-0.10.36 is already registered as shlib provider for libgstaudiotestsrc.so, ignoring gstreamer1.0-plugins-base-audiotestsrc-1.0.7 trying to register the same
WARNING: gst-plugins-base-encodebin-0.10.36 is already registered as shlib provider for libgstencodebin.so, ignoring gstreamer1.0-plugins-base-encodebin-1.0.7 trying to register the same
WARNING: gst-plugins-base-gio-0.10.36 is already registered as shlib provider for libgstgio.so, ignoring gstreamer1.0-plugins-base-gio-1.0.7 trying to register the same
WARNING: gst-plugins-base-ivorbisdec-0.10.36 is already registered as shlib provider for libgstivorbisdec.so, ignoring gstreamer1.0-plugins-base-ivorbisdec-1.0.7 trying to register the same
WARNING: gst-plugins-base-ogg-0.10.36 is already registered as shlib provider for libgstogg.so, ignoring gstreamer1.0-plugins-base-ogg-1.0.7 trying to register the same
WARNING: gst-plugins-base-subparse-0.10.36 is already registered as shlib provider for libgstsubparse.so, ignoring gstreamer1.0-plugins-base-subparse-1.0.7 trying to register the same
WARNING: gst-plugins-base-tcp-0.10.36 is already registered as shlib provider for libgsttcp.so, ignoring gstreamer1.0-plugins-base-tcp-1.0.7 trying to register the same
WARNING: gst-plugins-base-theora-0.10.36 is already registered as shlib provider for libgsttheora.so, ignoring gstreamer1.0-plugins-base-theora-1.0.7 trying to register the same
WARNING: gst-plugins-base-typefindfunctions-0.10.36 is already registered as shlib provider for libgsttypefindfunctions.so, ignoring gstreamer1.0-plugins-base-typefindfunctions-1.0.7 trying to register the same
WARNING: gst-plugins-base-videorate-0.10.36 is already registered as shlib provider for libgstvideorate.so, ignoring gstreamer1.0-plugins-base-videorate-1.0.7 trying to register the same
WARNING: gst-plugins-base-videoscale-0.10.36 is already registered as shlib provider for libgstvideoscale.so, ignoring gstreamer1.0-plugins-base-videoscale-1.0.7 trying to register the same
WARNING: gst-plugins-base-videotestsrc-0.10.36 is already registered as shlib provider for libgstvideotestsrc.so, ignoring gstreamer1.0-plugins-base-videotestsrc-1.0.7 trying to register the same
WARNING: gst-plugins-base-volume-0.10.36 is already registered as shlib provider for libgstvolume.so, ignoring gstreamer1.0-plugins-base-volume-1.0.7 trying to register the same
WARNING: gst-plugins-base-vorbis-0.10.36 is already registered as shlib provider for libgstvorbis.so, ignoring gstreamer1.0-plugins-base-vorbis-1.0.7 trying to register the same
WARNING: gst-plugins-base-ximagesink-0.10.36 is already registered as shlib provider for libgstximagesink.so, ignoring gstreamer1.0-plugins-base-ximagesink-1.0.7 trying to register the same
WARNING: gst-plugins-base-xvimagesink-0.10.36 is already registered as shlib provider for libgstxvimagesink.so, ignoring gstreamer1.0-plugins-base-xvimagesink-1.0.7 trying to register the same
WARNING: firefox-10.0.11esr is already registered as shlib provider for libnss3.so, ignoring nss-3.13.3 trying to register the same
WARNING: firefox-10.0.11esr is already registered as shlib provider for libfreebl3.so, ignoring nss-3.13.3 trying to register the same
WARNING: firefox-10.0.11esr is already registered as shlib provider for libnssutil3.so, ignoring nss-3.13.3 trying to register the same
WARNING: firefox-10.0.11esr is already registered as shlib provider for libsmime3.so, ignoring nss-3.13.3 trying to register the same
WARNING: firefox-10.0.11esr is already registered as shlib provider for libnssckbi.so, ignoring nss-3.13.3 trying to register the same
WARNING: firefox-10.0.11esr is already registered as shlib provider for libnssdbm3.so, ignoring nss-3.13.3 trying to register the same
WARNING: firefox-10.0.11esr is already registered as shlib provider for libsoftokn3.so, ignoring nss-3.13.3 trying to register the same
WARNING: firefox-10.0.11esr is already registered as shlib provider for libssl3.so, ignoring nss-3.13.3 trying to register the same
WARNING: imlib2-loaders-1.4.5+svnr82070 is already registered as shlib provider for png.so, ignoring lightmediascanner-0.4.4 trying to register the same
WARNING: imlib2-loaders-1.4.5+svnr82070 is already registered as shlib provider for jpeg.so, ignoring lightmediascanner-0.4.4 trying to register the same
WARNING: imlib2-loaders-1.4.5+svnr82070 is already registered as shlib provider for id3.so, ignoring lightmediascanner-0.4.4 trying to register the same
WARNING: python-gst-0.10.22 is already registered as shlib provider for audio.so, ignoring fsodeviced-0.12.0 trying to register the same
WARNING: fsoaudiod-0.12.0 is already registered as shlib provider for router_alsa.so, ignoring fsodeviced-0.12.0 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring elfe-0.0.1+svnr82070 trying to register the same
WARNING: fsousaged-0.12.0 is already registered as shlib provider for lowlevel_openmoko.so, ignoring fsogsmd-module-lowlevel-openmoko-0.12.0 trying to register the same
WARNING: fsousaged-0.12.0 is already registered as shlib provider for dbus_service.so, ignoring fsogsmd-0.12.0 trying to register the same
WARNING: gtk-xfce-engine-3.0.1 is already registered as shlib provider for libxfce.so, ignoring gtk3-xfce-engine-3.0.1 trying to register the same
WARNING: xfce4-session-4.10.1 is already registered as shlib provider for libsimple.so, ignoring libpurple-protocol-simple-2.7.9 trying to register the same
WARNING: apache2-2.4.4 is already registered as shlib provider for mod_alias.so, ignoring lighttpd-module-alias-1.4.32 trying to register the same
WARNING: apache2-2.4.4 is already registered as shlib provider for mod_proxy.so, ignoring lighttpd-module-proxy-1.4.32 trying to register the same
WARNING: apache2-2.4.4 is already registered as shlib provider for mod_rewrite.so, ignoring lighttpd-module-rewrite-1.4.32 trying to register the same
WARNING: apache2-2.4.4 is already registered as shlib provider for mod_status.so, ignoring lighttpd-module-status-1.4.32 trying to register the same
WARNING: apache2-2.4.4 is already registered as shlib provider for mod_userdir.so, ignoring lighttpd-module-userdir-1.4.32 trying to register the same
WARNING: matchbox-keyboard-applet-0.0+git1+b38f24036c is already registered as shlib provider for libkeyboard.so, ignoring gnome-settings-daemon-2.32.1 trying to register the same
WARNING: gnome-vfs-plugin-http-2.24.4 is already registered as shlib provider for libhttp.so, ignoring qmmp-plugin-transports-http-0.6.6 trying to register the same
WARNING: matchbox-panel-2-2.0+git3+26a3a67b41 is already registered as shlib provider for libbattery.so, ignoring xfce4-battery-plugin-1.0.5 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring shr-e-gadgets-0.0.0+gitr1+27b6c17d73 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring cpu-0.0.1+svnr82070 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring places-0.1.0+svnr82070 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring forecasts-0.2.0+svnr82070 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring uptime-0.0.2+svnr82070 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring screenshot-0.3.0+svnr82070 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring exalt-client-0.0.1+svnr82070 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring diskio-0.0.1+svnr82070 trying to register the same
WARNING: libgphoto2-camlibs-2.4.11 is already registered as shlib provider for serial.so, ignoring libfreerdp-plugin-serial-gitr1+f311acaffb trying to register the same
WARNING: libgphoto2-camlibs-2.4.11 is already registered as shlib provider for disk.so, ignoring libfreerdp-plugin-disk-gitr1+f311acaffb trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring rain-0.0.3+svnr82070 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring news-0.1.0+svnr82070 trying to register the same
WARNING: evas-engine-fb-1.7.7 is already registered as shlib provider for module.so, ignoring flame-0.0.3+svnr82070 trying to register the same
WARNING: systemd-204 is already registered as shlib provider for libnss_myhostname.so.2, ignoring nss-myhostname-0.3 trying to register the same
WARNING: gst-plugins-bad-adpcmdec-0.10.23 is already registered as shlib provider for libgstadpcmdec.so, ignoring gstreamer1.0-plugins-bad-adpcmdec-1.0.7 trying to register the same
WARNING: gst-plugins-bad-adpcmenc-0.10.23 is already registered as shlib provider for libgstadpcmenc.so, ignoring gstreamer1.0-plugins-bad-adpcmenc-1.0.7 trying to register the same
WARNING: gst-plugins-bad-asfmux-0.10.23 is already registered as shlib provider for libgstasfmux.so, ignoring gstreamer1.0-plugins-bad-asfmux-1.0.7 trying to register the same
WARNING: gst-plugins-bad-audiovisualizers-0.10.23 is already registered as shlib provider for libgstaudiovisualizers.so, ignoring gstreamer1.0-plugins-bad-audiovisualizers-1.0.7 trying to register the same
WARNING: gst-plugins-bad-autoconvert-0.10.23 is already registered as shlib provider for libgstautoconvert.so, ignoring gstreamer1.0-plugins-bad-autoconvert-1.0.7 trying to register the same
WARNING: gst-plugins-bad-bayer-0.10.23 is already registered as shlib provider for libgstbayer.so, ignoring gstreamer1.0-plugins-bad-bayer-1.0.7 trying to register the same
WARNING: gst-plugins-bad-bz2-0.10.23 is already registered as shlib provider for libgstbz2.so, ignoring gstreamer1.0-plugins-bad-bz2-1.0.7 trying to register the same
WARNING: gst-plugins-bad-camerabin2-0.10.23 is already registered as shlib provider for libgstcamerabin2.so, ignoring gstreamer1.0-plugins-bad-camerabin2-1.0.7 trying to register the same
WARNING: gst-plugins-bad-coloreffects-0.10.23 is already registered as shlib provider for libgstcoloreffects.so, ignoring gstreamer1.0-plugins-bad-coloreffects-1.0.7 trying to register the same
WARNING: gst-plugins-bad-curl-0.10.23 is already registered as shlib provider for libgstcurl.so, ignoring gstreamer1.0-plugins-bad-curl-1.0.7 trying to register the same
WARNING: gst-plugins-bad-dataurisrc-0.10.23 is already registered as shlib provider for libgstdataurisrc.so, ignoring gstreamer1.0-plugins-bad-dataurisrc-1.0.7 trying to register the same
WARNING: gst-plugins-bad-debugutilsbad-0.10.23 is already registered as shlib provider for libgstdebugutilsbad.so, ignoring gstreamer1.0-plugins-bad-debugutilsbad-1.0.7 trying to register the same
WARNING: gst-plugins-bad-dtmf-0.10.23 is already registered as shlib provider for libgstdtmf.so, ignoring gstreamer1.0-plugins-bad-dtmf-1.0.7 trying to register the same
WARNING: gst-plugins-bad-dvb-0.10.23 is already registered as shlib provider for libgstdvb.so, ignoring gstreamer1.0-plugins-bad-dvb-1.0.7 trying to register the same
WARNING: gst-plugins-bad-dvbsuboverlay-0.10.23 is already registered as shlib provider for libgstdvbsuboverlay.so, ignoring gstreamer1.0-plugins-bad-dvbsuboverlay-1.0.7 trying to register the same
WARNING: gst-plugins-bad-dvdspu-0.10.23 is already registered as shlib provider for libgstdvdspu.so, ignoring gstreamer1.0-plugins-bad-dvdspu-1.0.7 trying to register the same
WARNING: gst-plugins-bad-festival-0.10.23 is already registered as shlib provider for libgstfestival.so, ignoring gstreamer1.0-plugins-bad-festival-1.0.7 trying to register the same
WARNING: gst-plugins-bad-fieldanalysis-0.10.23 is already registered as shlib provider for libgstfieldanalysis.so, ignoring gstreamer1.0-plugins-bad-fieldanalysis-1.0.7 trying to register the same
WARNING: gst-plugins-bad-fragmented-0.10.23 is already registered as shlib provider for libgstfragmented.so, ignoring gstreamer1.0-plugins-bad-fragmented-1.0.7 trying to register the same
WARNING: gst-plugins-bad-frei0r-0.10.23 is already registered as shlib provider for libgstfrei0r.so, ignoring gstreamer1.0-plugins-bad-frei0r-1.0.7 trying to register the same
WARNING: gst-plugins-bad-gaudieffects-0.10.23 is already registered as shlib provider for libgstgaudieffects.so, ignoring gstreamer1.0-plugins-bad-gaudieffects-1.0.7 trying to register the same
WARNING: gst-plugins-base-gdp-0.10.36 is already registered as shlib provider for libgstgdp.so, ignoring gstreamer1.0-plugins-bad-gdp-1.0.7 trying to register the same
WARNING: gst-plugins-bad-geometrictransform-0.10.23 is already registered as shlib provider for libgstgeometrictransform.so, ignoring gstreamer1.0-plugins-bad-geometrictransform-1.0.7 trying to register the same
WARNING: gst-plugins-bad-id3tag-0.10.23 is already registered as shlib provider for libgstid3tag.so, ignoring gstreamer1.0-plugins-bad-id3tag-1.0.7 trying to register the same
WARNING: gst-plugins-bad-inter-0.10.23 is already registered as shlib provider for libgstinter.so, ignoring gstreamer1.0-plugins-bad-inter-1.0.7 trying to register the same
WARNING: gst-plugins-bad-interlace-0.10.23 is already registered as shlib provider for libgstinterlace.so, ignoring gstreamer1.0-plugins-bad-interlace-1.0.7 trying to register the same
WARNING: gst-plugins-bad-jpegformat-0.10.23 is already registered as shlib provider for libgstjpegformat.so, ignoring gstreamer1.0-plugins-bad-jpegformat-1.0.7 trying to register the same
WARNING: gst-plugins-bad-liveadder-0.10.23 is already registered as shlib provider for libgstliveadder.so, ignoring gstreamer1.0-plugins-bad-liveadder-1.0.7 trying to register the same
WARNING: gst-plugins-bad-mpegpsmux-0.10.23 is already registered as shlib provider for libgstmpegpsmux.so, ignoring gstreamer1.0-plugins-bad-mpegpsmux-1.0.7 trying to register the same
WARNING: gst-plugins-bad-mpegtsdemux-0.10.23 is already registered as shlib provider for libgstmpegtsdemux.so, ignoring gstreamer1.0-plugins-bad-mpegtsdemux-1.0.7 trying to register the same
WARNING: gst-plugins-bad-mpegtsmux-0.10.23 is already registered as shlib provider for libgstmpegtsmux.so, ignoring gstreamer1.0-plugins-bad-mpegtsmux-1.0.7 trying to register the same
WARNING: gst-plugins-bad-pcapparse-0.10.23 is already registered as shlib provider for libgstpcapparse.so, ignoring gstreamer1.0-plugins-bad-pcapparse-1.0.7 trying to register the same
WARNING: gst-plugins-bad-pnm-0.10.23 is already registered as shlib provider for libgstpnm.so, ignoring gstreamer1.0-plugins-bad-pnm-1.0.7 trying to register the same
WARNING: gst-plugins-bad-rawparse-0.10.23 is already registered as shlib provider for libgstrawparse.so, ignoring gstreamer1.0-plugins-bad-rawparse-1.0.7 trying to register the same
WARNING: gst-plugins-bad-removesilence-0.10.23 is already registered as shlib provider for libgstremovesilence.so, ignoring gstreamer1.0-plugins-bad-removesilence-1.0.7 trying to register the same
WARNING: gst-plugins-bad-rtpmux-0.10.23 is already registered as shlib provider for libgstrtpmux.so, ignoring gstreamer1.0-plugins-bad-rtpmux-1.0.7 trying to register the same
WARNING: gst-plugins-bad-rtpvp8-0.10.23 is already registered as shlib provider for libgstrtpvp8.so, ignoring gstreamer1.0-plugins-bad-rtpvp8-1.0.7 trying to register the same
WARNING: gst-plugins-bad-scaletempoplugin-0.10.23 is already registered as shlib provider for libgstscaletempoplugin.so, ignoring gstreamer1.0-plugins-bad-scaletempoplugin-1.0.7 trying to register the same
WARNING: gst-plugins-bad-sdpelem-0.10.23 is already registered as shlib provider for libgstsdpelem.so, ignoring gstreamer1.0-plugins-bad-sdpelem-1.0.7 trying to register the same
WARNING: gst-plugins-bad-segmentclip-0.10.23 is already registered as shlib provider for libgstsegmentclip.so, ignoring gstreamer1.0-plugins-bad-segmentclip-1.0.7 trying to register the same
WARNING: gst-plugins-bad-shm-0.10.23 is already registered as shlib provider for libgstshm.so, ignoring gstreamer1.0-plugins-bad-shm-1.0.7 trying to register the same
WARNING: gst-plugins-bad-siren-0.10.23 is already registered as shlib provider for libgstsiren.so, ignoring gstreamer1.0-plugins-bad-siren-1.0.7 trying to register the same
WARNING: gst-plugins-bad-smooth-0.10.23 is already registered as shlib provider for libgstsmooth.so, ignoring gstreamer1.0-plugins-bad-smooth-1.0.7 trying to register the same
WARNING: gst-plugins-bad-speed-0.10.23 is already registered as shlib provider for libgstspeed.so, ignoring gstreamer1.0-plugins-bad-speed-1.0.7 trying to register the same
WARNING: gst-plugins-bad-subenc-0.10.23 is already registered as shlib provider for libgstsubenc.so, ignoring gstreamer1.0-plugins-bad-subenc-1.0.7 trying to register the same
WARNING: gst-plugins-bad-videoparsersbad-0.10.23 is already registered as shlib provider for libgstvideoparsersbad.so, ignoring gstreamer1.0-plugins-bad-videoparsersbad-1.0.7 trying to register the same
WARNING: gst-plugins-bad-y4mdec-0.10.23 is already registered as shlib provider for libgsty4mdec.so, ignoring gstreamer1.0-plugins-bad-y4mdec-1.0.7 trying to register the same
WARNING: gst-plugins-good-alaw-0.10.31 is already registered as shlib provider for libgstalaw.so, ignoring gstreamer1.0-plugins-good-alaw-1.0.7 trying to register the same
WARNING: gst-plugins-good-alpha-0.10.31 is already registered as shlib provider for libgstalpha.so, ignoring gstreamer1.0-plugins-good-alpha-1.0.7 trying to register the same
WARNING: gst-plugins-good-alphacolor-0.10.31 is already registered as shlib provider for libgstalphacolor.so, ignoring gstreamer1.0-plugins-good-alphacolor-1.0.7 trying to register the same
WARNING: gst-plugins-good-apetag-0.10.31 is already registered as shlib provider for libgstapetag.so, ignoring gstreamer1.0-plugins-good-apetag-1.0.7 trying to register the same
WARNING: gst-plugins-good-audiofx-0.10.31 is already registered as shlib provider for libgstaudiofx.so, ignoring gstreamer1.0-plugins-good-audiofx-1.0.7 trying to register the same
WARNING: gst-plugins-good-audioparsers-0.10.31 is already registered as shlib provider for libgstaudioparsers.so, ignoring gstreamer1.0-plugins-good-audioparsers-1.0.7 trying to register the same
WARNING: gst-plugins-good-auparse-0.10.31 is already registered as shlib provider for libgstauparse.so, ignoring gstreamer1.0-plugins-good-auparse-1.0.7 trying to register the same
WARNING: gst-plugins-good-autodetect-0.10.31 is already registered as shlib provider for libgstautodetect.so, ignoring gstreamer1.0-plugins-good-autodetect-1.0.7 trying to register the same
WARNING: gst-plugins-good-avi-0.10.31 is already registered as shlib provider for libgstavi.so, ignoring gstreamer1.0-plugins-good-avi-1.0.7 trying to register the same
WARNING: gst-plugins-good-cairo-0.10.31 is already registered as shlib provider for libgstcairo.so, ignoring gstreamer1.0-plugins-good-cairo-1.0.7 trying to register the same
WARNING: gst-plugins-good-cutter-0.10.31 is already registered as shlib provider for libgstcutter.so, ignoring gstreamer1.0-plugins-good-cutter-1.0.7 trying to register the same
WARNING: gst-plugins-good-debug-0.10.31 is already registered as shlib provider for libgstdebug.so, ignoring gstreamer1.0-plugins-good-debug-1.0.7 trying to register the same
WARNING: gst-plugins-good-deinterlace-0.10.31 is already registered as shlib provider for libgstdeinterlace.so, ignoring gstreamer1.0-plugins-good-deinterlace-1.0.7 trying to register the same
WARNING: gst-plugins-good-effectv-0.10.31 is already registered as shlib provider for libgsteffectv.so, ignoring gstreamer1.0-plugins-good-effectv-1.0.7 trying to register the same
WARNING: gst-plugins-good-equalizer-0.10.31 is already registered as shlib provider for libgstequalizer.so, ignoring gstreamer1.0-plugins-good-equalizer-1.0.7 trying to register the same
WARNING: gst-plugins-good-flac-0.10.31 is already registered as shlib provider for libgstflac.so, ignoring gstreamer1.0-plugins-good-flac-1.0.7 trying to register the same
WARNING: gst-plugins-good-flv-0.10.31 is already registered as shlib provider for libgstflv.so, ignoring gstreamer1.0-plugins-good-flv-1.0.7 trying to register the same
WARNING: gst-plugins-good-flxdec-0.10.31 is already registered as shlib provider for libgstflxdec.so, ignoring gstreamer1.0-plugins-good-flxdec-1.0.7 trying to register the same
WARNING: gst-plugins-good-gdkpixbuf-0.10.31 is already registered as shlib provider for libgstgdkpixbuf.so, ignoring gstreamer1.0-plugins-good-gdkpixbuf-1.0.7 trying to register the same
WARNING: gst-plugins-good-goom-0.10.31 is already registered as shlib provider for libgstgoom.so, ignoring gstreamer1.0-plugins-good-goom-1.0.7 trying to register the same
WARNING: gst-plugins-good-goom2k1-0.10.31 is already registered as shlib provider for libgstgoom2k1.so, ignoring gstreamer1.0-plugins-good-goom2k1-1.0.7 trying to register the same
WARNING: gst-plugins-good-icydemux-0.10.31 is already registered as shlib provider for libgsticydemux.so, ignoring gstreamer1.0-plugins-good-icydemux-1.0.7 trying to register the same
WARNING: gst-plugins-good-id3demux-0.10.31 is already registered as shlib provider for libgstid3demux.so, ignoring gstreamer1.0-plugins-good-id3demux-1.0.7 trying to register the same
WARNING: gst-plugins-good-imagefreeze-0.10.31 is already registered as shlib provider for libgstimagefreeze.so, ignoring gstreamer1.0-plugins-good-imagefreeze-1.0.7 trying to register the same
WARNING: gst-plugins-good-interleave-0.10.31 is already registered as shlib provider for libgstinterleave.so, ignoring gstreamer1.0-plugins-good-interleave-1.0.7 trying to register the same
WARNING: gst-plugins-good-isomp4-0.10.31 is already registered as shlib provider for libgstisomp4.so, ignoring gstreamer1.0-plugins-good-isomp4-1.0.7 trying to register the same
WARNING: gst-plugins-good-jpeg-0.10.31 is already registered as shlib provider for libgstjpeg.so, ignoring gstreamer1.0-plugins-good-jpeg-1.0.7 trying to register the same
WARNING: gst-plugins-good-level-0.10.31 is already registered as shlib provider for libgstlevel.so, ignoring gstreamer1.0-plugins-good-level-1.0.7 trying to register the same
WARNING: gst-plugins-good-matroska-0.10.31 is already registered as shlib provider for libgstmatroska.so, ignoring gstreamer1.0-plugins-good-matroska-1.0.7 trying to register the same
WARNING: gst-plugins-good-mulaw-0.10.31 is already registered as shlib provider for libgstmulaw.so, ignoring gstreamer1.0-plugins-good-mulaw-1.0.7 trying to register the same
WARNING: gst-plugins-good-multifile-0.10.31 is already registered as shlib provider for libgstmultifile.so, ignoring gstreamer1.0-plugins-good-multifile-1.0.7 trying to register the same
WARNING: gst-plugins-good-multipart-0.10.31 is already registered as shlib provider for libgstmultipart.so, ignoring gstreamer1.0-plugins-good-multipart-1.0.7 trying to register the same
WARNING: gst-plugins-good-navigationtest-0.10.31 is already registered as shlib provider for libgstnavigationtest.so, ignoring gstreamer1.0-plugins-good-navigationtest-1.0.7 trying to register the same
WARNING: gst-plugins-good-png-0.10.31 is already registered as shlib provider for libgstpng.so, ignoring gstreamer1.0-plugins-good-png-1.0.7 trying to register the same
WARNING: gst-plugins-good-pulse-0.10.31 is already registered as shlib provider for libgstpulse.so, ignoring gstreamer1.0-plugins-good-pulse-1.0.7 trying to register the same
WARNING: gst-plugins-good-replaygain-0.10.31 is already registered as shlib provider for libgstreplaygain.so, ignoring gstreamer1.0-plugins-good-replaygain-1.0.7 trying to register the same
WARNING: gst-plugins-good-rtp-0.10.31 is already registered as shlib provider for libgstrtp.so, ignoring gstreamer1.0-plugins-good-rtp-1.0.7 trying to register the same
WARNING: gst-plugins-good-rtpmanager-0.10.31 is already registered as shlib provider for libgstrtpmanager.so, ignoring gstreamer1.0-plugins-good-rtpmanager-1.0.7 trying to register the same
WARNING: gst-plugins-good-rtsp-0.10.31 is already registered as shlib provider for libgstrtsp.so, ignoring gstreamer1.0-plugins-good-rtsp-1.0.7 trying to register the same
WARNING: gst-plugins-good-shapewipe-0.10.31 is already registered as shlib provider for libgstshapewipe.so, ignoring gstreamer1.0-plugins-good-shapewipe-1.0.7 trying to register the same
WARNING: gst-plugins-good-smpte-0.10.31 is already registered as shlib provider for libgstsmpte.so, ignoring gstreamer1.0-plugins-good-smpte-1.0.7 trying to register the same
WARNING: gst-plugins-good-souphttpsrc-0.10.31 is already registered as shlib provider for libgstsouphttpsrc.so, ignoring gstreamer1.0-plugins-good-souphttpsrc-1.0.7 trying to register the same
WARNING: gst-plugins-good-spectrum-0.10.31 is already registered as shlib provider for libgstspectrum.so, ignoring gstreamer1.0-plugins-good-spectrum-1.0.7 trying to register the same
WARNING: gst-plugins-good-speex-0.10.31 is already registered as shlib provider for libgstspeex.so, ignoring gstreamer1.0-plugins-good-speex-1.0.7 trying to register the same
WARNING: gst-plugins-good-udp-0.10.31 is already registered as shlib provider for libgstudp.so, ignoring gstreamer1.0-plugins-good-udp-1.0.7 trying to register the same
WARNING: gst-plugins-good-video4linux2-0.10.31 is already registered as shlib provider for libgstvideo4linux2.so, ignoring gstreamer1.0-plugins-good-video4linux2-1.0.7 trying to register the same
WARNING: gst-plugins-good-videobox-0.10.31 is already registered as shlib provider for libgstvideobox.so, ignoring gstreamer1.0-plugins-good-videobox-1.0.7 trying to register the same
WARNING: gst-plugins-good-videocrop-0.10.31 is already registered as shlib provider for libgstvideocrop.so, ignoring gstreamer1.0-plugins-good-videocrop-1.0.7 trying to register the same
WARNING: gst-plugins-good-videofilter-0.10.31 is already registered as shlib provider for libgstvideofilter.so, ignoring gstreamer1.0-plugins-good-videofilter-1.0.7 trying to register the same
WARNING: gst-plugins-good-videomixer-0.10.31 is already registered as shlib provider for libgstvideomixer.so, ignoring gstreamer1.0-plugins-good-videomixer-1.0.7 trying to register the same
WARNING: gst-plugins-good-wavenc-0.10.31 is already registered as shlib provider for libgstwavenc.so, ignoring gstreamer1.0-plugins-good-wavenc-1.0.7 trying to register the same
WARNING: gst-plugins-good-wavparse-0.10.31 is already registered as shlib provider for libgstwavparse.so, ignoring gstreamer1.0-plugins-good-wavparse-1.0.7 trying to register the same
WARNING: gst-plugins-good-ximagesrc-0.10.31 is already registered as shlib provider for libgstximagesrc.so, ignoring gstreamer1.0-plugins-good-ximagesrc-1.0.7 trying to register the same
WARNING: gst-plugins-good-y4menc-0.10.31 is already registered as shlib provider for libgsty4menc.so, ignoring gstreamer1.0-plugins-good-y4menc-1.0.7 trying to register the same
WARNING: gst-plugins-ugly-a52dec-0.10.19 is already registered as shlib provider for libgsta52dec.so, ignoring gstreamer1.0-plugins-ugly-a52dec-1.0.7 trying to register the same
WARNING: gst-plugins-ugly-asf-0.10.19 is already registered as shlib provider for libgstasf.so, ignoring gstreamer1.0-plugins-ugly-asf-1.0.7 trying to register the same
WARNING: gst-plugins-ugly-lame-0.10.19 is already registered as shlib provider for libgstlame.so, ignoring gstreamer1.0-plugins-ugly-lame-1.0.7 trying to register the same
WARNING: gst-plugins-ugly-mad-0.10.19 is already registered as shlib provider for libgstmad.so, ignoring gstreamer1.0-plugins-ugly-mad-1.0.7 trying to register the same
WARNING: gst-plugins-ugly-mpeg2dec-0.10.19 is already registered as shlib provider for libgstmpeg2dec.so, ignoring gstreamer1.0-plugins-ugly-mpeg2dec-1.0.7 trying to register the same
WARNING: gst-plugins-ugly-rmdemux-0.10.19 is already registered as shlib provider for libgstrmdemux.so, ignoring gstreamer1.0-plugins-ugly-rmdemux-1.0.7 trying to register the same
WARNING: libgphoto2-camlibs-2.4.11 is already registered as shlib provider for serial.so, ignoring collectd-5.2.2 trying to register the same
WARNING: gegl-0.2.0 is already registered as shlib provider for load.so, ignoring collectd-5.2.2 trying to register the same
WARNING: libgphoto2-camlibs-2.4.11 is already registered as shlib provider for disk.so, ignoring collectd-5.2.2 trying to register the same
WARNING: gegl-0.2.0 is already registered as shlib provider for threshold.so, ignoring collectd-5.2.2 trying to register the same
WARNING: libfsotest-0.12.0 is already registered as shlib provider for plugin.so, ignoring gnumeric-1.12.0 trying to register the same
WARNING: fsodeviced-0.12.0 is already registered as shlib provider for kernel26_firmwareloader.so, ignoring fsosystemd-0.12.0 trying to register the same
WARNING: gst-openmax-0.10.1 is already registered as shlib provider for libgstomx.so, ignoring gstreamer1.0-omx-1.0.0 trying to register the same

Patch

diff --git a/meta/classes/package.bbclass b/meta/classes/package.bbclass
index d80535d..6c3ca56 100644
--- a/meta/classes/package.bbclass
+++ b/meta/classes/package.bbclass
@@ -1341,6 +1341,7 @@  python package_do_shlibs() {
         list_re = re.compile('^(.*)\.list$')
         # Go from least to most specific since the last one found wins
         for dir in reversed(shlibs_dirs):
+            bb.debug(2, "Reading shlib providers in %s" % (dir))
             if not os.path.exists(dir):
                 continue
             for file in os.listdir(dir):
@@ -1456,6 +1457,8 @@  python package_do_shlibs() {
 
     needed = {}
     shlib_provider = {}
+    read_shlib_providers()
+
     for pkg in packages.split():
         private_libs = d.getVar('PRIVATE_LIBS_' + pkg, True) or d.getVar('PRIVATE_LIBS', True)
         needs_ldconfig = False
@@ -1487,6 +1490,12 @@  python package_do_shlibs() {
         if len(sonames):
             fd = open(shlibs_file, 'w')
             for s in sonames:
+                if s in shlib_provider:
+                    (old_pkg, old_pkgver) = shlib_provider[s]
+                    if old_pkg != pkg:
+                        bb.warn('%s-%s is already registered as shlib provider for %s, ignoring %s-%s trying to register the same' % (old_pkg, old_pkgver, s, pkg, pkgver))
+                        continue
+                bb.debug(1, 'registering %s-%s as shlib provider for %s' % (pkg, pkgver, s))
                 fd.write(s + '\n')
                 shlib_provider[s] = (pkg, pkgver)
             fd.close()
@@ -1501,8 +1510,6 @@  python package_do_shlibs() {
             postinst += d.getVar('ldconfig_postinst_fragment', True)
             d.setVar('pkg_postinst_%s' % pkg, postinst)
 
-    read_shlib_providers()
-
     bb.utils.unlockfile(lf)
 
     assumed_libs = d.getVar('ASSUME_SHLIBS', True)