[2/3] lttng-modules: remove redundant devupstream assignments

Message ID 20220315162345.613041-2-ross.burton@arm.com
State Accepted, archived
Commit 39d39c61633e229a04eec6848b5e49c9f9860fa8
Headers show
Series [1/3] devupstream: fix handling of SRC_URI | expand

Commit Message

Ross Burton March 15, 2022, 4:23 p.m. UTC
These are set by devupstream, so they don't need to be set in the recipe.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 meta/recipes-kernel/lttng/lttng-modules_2.13.1.bb | 5 -----
 1 file changed, 5 deletions(-)

Comments

Richard Purdie March 16, 2022, 10:30 a.m. UTC | #1
On Tue, 2022-03-15 at 16:23 +0000, Ross Burton wrote:
> These are set by devupstream, so they don't need to be set in the recipe.
> 
> Signed-off-by: Ross Burton <ross.burton@arm.com>
> ---
>  meta/recipes-kernel/lttng/lttng-modules_2.13.1.bb | 5 -----
>  1 file changed, 5 deletions(-)
> 
> diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.13.1.bb b/meta/recipes-kernel/lttng/lttng-modules_2.13.1.bb
> index a8e4cc5afa..80877bcf5e 100644
> --- a/meta/recipes-kernel/lttng/lttng-modules_2.13.1.bb
> +++ b/meta/recipes-kernel/lttng/lttng-modules_2.13.1.bb
> @@ -42,11 +42,6 @@ python do_package:prepend() {
>  }
>  
>  BBCLASSEXTEND = "devupstream:target"
> -LIC_FILES_CHKSUM:class-devupstream = "file://LICENSE;md5=0464cff101a009c403cd2ed65d01d4c4"
> -DEFAULT_PREFERENCE:class-devupstream = "-1"
>  SRC_URI:class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.13"
> -
>  SRCREV:class-devupstream = "7584cfc04914cb0842a986e9808686858b9c8630"
> -PV:class-devupstream = "2.13.1+git${SRCPV}"
> -S:class-devupstream = "${WORKDIR}/git"
>  SRCREV_FORMAT ?= "lttng_git"

I think you need to leave PV?

Cheers,

Richard
Ross Burton March 16, 2022, 2:35 p.m. UTC | #2
On Wed, 16 Mar 2022 at 10:30, Richard Purdie
<richard.purdie@linuxfoundation.org> wrote:
> >  SRCREV:class-devupstream = "7584cfc04914cb0842a986e9808686858b9c8630"
> > -PV:class-devupstream = "2.13.1+git${SRCPV}"
> > -S:class-devupstream = "${WORKDIR}/git"
> >  SRCREV_FORMAT ?= "lttng_git"
>
> I think you need to leave PV?

devupstream should be setting PV automatically:

if proto_marker not in pv and not d.getVar("PV:class-devupstream"):
  d.setVar("PV", pv + proto_marker + "${SRCPV}")

I can double check shortly.

Ross
Richard Purdie March 16, 2022, 2:52 p.m. UTC | #3
On Wed, 2022-03-16 at 14:35 +0000, Ross Burton wrote:
> On Wed, 16 Mar 2022 at 10:30, Richard Purdie
> <richard.purdie@linuxfoundation.org> wrote:
> > >  SRCREV:class-devupstream = "7584cfc04914cb0842a986e9808686858b9c8630"
> > > -PV:class-devupstream = "2.13.1+git${SRCPV}"
> > > -S:class-devupstream = "${WORKDIR}/git"
> > >  SRCREV_FORMAT ?= "lttng_git"
> > 
> > I think you need to leave PV?
> 
> devupstream should be setting PV automatically:
> 
> if proto_marker not in pv and not d.getVar("PV:class-devupstream"):
>   d.setVar("PV", pv + proto_marker + "${SRCPV}")
> 
> I can double check shortly.

Sorry, you're right. I swear I looked at the class and didn't see that!

I think I was looking for "git" instead of url.scheme.

Cheers,

Richard

Patch

diff --git a/meta/recipes-kernel/lttng/lttng-modules_2.13.1.bb b/meta/recipes-kernel/lttng/lttng-modules_2.13.1.bb
index a8e4cc5afa..80877bcf5e 100644
--- a/meta/recipes-kernel/lttng/lttng-modules_2.13.1.bb
+++ b/meta/recipes-kernel/lttng/lttng-modules_2.13.1.bb
@@ -42,11 +42,6 @@  python do_package:prepend() {
 }
 
 BBCLASSEXTEND = "devupstream:target"
-LIC_FILES_CHKSUM:class-devupstream = "file://LICENSE;md5=0464cff101a009c403cd2ed65d01d4c4"
-DEFAULT_PREFERENCE:class-devupstream = "-1"
 SRC_URI:class-devupstream = "git://git.lttng.org/lttng-modules;branch=stable-2.13"
-
 SRCREV:class-devupstream = "7584cfc04914cb0842a986e9808686858b9c8630"
-PV:class-devupstream = "2.13.1+git${SRCPV}"
-S:class-devupstream = "${WORKDIR}/git"
 SRCREV_FORMAT ?= "lttng_git"