Patchwork [2/2] Disable build qt related packagegroups on mips64 with 64 bits userspace

login
register
mail settings
Submitter Kang Kai
Date June 28, 2013, 7:48 a.m.
Message ID <0b6b3178a957a5f1719d6e7d3de74ef10e997266.1372403777.git.kai.kang@windriver.com>
Download mbox | patch
Permalink /patch/52537/
State Accepted
Commit c4c6e5829c92a91cab8233bf2e4848bd3112ce0d
Headers show

Comments

Kang Kai - June 28, 2013, 7:48 a.m.
Because qt could not be built on mips64 with 64 bits userspace, set
COMPATIBLE_HOST for qt related packagegroups to disable them on mips64
with 64 bit userspace too.

Signed-off-by: Kai Kang <kai.kang@windriver.com>
---
 .../packagegroups/packagegroup-core-qt.bb          |    3 +++
 .../packagegroups/packagegroup-core-qt4e.bb        |    3 +++
 .../packagegroup-qt-toolchain-target.inc           |    3 +++
 3 files changed, 9 insertions(+), 0 deletions(-)
Paul Eggleton - June 28, 2013, 9 a.m.
Hi Kai,

On Friday 28 June 2013 15:48:47 Kai Kang wrote:
> Because qt could not be built on mips64 with 64 bits userspace, set
> COMPATIBLE_HOST for qt related packagegroups to disable them on mips64
> with 64 bit userspace too.
> 
> Signed-off-by: Kai Kang <kai.kang@windriver.com>
> ---
>  .../packagegroups/packagegroup-core-qt.bb          |    3 +++
>  .../packagegroups/packagegroup-core-qt4e.bb        |    3 +++
>  .../packagegroup-qt-toolchain-target.inc           |    3 +++
>  3 files changed, 9 insertions(+), 0 deletions(-)
> 
> diff --git a/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
> b/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb index
> 315df33..c993242 100644
> --- a/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
> +++ b/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
> @@ -6,6 +6,9 @@ DESCRIPTION = "Qt package groups"
>  LICENSE = "MIT"
>  PR = "r4"
> 
> +# Qt4 could NOT be built on MIPS64 with 64 bits userspace
> +COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
> +
>  inherit packagegroup
> 
>  PACKAGES = "${PN}-demoapps"
> diff --git a/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
> b/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb index
> 9263828..6ef844f 100644
> --- a/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
> +++ b/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
> @@ -2,6 +2,9 @@ SUMMARY = "Qt for Embedded Linux (Qt without X11)"
>  PR = "r2"
>  LICENSE = "MIT"
> 
> +# Qt4 could NOT be built on MIPS64 with 64 bits userspace
> +COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
> +
>  inherit packagegroup
> 
>  # For backwards compatibility after rename
> diff --git
> a/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc
> b/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc index
> 8413eec..fc1ccba 100644
> --- a/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc
> +++ b/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc
> @@ -1,5 +1,8 @@
>  LICENSE = "MIT"
> 
> +# Qt4 could NOT be built on MIPS64 with 64 bits userspace
> +COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
> +
>  inherit packagegroup
> 
>  PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"

I'm fine with the other change; the question is is this one needed in addition? 
Since the packagegroup-*qt* recipes reference packages from Qt which itself 
inherits qt4x11/qt4e bbclasses, surely trying to build these will immediately 
fail for mips64 anyway?

Cheers,
Paul
Kang Kai - June 28, 2013, 9:33 a.m.
On 2013?06?28? 17:00, Paul Eggleton wrote:
> Hi Kai,
>
> On Friday 28 June 2013 15:48:47 Kai Kang wrote:
>> Because qt could not be built on mips64 with 64 bits userspace, set
>> COMPATIBLE_HOST for qt related packagegroups to disable them on mips64
>> with 64 bit userspace too.
>>
>> Signed-off-by: Kai Kang <kai.kang@windriver.com>
>> ---
>>   .../packagegroups/packagegroup-core-qt.bb          |    3 +++
>>   .../packagegroups/packagegroup-core-qt4e.bb        |    3 +++
>>   .../packagegroup-qt-toolchain-target.inc           |    3 +++
>>   3 files changed, 9 insertions(+), 0 deletions(-)
>>
>> diff --git a/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
>> b/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb index
>> 315df33..c993242 100644
>> --- a/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
>> +++ b/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
>> @@ -6,6 +6,9 @@ DESCRIPTION = "Qt package groups"
>>   LICENSE = "MIT"
>>   PR = "r4"
>>
>> +# Qt4 could NOT be built on MIPS64 with 64 bits userspace
>> +COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
>> +
>>   inherit packagegroup
>>
>>   PACKAGES = "${PN}-demoapps"
>> diff --git a/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
>> b/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb index
>> 9263828..6ef844f 100644
>> --- a/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
>> +++ b/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
>> @@ -2,6 +2,9 @@ SUMMARY = "Qt for Embedded Linux (Qt without X11)"
>>   PR = "r2"
>>   LICENSE = "MIT"
>>
>> +# Qt4 could NOT be built on MIPS64 with 64 bits userspace
>> +COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
>> +
>>   inherit packagegroup
>>
>>   # For backwards compatibility after rename
>> diff --git
>> a/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc
>> b/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc index
>> 8413eec..fc1ccba 100644
>> --- a/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc
>> +++ b/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc
>> @@ -1,5 +1,8 @@
>>   LICENSE = "MIT"
>>
>> +# Qt4 could NOT be built on MIPS64 with 64 bits userspace
>> +COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
>> +
>>   inherit packagegroup
>>
>>   PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
> I'm fine with the other change; the question is is this one needed in addition?
> Since the packagegroup-*qt* recipes reference packages from Qt which itself
> inherits qt4x11/qt4e bbclasses, surely trying to build these will immediately
> fail for mips64 anyway?

Yes, it will fail immediately. What I want to do is to underline these 
packagegroups' build platform.
If you believe that they are redundant, I retrieve the patch 2/2.

Thanks,
Kai

>
> Cheers,
> Paul
>
Richard Purdie - June 28, 2013, 9:42 a.m.
On Fri, 2013-06-28 at 17:33 +0800, Kang Kai wrote:
> On 2013?06?28? 17:00, Paul Eggleton wrote:
> > Hi Kai,
> >
> > On Friday 28 June 2013 15:48:47 Kai Kang wrote:
> >> Because qt could not be built on mips64 with 64 bits userspace, set
> >> COMPATIBLE_HOST for qt related packagegroups to disable them on mips64
> >> with 64 bit userspace too.
> >>
> >> Signed-off-by: Kai Kang <kai.kang@windriver.com>
> >> ---
> >>   .../packagegroups/packagegroup-core-qt.bb          |    3 +++
> >>   .../packagegroups/packagegroup-core-qt4e.bb        |    3 +++
> >>   .../packagegroup-qt-toolchain-target.inc           |    3 +++
> >>   3 files changed, 9 insertions(+), 0 deletions(-)
> >>
> >> diff --git a/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
> >> b/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb index
> >> 315df33..c993242 100644
> >> --- a/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
> >> +++ b/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
> >> @@ -6,6 +6,9 @@ DESCRIPTION = "Qt package groups"
> >>   LICENSE = "MIT"
> >>   PR = "r4"
> >>
> >> +# Qt4 could NOT be built on MIPS64 with 64 bits userspace
> >> +COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
> >> +
> >>   inherit packagegroup
> >>
> >>   PACKAGES = "${PN}-demoapps"
> >> diff --git a/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
> >> b/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb index
> >> 9263828..6ef844f 100644
> >> --- a/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
> >> +++ b/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
> >> @@ -2,6 +2,9 @@ SUMMARY = "Qt for Embedded Linux (Qt without X11)"
> >>   PR = "r2"
> >>   LICENSE = "MIT"
> >>
> >> +# Qt4 could NOT be built on MIPS64 with 64 bits userspace
> >> +COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
> >> +
> >>   inherit packagegroup
> >>
> >>   # For backwards compatibility after rename
> >> diff --git
> >> a/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc
> >> b/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc index
> >> 8413eec..fc1ccba 100644
> >> --- a/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc
> >> +++ b/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc
> >> @@ -1,5 +1,8 @@
> >>   LICENSE = "MIT"
> >>
> >> +# Qt4 could NOT be built on MIPS64 with 64 bits userspace
> >> +COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
> >> +
> >>   inherit packagegroup
> >>
> >>   PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
> > I'm fine with the other change; the question is is this one needed in addition?
> > Since the packagegroup-*qt* recipes reference packages from Qt which itself
> > inherits qt4x11/qt4e bbclasses, surely trying to build these will immediately
> > fail for mips64 anyway?
> 
> Yes, it will fail immediately. What I want to do is to underline these 
> packagegroups' build platform.
> If you believe that they are redundant, I retrieve the patch 2/2.

At a guess the one advantage of this is to clean up what "bitbake world"
would show?

Cheers,

Richard
Paul Eggleton - June 28, 2013, 9:53 a.m.
On Friday 28 June 2013 10:42:29 Richard Purdie wrote:
> On Fri, 2013-06-28 at 17:33 +0800, Kang Kai wrote:
> > On 2013?06?28? 17:00, Paul Eggleton wrote:
> > > Hi Kai,
> > > 
> > > On Friday 28 June 2013 15:48:47 Kai Kang wrote:
> > >> Because qt could not be built on mips64 with 64 bits userspace, set
> > >> COMPATIBLE_HOST for qt related packagegroups to disable them on mips64
> > >> with 64 bit userspace too.
> > >> 
> > >> Signed-off-by: Kai Kang <kai.kang@windriver.com>
> > >> ---
> > >> 
> > >>   .../packagegroups/packagegroup-core-qt.bb          |    3 +++
> > >>   .../packagegroups/packagegroup-core-qt4e.bb        |    3 +++
> > >>   .../packagegroup-qt-toolchain-target.inc           |    3 +++
> > >>   3 files changed, 9 insertions(+), 0 deletions(-)
> > >> 
> > >> diff --git a/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
> > >> b/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb index
> > >> 315df33..c993242 100644
> > >> --- a/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
> > >> +++ b/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
> > >> @@ -6,6 +6,9 @@ DESCRIPTION = "Qt package groups"
> > >> 
> > >>   LICENSE = "MIT"
> > >>   PR = "r4"
> > >> 
> > >> +# Qt4 could NOT be built on MIPS64 with 64 bits userspace
> > >> +COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
> > >> +
> > >> 
> > >>   inherit packagegroup
> > >>   
> > >>   PACKAGES = "${PN}-demoapps"
> > >> 
> > >> diff --git a/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
> > >> b/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb index
> > >> 9263828..6ef844f 100644
> > >> --- a/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
> > >> +++ b/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
> > >> @@ -2,6 +2,9 @@ SUMMARY = "Qt for Embedded Linux (Qt without X11)"
> > >> 
> > >>   PR = "r2"
> > >>   LICENSE = "MIT"
> > >> 
> > >> +# Qt4 could NOT be built on MIPS64 with 64 bits userspace
> > >> +COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
> > >> +
> > >> 
> > >>   inherit packagegroup
> > >>   
> > >>   # For backwards compatibility after rename
> > >> 
> > >> diff --git
> > >> a/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc
> > >> b/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc
> > >> index
> > >> 8413eec..fc1ccba 100644
> > >> ---
> > >> a/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc
> > >> +++
> > >> b/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc
> > >> @@ -1,5 +1,8 @@
> > >> 
> > >>   LICENSE = "MIT"
> > >> 
> > >> +# Qt4 could NOT be built on MIPS64 with 64 bits userspace
> > >> +COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
> > >> +
> > >> 
> > >>   inherit packagegroup
> > >>   
> > >>   PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"
> > > 
> > > I'm fine with the other change; the question is is this one needed in
> > > addition? Since the packagegroup-*qt* recipes reference packages from
> > > Qt which itself inherits qt4x11/qt4e bbclasses, surely trying to build
> > > these will immediately fail for mips64 anyway?
> > 
> > Yes, it will fail immediately. What I want to do is to underline these
> > packagegroups' build platform.
> > If you believe that they are redundant, I retrieve the patch 2/2.
> 
> At a guess the one advantage of this is to clean up what "bitbake world"
> would show?

OK, I don't have any strong objections if it does help in some way.

Cheers,
Paul

Patch

diff --git a/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb b/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
index 315df33..c993242 100644
--- a/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
+++ b/meta/recipes-qt/packagegroups/packagegroup-core-qt.bb
@@ -6,6 +6,9 @@  DESCRIPTION = "Qt package groups"
 LICENSE = "MIT"
 PR = "r4"
 
+# Qt4 could NOT be built on MIPS64 with 64 bits userspace
+COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
+
 inherit packagegroup
 
 PACKAGES = "${PN}-demoapps"
diff --git a/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb b/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
index 9263828..6ef844f 100644
--- a/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
+++ b/meta/recipes-qt/packagegroups/packagegroup-core-qt4e.bb
@@ -2,6 +2,9 @@  SUMMARY = "Qt for Embedded Linux (Qt without X11)"
 PR = "r2"
 LICENSE = "MIT"
 
+# Qt4 could NOT be built on MIPS64 with 64 bits userspace
+COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
+
 inherit packagegroup
 
 # For backwards compatibility after rename
diff --git a/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc b/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc
index 8413eec..fc1ccba 100644
--- a/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc
+++ b/meta/recipes-qt/packagegroups/packagegroup-qt-toolchain-target.inc
@@ -1,5 +1,8 @@ 
 LICENSE = "MIT"
 
+# Qt4 could NOT be built on MIPS64 with 64 bits userspace
+COMPATIBLE_HOST_mips64 = "mips64.*-linux-gnun32"
+
 inherit packagegroup
 
 PACKAGEGROUP_DISABLE_COMPLEMENTARY = "1"