[33/33] python3-cryptography-vectors: Fix reproducibility

Message ID 20220314224837.834776-33-richard.purdie@linuxfoundation.org
State Accepted, archived
Commit 3c1e7e50c929436d0007d60e738c8270e7e6c7d9
Headers show
Series [01/33] python3-setuptools-rust-native: from meta-python | expand

Commit Message

Richard Purdie March 14, 2022, 10:48 p.m. UTC
We regenerate the pycache files and the checksums in the manifest are incorrect.
Remove them to avoid this and ensure reproducibility.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 .../python/python3-cryptography-vectors_36.0.1.bb            | 5 +++++
 1 file changed, 5 insertions(+)

Patch

diff --git a/meta/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb b/meta/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb
index b9e6b811c37..da6718fb90c 100644
--- a/meta/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb
+++ b/meta/recipes-devtools/python/python3-cryptography-vectors_36.0.1.bb
@@ -19,6 +19,11 @@  DEPENDS += " \
     ${PYTHON_PN}-cryptography \
 "
 
+do_install:append () {
+	# Remove the sha256 checksum lines for pycache files
+	sed ${D}${PYTHON_SITEPACKAGES_DIR}/cryptography_vectors-${PV}.dist-info/RECORD -e '/__pycache__/d' -i
+}
+
 BBCLASSEXTEND = "native nativesdk"
 
 UPSTREAM_CHECK_REGEX = ""