Patchwork [meta-networking] cyrus-sasl: Avoid to call AC_TRY_RUN

login
register
mail settings
Submitter rongqing.li@windriver.com
Date June 25, 2013, 1:22 a.m.
Message ID <1372123379-20337-1-git-send-email-rongqing.li@windriver.com>
Download mbox | patch
Permalink /patch/52305/
State Accepted, archived
Headers show

Comments

rongqing.li@windriver.com - June 25, 2013, 1:22 a.m.
From: "Roy.Li" <rongqing.li@windriver.com>

If the gssapi libraries are compiled before cyrus-sasl, configure will call
AC_TRY_RUN to check if gssapi libraries support SPNEGO, but calling AC_TRY_RUN
will fail on cross-compile environment.

Signed-off-by: Roy.Li <rongqing.li@windriver.com>
---
 .../cyrus-sasl/cyrus-sasl_2.1.26.bb                |    6 ++-
 .../files/avoid-to-call-AC_TRY_RUN.patch           |   46 ++++++++++++++++++++
 2 files changed, 51 insertions(+), 1 deletion(-)
 create mode 100644 meta-networking/recipes-daemons/cyrus-sasl/files/avoid-to-call-AC_TRY_RUN.patch
rongqing.li@windriver.com - June 28, 2013, 8:44 a.m.
ping

On 06/25/2013 09:22 AM, rongqing.li@windriver.com wrote:
> From: "Roy.Li" <rongqing.li@windriver.com>
>
> If the gssapi libraries are compiled before cyrus-sasl, configure will call
> AC_TRY_RUN to check if gssapi libraries support SPNEGO, but calling AC_TRY_RUN
> will fail on cross-compile environment.
>
> Signed-off-by: Roy.Li <rongqing.li@windriver.com>
> ---
>   .../cyrus-sasl/cyrus-sasl_2.1.26.bb                |    6 ++-
>   .../files/avoid-to-call-AC_TRY_RUN.patch           |   46 ++++++++++++++++++++
>   2 files changed, 51 insertions(+), 1 deletion(-)
>   create mode 100644 meta-networking/recipes-daemons/cyrus-sasl/files/avoid-to-call-AC_TRY_RUN.patch
>
> diff --git a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
> index bf6f95c..4311540 100644
> --- a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
> +++ b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
> @@ -4,7 +4,8 @@ DEPENDS = "openssl virtual/db"
>   LICENSE = "BSD"
>   LIC_FILES_CHKSUM = "file://COPYING;md5=3f55e0974e3d6db00ca6f57f2d206396"
>
> -SRC_URI = "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-${PV}.tar.gz "
> +SRC_URI = "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-${PV}.tar.gz \
> +	   file://avoid-to-call-AC_TRY_RUN.patch"
>
>   inherit autotools pkgconfig
>
> @@ -14,6 +15,9 @@ EXTRA_OECONF += "--with-dblib=berkeley \
>                    --without-pam --without-opie --without-des \
>                    andrew_cv_runpath_switch=none"
>
> +PACKAGECONFIG ??= ""
> +PACKAGECONFIG[gssapi] = "--enable-gssapi=yes,--enable-gssapi=no,krb5,"
> +
>   do_configure_prepend () {
>       rm -f acinclude.m4 config/libtool.m4
>   }
> diff --git a/meta-networking/recipes-daemons/cyrus-sasl/files/avoid-to-call-AC_TRY_RUN.patch b/meta-networking/recipes-daemons/cyrus-sasl/files/avoid-to-call-AC_TRY_RUN.patch
> new file mode 100644
> index 0000000..df9fa15
> --- /dev/null
> +++ b/meta-networking/recipes-daemons/cyrus-sasl/files/avoid-to-call-AC_TRY_RUN.patch
> @@ -0,0 +1,46 @@
> +Avoid to call AC_TRY_RUN
> +
> +Upstream-Status: Inappropriate [configuration]
> +
> +Avoid to call AC_TRY_RUN to check if GSSAPI libraries support SPNEGO
> +on cross-compile environment by definition AC_ARG_ENABLE enable-spnego
> +
> +Signed-off-by: Roy.Li <rongqing.li@windriver.com>
> +---
> + cmulocal/sasl2.m4 |   13 ++++++++++++-
> + 1 file changed, 12 insertions(+), 1 deletion(-)
> +
> +diff --git a/cmulocal/sasl2.m4 b/cmulocal/sasl2.m4
> +index 3c2841a..a5ecf81 100644
> +--- a/cmulocal/sasl2.m4
> ++++ b/cmulocal/sasl2.m4
> +@@ -281,6 +281,17 @@ if test "$gssapi" != no; then
> +
> +   cmu_save_LIBS="$LIBS"
> +   LIBS="$LIBS $GSSAPIBASE_LIBS"
> ++  AC_ARG_ENABLE([spnego],
> ++              [AC_HELP_STRING([--enable-spnego=<DIR>],
> ++                              [enable SPNEGO support in GSSAPI libraries [no]])],
> ++              [spnego=$enableval],
> ++              [spnego=no])
> ++
> ++  if test "$spnego" = no; then
> ++       echo "no"
> ++  elif test "$spnego" = yes; then
> ++       AC_DEFINE(HAVE_GSS_SPNEGO,,[Define if your GSSAPI implementation supports SPNEGO])
> ++  else
> +   AC_MSG_CHECKING([for SPNEGO support in GSSAPI libraries])
> +   AC_TRY_RUN([
> + #ifdef HAVE_GSSAPI_H
> +@@ -308,7 +319,7 @@ int main(void)
> + 	AC_MSG_RESULT(yes) ],
> + 	AC_MSG_RESULT(no))
> +   LIBS="$cmu_save_LIBS"
> +-
> ++   fi
> + else
> +   AC_MSG_RESULT([disabled])
> + fi
> +--
> +1.7.10.4
> +
>
Joe MacDonald - June 28, 2013, 3:08 p.m.
[Re: [oe] [PATCH meta-networking] cyrus-sasl: Avoid to call AC_TRY_RUN] On 13.06.28 (Fri 16:44) Rongqing Li wrote:

> ping

Hey Roy,

Sorry about that, I had a couple of outstanding questions I was trying
to answer for myself first.  Merged now.

-J.

> 
> On 06/25/2013 09:22 AM, rongqing.li@windriver.com wrote:
> >From: "Roy.Li" <rongqing.li@windriver.com>
> >
> >If the gssapi libraries are compiled before cyrus-sasl, configure will call
> >AC_TRY_RUN to check if gssapi libraries support SPNEGO, but calling AC_TRY_RUN
> >will fail on cross-compile environment.
> >
> >Signed-off-by: Roy.Li <rongqing.li@windriver.com>
> >---
> >  .../cyrus-sasl/cyrus-sasl_2.1.26.bb                |    6 ++-
> >  .../files/avoid-to-call-AC_TRY_RUN.patch           |   46 ++++++++++++++++++++
> >  2 files changed, 51 insertions(+), 1 deletion(-)
> >  create mode 100644 meta-networking/recipes-daemons/cyrus-sasl/files/avoid-to-call-AC_TRY_RUN.patch
> >
> >diff --git a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
> >index bf6f95c..4311540 100644
> >--- a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
> >+++ b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
> >@@ -4,7 +4,8 @@ DEPENDS = "openssl virtual/db"
> >  LICENSE = "BSD"
> >  LIC_FILES_CHKSUM = "file://COPYING;md5=3f55e0974e3d6db00ca6f57f2d206396"
> >
> >-SRC_URI = "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-${PV}.tar.gz "
> >+SRC_URI = "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-${PV}.tar.gz \
> >+	   file://avoid-to-call-AC_TRY_RUN.patch"
> >
> >  inherit autotools pkgconfig
> >
> >@@ -14,6 +15,9 @@ EXTRA_OECONF += "--with-dblib=berkeley \
> >                   --without-pam --without-opie --without-des \
> >                   andrew_cv_runpath_switch=none"
> >
> >+PACKAGECONFIG ??= ""
> >+PACKAGECONFIG[gssapi] = "--enable-gssapi=yes,--enable-gssapi=no,krb5,"
> >+
> >  do_configure_prepend () {
> >      rm -f acinclude.m4 config/libtool.m4
> >  }
> >diff --git a/meta-networking/recipes-daemons/cyrus-sasl/files/avoid-to-call-AC_TRY_RUN.patch b/meta-networking/recipes-daemons/cyrus-sasl/files/avoid-to-call-AC_TRY_RUN.patch
> >new file mode 100644
> >index 0000000..df9fa15
> >--- /dev/null
> >+++ b/meta-networking/recipes-daemons/cyrus-sasl/files/avoid-to-call-AC_TRY_RUN.patch
> >@@ -0,0 +1,46 @@
> >+Avoid to call AC_TRY_RUN
> >+
> >+Upstream-Status: Inappropriate [configuration]
> >+
> >+Avoid to call AC_TRY_RUN to check if GSSAPI libraries support SPNEGO
> >+on cross-compile environment by definition AC_ARG_ENABLE enable-spnego
> >+
> >+Signed-off-by: Roy.Li <rongqing.li@windriver.com>
> >+---
> >+ cmulocal/sasl2.m4 |   13 ++++++++++++-
> >+ 1 file changed, 12 insertions(+), 1 deletion(-)
> >+
> >+diff --git a/cmulocal/sasl2.m4 b/cmulocal/sasl2.m4
> >+index 3c2841a..a5ecf81 100644
> >+--- a/cmulocal/sasl2.m4
> >++++ b/cmulocal/sasl2.m4
> >+@@ -281,6 +281,17 @@ if test "$gssapi" != no; then
> >+
> >+   cmu_save_LIBS="$LIBS"
> >+   LIBS="$LIBS $GSSAPIBASE_LIBS"
> >++  AC_ARG_ENABLE([spnego],
> >++              [AC_HELP_STRING([--enable-spnego=<DIR>],
> >++                              [enable SPNEGO support in GSSAPI libraries [no]])],
> >++              [spnego=$enableval],
> >++              [spnego=no])
> >++
> >++  if test "$spnego" = no; then
> >++       echo "no"
> >++  elif test "$spnego" = yes; then
> >++       AC_DEFINE(HAVE_GSS_SPNEGO,,[Define if your GSSAPI implementation supports SPNEGO])
> >++  else
> >+   AC_MSG_CHECKING([for SPNEGO support in GSSAPI libraries])
> >+   AC_TRY_RUN([
> >+ #ifdef HAVE_GSSAPI_H
> >+@@ -308,7 +319,7 @@ int main(void)
> >+ 	AC_MSG_RESULT(yes) ],
> >+ 	AC_MSG_RESULT(no))
> >+   LIBS="$cmu_save_LIBS"
> >+-
> >++   fi
> >+ else
> >+   AC_MSG_RESULT([disabled])
> >+ fi
> >+--
> >+1.7.10.4
> >+
> >
>

Patch

diff --git a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
index bf6f95c..4311540 100644
--- a/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
+++ b/meta-networking/recipes-daemons/cyrus-sasl/cyrus-sasl_2.1.26.bb
@@ -4,7 +4,8 @@  DEPENDS = "openssl virtual/db"
 LICENSE = "BSD"
 LIC_FILES_CHKSUM = "file://COPYING;md5=3f55e0974e3d6db00ca6f57f2d206396"
 
-SRC_URI = "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-${PV}.tar.gz "
+SRC_URI = "ftp://ftp.cyrusimap.org/cyrus-sasl/cyrus-sasl-${PV}.tar.gz \
+	   file://avoid-to-call-AC_TRY_RUN.patch"
 
 inherit autotools pkgconfig
 
@@ -14,6 +15,9 @@  EXTRA_OECONF += "--with-dblib=berkeley \
                  --without-pam --without-opie --without-des \
                  andrew_cv_runpath_switch=none"
 
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[gssapi] = "--enable-gssapi=yes,--enable-gssapi=no,krb5,"
+
 do_configure_prepend () {
     rm -f acinclude.m4 config/libtool.m4
 }
diff --git a/meta-networking/recipes-daemons/cyrus-sasl/files/avoid-to-call-AC_TRY_RUN.patch b/meta-networking/recipes-daemons/cyrus-sasl/files/avoid-to-call-AC_TRY_RUN.patch
new file mode 100644
index 0000000..df9fa15
--- /dev/null
+++ b/meta-networking/recipes-daemons/cyrus-sasl/files/avoid-to-call-AC_TRY_RUN.patch
@@ -0,0 +1,46 @@ 
+Avoid to call AC_TRY_RUN
+
+Upstream-Status: Inappropriate [configuration] 
+
+Avoid to call AC_TRY_RUN to check if GSSAPI libraries support SPNEGO
+on cross-compile environment by definition AC_ARG_ENABLE enable-spnego
+
+Signed-off-by: Roy.Li <rongqing.li@windriver.com>
+---
+ cmulocal/sasl2.m4 |   13 ++++++++++++-
+ 1 file changed, 12 insertions(+), 1 deletion(-)
+
+diff --git a/cmulocal/sasl2.m4 b/cmulocal/sasl2.m4
+index 3c2841a..a5ecf81 100644
+--- a/cmulocal/sasl2.m4
++++ b/cmulocal/sasl2.m4
+@@ -281,6 +281,17 @@ if test "$gssapi" != no; then
+ 
+   cmu_save_LIBS="$LIBS"
+   LIBS="$LIBS $GSSAPIBASE_LIBS"
++  AC_ARG_ENABLE([spnego],
++              [AC_HELP_STRING([--enable-spnego=<DIR>],
++                              [enable SPNEGO support in GSSAPI libraries [no]])],
++              [spnego=$enableval],
++              [spnego=no])
++
++  if test "$spnego" = no; then
++       echo "no"
++  elif test "$spnego" = yes; then
++       AC_DEFINE(HAVE_GSS_SPNEGO,,[Define if your GSSAPI implementation supports SPNEGO])
++  else
+   AC_MSG_CHECKING([for SPNEGO support in GSSAPI libraries])
+   AC_TRY_RUN([
+ #ifdef HAVE_GSSAPI_H
+@@ -308,7 +319,7 @@ int main(void)
+ 	AC_MSG_RESULT(yes) ],
+ 	AC_MSG_RESULT(no))
+   LIBS="$cmu_save_LIBS"
+-
++   fi
+ else
+   AC_MSG_RESULT([disabled])
+ fi
+-- 
+1.7.10.4
+