Patchwork sanity.bbclass: Drop horrible obsolete minversion hack

login
register
mail settings
Submitter Richard Purdie
Date June 21, 2013, 4:44 p.m.
Message ID <1371833048.20823.304.camel@ted>
Download mbox | patch
Permalink /patch/52217/
State New
Headers show

Comments

Richard Purdie - June 21, 2013, 4:44 p.m.
We once needed to do this, things seem to work fine without this now,
thankfully.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---

Patch

diff --git a/meta/classes/sanity.bbclass b/meta/classes/sanity.bbclass
index 3b9934b..7e61daa 100644
--- a/meta/classes/sanity.bbclass
+++ b/meta/classes/sanity.bbclass
@@ -369,15 +369,8 @@  def check_sanity(sanity_data):
             print("WARNING: sanity.bbclass can't compare versions without python-distutils")
             return 1
 
-    # Check the bitbake version meets minimum requirements
-    minversion = sanity_data.getVar('BB_MIN_VERSION', True)
-    if not minversion:
-        # Hack: BB_MIN_VERSION hasn't been parsed yet so return 
-        # and wait for the next call
-        return
-
     if 0 == os.getuid():
         raise_sanity_error("Do not use Bitbake as root.", sanity_data)
 
     messages = ""
 
@@ -392,6 +385,8 @@  def check_sanity(sanity_data):
     except ImportError:
         messages = messages + 'Your python is not a full install. Please install the module xml.parsers.expat (python-xml on openSUSE and SUSE Linux).\n'
 
+    # Check the bitbake version meets minimum requirements
+    minversion = sanity_data.getVar('BB_MIN_VERSION', True)
     if (LooseVersion(bb.__version__) < LooseVersion(minversion)):
         messages = messages + 'Bitbake version %s is required and version %s was found\n' % (minversion, bb.__version__)