Patchwork [RFC,v1,01/16] native.bbclass: allow a native package to be populated into its own dir

login
register
mail settings
Submitter Dexuan Cui
Date June 1, 2011, 1:18 p.m.
Message ID <806387a97c6c01bb724c29f51de511ed43688bb0.1306931848.git.dexuan.cui@intel.com>
Download mbox | patch
Permalink /patch/5205/
State New, archived
Headers show

Comments

Dexuan Cui - June 1, 2011, 1:18 p.m.
Signed-off-by: Dexuan Cui <dexuan.cui@intel.com>
---
 meta/classes/native.bbclass |    5 +++++
 1 files changed, 5 insertions(+), 0 deletions(-)
Phil Blundell - June 1, 2011, 1:40 p.m.
On Wed, 2011-06-01 at 21:18 +0800, Dexuan Cui wrote:
> +PACKAGE_OWN_DIR = ""
> +bindir .= "${PACKAGE_OWN_DIR}"
> +libdir .= "${PACKAGE_OWN_DIR}"
> +libexecdir .= "${PACKAGE_OWN_DIR}"

I think the general idea of this patch is a good one but I'm not
terribly fond of the name of that variable.  If this is meant to be a
path suffix that you can optionally set for native packages then how
about calling it something like NATIVE_PACKAGE_PATH_SUFFIX?

p.
Dexuan Cui - June 2, 2011, 6:04 a.m.
Phil Blundell wrote:
> On Wed, 2011-06-01 at 21:18 +0800, Dexuan Cui wrote:
>> +PACKAGE_OWN_DIR = ""
>> +bindir .= "${PACKAGE_OWN_DIR}"
>> +libdir .= "${PACKAGE_OWN_DIR}"
>> +libexecdir .= "${PACKAGE_OWN_DIR}"
> 
> I think the general idea of this patch is a good one but I'm not
> terribly fond of the name of that variable.  If this is meant to be a
> path suffix that you can optionally set for native packages then how
> about calling it something like NATIVE_PACKAGE_PATH_SUFFIX?

Hi Phil,
Thanks a lot for the suggestion.
Surely NATIVE_PACKAGE_PATH_SUFFIX is a much better naming! :-)
I'll change to use it.

Thanks,
-- Dexuan
Dexuan Cui - June 2, 2011, 1:50 p.m.
Cui, Dexuan wrote:
> Phil Blundell wrote:
>> On Wed, 2011-06-01 at 21:18 +0800, Dexuan Cui wrote:
>>> +PACKAGE_OWN_DIR = ""
>>> +bindir .= "${PACKAGE_OWN_DIR}"
>>> +libdir .= "${PACKAGE_OWN_DIR}"
>>> +libexecdir .= "${PACKAGE_OWN_DIR}"
>> 
>> I think the general idea of this patch is a good one but I'm not
>> terribly fond of the name of that variable.  If this is meant to be a
>> path suffix that you can optionally set for native packages then how
>> about calling it something like NATIVE_PACKAGE_PATH_SUFFIX?
> 
> Hi Phil,
> Thanks a lot for the suggestion.
> Surely NATIVE_PACKAGE_PATH_SUFFIX is a much better naming! :-)
> I'll change to use it.

Hi RP, Phil, 
A new branch dcui/master_perl-native_v2 was created for this better naming(this is the only difference compared with the previous version):
http://git.pokylinux.org/cgit/cgit.cgi/poky-contrib/log/?h=dcui/master_perl-native_v2

Thanks,
-- Dexuan

Patch

diff --git a/meta/classes/native.bbclass b/meta/classes/native.bbclass
index e06f02a..8a3c294 100644
--- a/meta/classes/native.bbclass
+++ b/meta/classes/native.bbclass
@@ -67,6 +67,11 @@  base_prefix = "${STAGING_DIR_NATIVE}"
 prefix = "${STAGING_DIR_NATIVE}${prefix_native}"
 exec_prefix = "${STAGING_DIR_NATIVE}${prefix_native}"
 
+PACKAGE_OWN_DIR = ""
+bindir .= "${PACKAGE_OWN_DIR}"
+libdir .= "${PACKAGE_OWN_DIR}"
+libexecdir .= "${PACKAGE_OWN_DIR}"
+
 do_populate_sysroot[sstate-inputdirs] = "${SYSROOT_DESTDIR}/${STAGING_DIR_NATIVE}"
 do_populate_sysroot[sstate-outputdirs] = "${STAGING_DIR_NATIVE}"