Patchwork qt4e.bbclass: export OE_QMAKE_QT_CONFIG

login
register
mail settings
Submitter Jonathan Liu
Date June 15, 2013, 12:06 a.m.
Message ID <1371254791-8168-1-git-send-email-net147@gmail.com>
Download mbox | patch
Permalink /patch/51749/
State Accepted
Commit 85f0cf943d3165a603ccb058d838bc0b6a80ce43
Headers show

Comments

Jonathan Liu - June 15, 2013, 12:06 a.m.
The class is inheriting qmake2.bbclass which exports OE_QMAKE_QT_CONFIG
pointing to the qt4 qconfig.pri when it should be pointing to the
qt4-embedded qconfig.pri.

Signed-off-by: Jonathan Liu <net147@gmail.com>
---
 meta/classes/qt4e.bbclass | 1 +
 1 file changed, 1 insertion(+)
Jonathan Liu - June 28, 2013, 12:07 p.m.
On 15/06/2013 10:06 AM, Jonathan Liu wrote:
> The class is inheriting qmake2.bbclass which exports OE_QMAKE_QT_CONFIG
> pointing to the qt4 qconfig.pri when it should be pointing to the
> qt4-embedded qconfig.pri.
>
> Signed-off-by: Jonathan Liu <net147@gmail.com>
> ---
>   meta/classes/qt4e.bbclass | 1 +
>   1 file changed, 1 insertion(+)
>
> diff --git a/meta/classes/qt4e.bbclass b/meta/classes/qt4e.bbclass
> index de2a68d..13b1050 100644
> --- a/meta/classes/qt4e.bbclass
> +++ b/meta/classes/qt4e.bbclass
> @@ -9,6 +9,7 @@ QT_LIBINFIX = "E"
>   # override variables set by qmake-base to compile Qt/Embedded apps
>   #
>   export QMAKESPEC = "${STAGING_DATADIR}/${QT_DIR_NAME}/mkspecs/${TARGET_OS}-oe-g++"
> +export OE_QMAKE_QT_CONFIG = "${STAGING_DATADIR}/${QT_DIR_NAME}/mkspecs/qconfig.pri"
>   export OE_QMAKE_INCDIR_QT = "${STAGING_INCDIR}/${QT_DIR_NAME}"
>   export OE_QMAKE_LIBDIR_QT = "${STAGING_LIBDIR}"
>   export OE_QMAKE_LIBS_QT = "qt"
Hi Saul,

Do you have a log of the error you had building qt4-embedded with this 
patch?

Regards,
Jonathan
Martin Jansa - June 28, 2013, 12:28 p.m.
It's failing in my world builds too now, you can see log here:
http://logs.nslu2-linux.org/buildlogs/oe/oe-shr-core-branches/log.world.20130627_214856.log/bitbake.log

Cheers,


On Fri, Jun 28, 2013 at 2:07 PM, Jonathan Liu <net147@gmail.com> wrote:

> On 15/06/2013 10:06 AM, Jonathan Liu wrote:
>
>> The class is inheriting qmake2.bbclass which exports OE_QMAKE_QT_CONFIG
>> pointing to the qt4 qconfig.pri when it should be pointing to the
>> qt4-embedded qconfig.pri.
>>
>> Signed-off-by: Jonathan Liu <net147@gmail.com>
>> ---
>>   meta/classes/qt4e.bbclass | 1 +
>>   1 file changed, 1 insertion(+)
>>
>> diff --git a/meta/classes/qt4e.bbclass b/meta/classes/qt4e.bbclass
>> index de2a68d..13b1050 100644
>> --- a/meta/classes/qt4e.bbclass
>> +++ b/meta/classes/qt4e.bbclass
>> @@ -9,6 +9,7 @@ QT_LIBINFIX = "E"
>>   # override variables set by qmake-base to compile Qt/Embedded apps
>>   #
>>   export QMAKESPEC = "${STAGING_DATADIR}/${QT_DIR_**
>> NAME}/mkspecs/${TARGET_OS}-oe-**g++"
>> +export OE_QMAKE_QT_CONFIG = "${STAGING_DATADIR}/${QT_DIR_**
>> NAME}/mkspecs/qconfig.pri"
>>   export OE_QMAKE_INCDIR_QT = "${STAGING_INCDIR}/${QT_DIR_**NAME}"
>>   export OE_QMAKE_LIBDIR_QT = "${STAGING_LIBDIR}"
>>   export OE_QMAKE_LIBS_QT = "qt"
>>
> Hi Saul,
>
> Do you have a log of the error you had building qt4-embedded with this
> patch?
>
> Regards,
> Jonathan
>
> ______________________________**_________________
> Openembedded-core mailing list
> Openembedded-core@lists.**openembedded.org<Openembedded-core@lists.openembedded.org>
> http://lists.openembedded.org/**mailman/listinfo/openembedded-**core<http://lists.openembedded.org/mailman/listinfo/openembedded-core>
>
Paul Eggleton - June 28, 2013, 12:40 p.m.
On Friday 28 June 2013 14:28:56 Martin Jansa wrote:
> It's failing in my world builds too now, you can see log here:
> http://logs.nslu2-linux.org/buildlogs/oe/oe-shr-core-branches/log.world.2013
> 0627_214856.log/bitbake.log
> 
> Cheers,
> 
> On Fri, Jun 28, 2013 at 2:07 PM, Jonathan Liu <net147@gmail.com> wrote:
> > On 15/06/2013 10:06 AM, Jonathan Liu wrote:
> >> The class is inheriting qmake2.bbclass which exports OE_QMAKE_QT_CONFIG
> >> pointing to the qt4 qconfig.pri when it should be pointing to the
> >> qt4-embedded qconfig.pri.
> >> 
> >> Signed-off-by: Jonathan Liu <net147@gmail.com>
> >> ---
> >> 
> >>   meta/classes/qt4e.bbclass | 1 +
> >>   1 file changed, 1 insertion(+)
> >> 
> >> diff --git a/meta/classes/qt4e.bbclass b/meta/classes/qt4e.bbclass
> >> index de2a68d..13b1050 100644
> >> --- a/meta/classes/qt4e.bbclass
> >> +++ b/meta/classes/qt4e.bbclass
> >> @@ -9,6 +9,7 @@ QT_LIBINFIX = "E"
> >> 
> >>   # override variables set by qmake-base to compile Qt/Embedded apps
> >>   #
> >>   export QMAKESPEC = "${STAGING_DATADIR}/${QT_DIR_**
> >> 
> >> NAME}/mkspecs/${TARGET_OS}-oe-**g++"
> >> +export OE_QMAKE_QT_CONFIG = "${STAGING_DATADIR}/${QT_DIR_**
> >> NAME}/mkspecs/qconfig.pri"
> >> 
> >>   export OE_QMAKE_INCDIR_QT = "${STAGING_INCDIR}/${QT_DIR_**NAME}"
> >>   export OE_QMAKE_LIBDIR_QT = "${STAGING_LIBDIR}"
> >>   export OE_QMAKE_LIBS_QT = "qt"
> > 
> > Hi Saul,
> > 
> > Do you have a log of the error you had building qt4-embedded with this
> > patch?

FWIW, I see the same error without this patch if I build qt4-embedded after 
building qt4-x11, so I don't know if this patch is really related to the 
problem or not.

Cheers,
Paul
Martin Jansa - June 28, 2013, 12:45 p.m.
On Fri, Jun 28, 2013 at 01:40:26PM +0100, Paul Eggleton wrote:
> On Friday 28 June 2013 14:28:56 Martin Jansa wrote:
> > It's failing in my world builds too now, you can see log here:
> > http://logs.nslu2-linux.org/buildlogs/oe/oe-shr-core-branches/log.world.2013
> > 0627_214856.log/bitbake.log
> > 
> > Cheers,
> > 
> > On Fri, Jun 28, 2013 at 2:07 PM, Jonathan Liu <net147@gmail.com> wrote:
> > > On 15/06/2013 10:06 AM, Jonathan Liu wrote:
> > >> The class is inheriting qmake2.bbclass which exports OE_QMAKE_QT_CONFIG
> > >> pointing to the qt4 qconfig.pri when it should be pointing to the
> > >> qt4-embedded qconfig.pri.
> > >> 
> > >> Signed-off-by: Jonathan Liu <net147@gmail.com>
> > >> ---
> > >> 
> > >>   meta/classes/qt4e.bbclass | 1 +
> > >>   1 file changed, 1 insertion(+)
> > >> 
> > >> diff --git a/meta/classes/qt4e.bbclass b/meta/classes/qt4e.bbclass
> > >> index de2a68d..13b1050 100644
> > >> --- a/meta/classes/qt4e.bbclass
> > >> +++ b/meta/classes/qt4e.bbclass
> > >> @@ -9,6 +9,7 @@ QT_LIBINFIX = "E"
> > >> 
> > >>   # override variables set by qmake-base to compile Qt/Embedded apps
> > >>   #
> > >>   export QMAKESPEC = "${STAGING_DATADIR}/${QT_DIR_**
> > >> 
> > >> NAME}/mkspecs/${TARGET_OS}-oe-**g++"
> > >> +export OE_QMAKE_QT_CONFIG = "${STAGING_DATADIR}/${QT_DIR_**
> > >> NAME}/mkspecs/qconfig.pri"
> > >> 
> > >>   export OE_QMAKE_INCDIR_QT = "${STAGING_INCDIR}/${QT_DIR_**NAME}"
> > >>   export OE_QMAKE_LIBDIR_QT = "${STAGING_LIBDIR}"
> > >>   export OE_QMAKE_LIBS_QT = "qt"
> > > 
> > > Hi Saul,
> > > 
> > > Do you have a log of the error you had building qt4-embedded with this
> > > patch?
> 
> FWIW, I see the same error without this patch if I build qt4-embedded after 
> building qt4-x11, so I don't know if this patch is really related to the 
> problem or not.

It was building fine in world builds until 1-2 weeks ago, but it's
possible that I was just lucky to have it in right order.
Paul Eggleton - June 28, 2013, 12:47 p.m.
On Friday 28 June 2013 14:45:34 Martin Jansa wrote:
> On Fri, Jun 28, 2013 at 01:40:26PM +0100, Paul Eggleton wrote:
> > FWIW, I see the same error without this patch if I build qt4-embedded
> > after building qt4-x11, so I don't know if this patch is really related to
> > the problem or not.
> 
> It was building fine in world builds until 1-2 weeks ago, but it's
> possible that I was just lucky to have it in right order.

I'm pretty sure it's a recent regression, I'd be surprised if we never built 
them in the current order before on our autobuilder.

Cheers,
Paul
Hongxu Jia - June 28, 2013, 12:49 p.m.
On 06/28/2013 08:45 PM, Martin Jansa wrote:
> On Fri, Jun 28, 2013 at 01:40:26PM +0100, Paul Eggleton wrote:
>> On Friday 28 June 2013 14:28:56 Martin Jansa wrote:
>>> It's failing in my world builds too now, you can see log here:
>>> http://logs.nslu2-linux.org/buildlogs/oe/oe-shr-core-branches/log.world.2013
>>> 0627_214856.log/bitbake.log
>>>
>>> Cheers,
>>>
>>> On Fri, Jun 28, 2013 at 2:07 PM, Jonathan Liu <net147@gmail.com> wrote:
>>>> On 15/06/2013 10:06 AM, Jonathan Liu wrote:
>>>>> The class is inheriting qmake2.bbclass which exports OE_QMAKE_QT_CONFIG
>>>>> pointing to the qt4 qconfig.pri when it should be pointing to the
>>>>> qt4-embedded qconfig.pri.
>>>>>
>>>>> Signed-off-by: Jonathan Liu <net147@gmail.com>
>>>>> ---
>>>>>
>>>>>    meta/classes/qt4e.bbclass | 1 +
>>>>>    1 file changed, 1 insertion(+)
>>>>>
>>>>> diff --git a/meta/classes/qt4e.bbclass b/meta/classes/qt4e.bbclass
>>>>> index de2a68d..13b1050 100644
>>>>> --- a/meta/classes/qt4e.bbclass
>>>>> +++ b/meta/classes/qt4e.bbclass
>>>>> @@ -9,6 +9,7 @@ QT_LIBINFIX = "E"
>>>>>
>>>>>    # override variables set by qmake-base to compile Qt/Embedded apps
>>>>>    #
>>>>>    export QMAKESPEC = "${STAGING_DATADIR}/${QT_DIR_**
>>>>>
>>>>> NAME}/mkspecs/${TARGET_OS}-oe-**g++"
>>>>> +export OE_QMAKE_QT_CONFIG = "${STAGING_DATADIR}/${QT_DIR_**
>>>>> NAME}/mkspecs/qconfig.pri"
>>>>>
>>>>>    export OE_QMAKE_INCDIR_QT = "${STAGING_INCDIR}/${QT_DIR_**NAME}"
>>>>>    export OE_QMAKE_LIBDIR_QT = "${STAGING_LIBDIR}"
>>>>>    export OE_QMAKE_LIBS_QT = "qt"
>>>> Hi Saul,
>>>>
>>>> Do you have a log of the error you had building qt4-embedded with this
>>>> patch?
>> FWIW, I see the same error without this patch if I build qt4-embedded after
>> building qt4-x11, so I don't know if this patch is really related to the
>> problem or not.
> It was building fine in world builds until 1-2 weeks ago, but it's
> possible that I was just lucky to have it in right order.
>

Repoduce the bug by STEPS:

bitbake qt4-x11-free
bitbake qt4-embedded
and build qt4-embedded failed.

//Hongxu




>
>
> _______________________________________________
> Openembedded-core mailing list
> Openembedded-core@lists.openembedded.org
> http://lists.openembedded.org/mailman/listinfo/openembedded-core
Martin Jansa - June 30, 2013, 10:34 a.m.
On Fri, Jun 28, 2013 at 08:49:20PM +0800, Hongxu Jia wrote:
> On 06/28/2013 08:45 PM, Martin Jansa wrote:
> > On Fri, Jun 28, 2013 at 01:40:26PM +0100, Paul Eggleton wrote:
> >> On Friday 28 June 2013 14:28:56 Martin Jansa wrote:
> >>> It's failing in my world builds too now, you can see log here:
> >>> http://logs.nslu2-linux.org/buildlogs/oe/oe-shr-core-branches/log.world.2013
> >>> 0627_214856.log/bitbake.log
> >>>
> >>> Cheers,
> >>>
> >>> On Fri, Jun 28, 2013 at 2:07 PM, Jonathan Liu <net147@gmail.com> wrote:
> >>>> On 15/06/2013 10:06 AM, Jonathan Liu wrote:
> >>>>> The class is inheriting qmake2.bbclass which exports OE_QMAKE_QT_CONFIG
> >>>>> pointing to the qt4 qconfig.pri when it should be pointing to the
> >>>>> qt4-embedded qconfig.pri.
> >>>>>
> >>>>> Signed-off-by: Jonathan Liu <net147@gmail.com>
> >>>>> ---
> >>>>>
> >>>>>    meta/classes/qt4e.bbclass | 1 +
> >>>>>    1 file changed, 1 insertion(+)
> >>>>>
> >>>>> diff --git a/meta/classes/qt4e.bbclass b/meta/classes/qt4e.bbclass
> >>>>> index de2a68d..13b1050 100644
> >>>>> --- a/meta/classes/qt4e.bbclass
> >>>>> +++ b/meta/classes/qt4e.bbclass
> >>>>> @@ -9,6 +9,7 @@ QT_LIBINFIX = "E"
> >>>>>
> >>>>>    # override variables set by qmake-base to compile Qt/Embedded apps
> >>>>>    #
> >>>>>    export QMAKESPEC = "${STAGING_DATADIR}/${QT_DIR_**
> >>>>>
> >>>>> NAME}/mkspecs/${TARGET_OS}-oe-**g++"
> >>>>> +export OE_QMAKE_QT_CONFIG = "${STAGING_DATADIR}/${QT_DIR_**
> >>>>> NAME}/mkspecs/qconfig.pri"
> >>>>>
> >>>>>    export OE_QMAKE_INCDIR_QT = "${STAGING_INCDIR}/${QT_DIR_**NAME}"
> >>>>>    export OE_QMAKE_LIBDIR_QT = "${STAGING_LIBDIR}"
> >>>>>    export OE_QMAKE_LIBS_QT = "qt"
> >>>> Hi Saul,
> >>>>
> >>>> Do you have a log of the error you had building qt4-embedded with this
> >>>> patch?
> >> FWIW, I see the same error without this patch if I build qt4-embedded after
> >> building qt4-x11, so I don't know if this patch is really related to the
> >> problem or not.
> > It was building fine in world builds until 1-2 weeks ago, but it's
> > possible that I was just lucky to have it in right order.
> >
> 
> Repoduce the bug by STEPS:
> 
> bitbake qt4-x11-free
> bitbake qt4-embedded
> and build qt4-embedded failed.
> 
> //Hongxu

There is another qt4 issue which causes cmake-native to fail or was
cmake changed to require qt4 installed on host?


| CMake Warning at Modules/FindQt4.cmake:657 (message):
|   /usr/bin/qmake reported QT_INSTALL_LIBS as "/usr/lib/x86_64-linux-gnu" but
|   QtCore could not be found there.  Qt is NOT installed correctly for the
|   target build environment.
| Call Stack (most recent call first):
|   Tests/RunCMake/CMakeLists.txt:79 (find_package)
| 
| 
| -- Looking for Q_WS_X11
| -- Looking for Q_WS_X11 - not found
| -- Looking for Q_WS_WIN
| -- Looking for Q_WS_WIN - not found
| -- Looking for Q_WS_QWS
| -- Looking for Q_WS_QWS - not found
| -- Looking for Q_WS_MAC
| -- Looking for Q_WS_MAC - not found
| CMake Error at Modules/FindQt4.cmake:1032 (set_property):
|   set_property could not find TARGET Qt4::QtCore.  Perhaps it has not yet
|   been created.
| Call Stack (most recent call first):
|   Tests/RunCMake/CMakeLists.txt:79 (find_package)
| 
| 
| CMake Error at Modules/FindQt4.cmake:1037 (set_property):
|   set_property could not find TARGET Qt4::QtCore.  Perhaps it has not yet
|   been created.
| Call Stack (most recent call first):
|   Tests/RunCMake/CMakeLists.txt:79 (find_package)
| 
| 
| CMake Error at Modules/FindQt4.cmake:1040 (set_property):
|   set_property could not find TARGET Qt4::QtCore.  Perhaps it has not yet
|   been created.
| Call Stack (most recent call first):
|   Tests/RunCMake/CMakeLists.txt:79 (find_package)
| 
| 
| CMake Warning at Modules/FindQt4.cmake:657 (message):
|   /usr/bin/qmake reported QT_INSTALL_LIBS as "/usr/lib/x86_64-linux-gnu" but
|   QtCore could not be found there.  Qt is NOT installed correctly for the
|   target build environment.
| Call Stack (most recent call first):
|   Tests/CMakeLists.txt:263 (find_package)
| 
| 
| CMake Error at Modules/FindQt4.cmake:1032 (set_property):
|   set_property could not find TARGET Qt4::QtCore.  Perhaps it has not yet
|   been created.
| Call Stack (most recent call first):
|   Tests/CMakeLists.txt:263 (find_package)
| 
| 
| CMake Error at Modules/FindQt4.cmake:1037 (set_property):
|   set_property could not find TARGET Qt4::QtCore.  Perhaps it has not yet
|   been created.
| Call Stack (most recent call first):
|   Tests/CMakeLists.txt:263 (find_package)
| 
| 
| CMake Error at Modules/FindQt4.cmake:1040 (set_property):
|   set_property could not find TARGET Qt4::QtCore.  Perhaps it has not yet
|   been created.
| Call Stack (most recent call first):
|   Tests/CMakeLists.txt:263 (find_package)
| 
| 
| -- Could NOT find Qt4 (missing:  QT_MOC_EXECUTABLE QT_RCC_EXECUTABLE QT_UIC_EXECUTABLE QT_INCLUDE_DIR QT_LIBRARY_DIR QT_QTCORE_LIBRARY) (found version "4.8.1")
| -- Performing Test run_pic_test
| -- Performing Test run_pic_test - Success
| -- Configuring incomplete, errors occurred!
| ---------------------------------------------
| Error when bootstrapping CMake:
| Problem while running initial CMake
| ---------------------------------------------
| ERROR: Function failed: do_configure (log file is located at /home/jenkins/oe/shr-core-branches/shr-core/tmp-eglibc/work/x86_64-linux/cmake-native/2.8.11.1-r0/temp/log.do_configure.19730)
NOTE: recipe cmake-native-2.8.11.1-r0: task do_configure: Failed


> 
> 
> 
> 
> >
> >
> > _______________________________________________
> > Openembedded-core mailing list
> > Openembedded-core@lists.openembedded.org
> > http://lists.openembedded.org/mailman/listinfo/openembedded-core
> 

> _______________________________________________
> Openembedded-core mailing list
> Openembedded-core@lists.openembedded.org
> http://lists.openembedded.org/mailman/listinfo/openembedded-core
Paul Eggleton - June 30, 2013, 11:44 a.m.
On Sunday 30 June 2013 12:34:22 Martin Jansa wrote:
> There is another qt4 issue which causes cmake-native to fail or was
> cmake changed to require qt4 installed on host?

Certainly not. I had a report of this issue but wasn't able to reproduce it:

https://bugzilla.yoctoproject.org/show_bug.cgi?id=4565

Are you able to help me do that?
 
> | CMake Warning at Modules/FindQt4.cmake:657 (message):
> |   /usr/bin/qmake reported QT_INSTALL_LIBS as "/usr/lib/x86_64-linux-gnu"
> |   but
> |   QtCore could not be found there.  Qt is NOT installed correctly for the
> |   target build environment.
> | 
> | Call Stack (most recent call first):
> |   Tests/RunCMake/CMakeLists.txt:79 (find_package)
> | 
> | -- Looking for Q_WS_X11
> | -- Looking for Q_WS_X11 - not found
> | -- Looking for Q_WS_WIN
> | -- Looking for Q_WS_WIN - not found
> | -- Looking for Q_WS_QWS
> | -- Looking for Q_WS_QWS - not found
> | -- Looking for Q_WS_MAC
> | -- Looking for Q_WS_MAC - not found
> | 
> | CMake Error at Modules/FindQt4.cmake:1032 (set_property):
> |   set_property could not find TARGET Qt4::QtCore.  Perhaps it has not yet
> |   been created.
> | 
> | Call Stack (most recent call first):
> |   Tests/RunCMake/CMakeLists.txt:79 (find_package)
> | 
> | CMake Error at Modules/FindQt4.cmake:1037 (set_property):
> |   set_property could not find TARGET Qt4::QtCore.  Perhaps it has not yet
> |   been created.
> | 
> | Call Stack (most recent call first):
> |   Tests/RunCMake/CMakeLists.txt:79 (find_package)
> | 
> | CMake Error at Modules/FindQt4.cmake:1040 (set_property):
> |   set_property could not find TARGET Qt4::QtCore.  Perhaps it has not yet
> |   been created.
> | 
> | Call Stack (most recent call first):
> |   Tests/RunCMake/CMakeLists.txt:79 (find_package)
> | 
> | CMake Warning at Modules/FindQt4.cmake:657 (message):
> |   /usr/bin/qmake reported QT_INSTALL_LIBS as "/usr/lib/x86_64-linux-gnu"
> |   but
> |   QtCore could not be found there.  Qt is NOT installed correctly for the
> |   target build environment.
> | 
> | Call Stack (most recent call first):
> |   Tests/CMakeLists.txt:263 (find_package)
> | 
> | CMake Error at Modules/FindQt4.cmake:1032 (set_property):
> |   set_property could not find TARGET Qt4::QtCore.  Perhaps it has not yet
> |   been created.
> | 
> | Call Stack (most recent call first):
> |   Tests/CMakeLists.txt:263 (find_package)
> | 
> | CMake Error at Modules/FindQt4.cmake:1037 (set_property):
> |   set_property could not find TARGET Qt4::QtCore.  Perhaps it has not yet
> |   been created.
> | 
> | Call Stack (most recent call first):
> |   Tests/CMakeLists.txt:263 (find_package)
> | 
> | CMake Error at Modules/FindQt4.cmake:1040 (set_property):
> |   set_property could not find TARGET Qt4::QtCore.  Perhaps it has not yet
> |   been created.
> | 
> | Call Stack (most recent call first):
> |   Tests/CMakeLists.txt:263 (find_package)
> | 
> | -- Could NOT find Qt4 (missing:  QT_MOC_EXECUTABLE QT_RCC_EXECUTABLE
> | QT_UIC_EXECUTABLE QT_INCLUDE_DIR QT_LIBRARY_DIR QT_QTCORE_LIBRARY) (found
> | version "4.8.1") -- Performing Test run_pic_test
> | -- Performing Test run_pic_test - Success
> | -- Configuring incomplete, errors occurred!
> | ---------------------------------------------
> | Error when bootstrapping CMake:
> | Problem while running initial CMake
> | ---------------------------------------------
> | ERROR: Function failed: do_configure (log file is located at
> | /home/jenkins/oe/shr-core-branches/shr-core/tmp-eglibc/work/x86_64-linux/
> | cmake-native/2.8.11.1-r0/temp/log.do_configure.19730)
> NOTE: recipe cmake-native-2.8.11.1-r0: task do_configure: Failed
> 

Cheers,
Paul

Patch

diff --git a/meta/classes/qt4e.bbclass b/meta/classes/qt4e.bbclass
index de2a68d..13b1050 100644
--- a/meta/classes/qt4e.bbclass
+++ b/meta/classes/qt4e.bbclass
@@ -9,6 +9,7 @@  QT_LIBINFIX = "E"
 # override variables set by qmake-base to compile Qt/Embedded apps
 #
 export QMAKESPEC = "${STAGING_DATADIR}/${QT_DIR_NAME}/mkspecs/${TARGET_OS}-oe-g++"
+export OE_QMAKE_QT_CONFIG = "${STAGING_DATADIR}/${QT_DIR_NAME}/mkspecs/qconfig.pri"
 export OE_QMAKE_INCDIR_QT = "${STAGING_INCDIR}/${QT_DIR_NAME}"
 export OE_QMAKE_LIBDIR_QT = "${STAGING_LIBDIR}"
 export OE_QMAKE_LIBS_QT = "qt"