Patchwork scripts/buildenv-internal/sanity: Update to python 2.7.3 as a minimum

login
register
mail settings
Submitter Richard Purdie
Date June 7, 2013, 5:19 p.m.
Message ID <1370625553.6864.64.camel@ted>
Download mbox | patch
Permalink /patch/51375/
State Accepted
Commit 98abb113a02a4504ae969dbaf9844ab6539dcdb8
Headers show

Comments

Richard Purdie - June 7, 2013, 5:19 p.m.
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
Richard Purdie - June 7, 2013, 5:22 p.m.
On Fri, 2013-06-07 at 18:19 +0100, Richard Purdie wrote:
> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>

I should add that I'm aware that some of these commit messages are
missing full explaintions. I will add those before they get merged, I
just ran out of time today yet wanted to post them for others to see.
Its pretty clear what the patches are doing and why is covered in other
emails I've written today.

This series does depend on the bitbake series which I've posted to
bitbake-devel.

http://git.yoctoproject.org/cgit.cgi/poky-contrib/log/?h=rpurdie/t8

is the series (ignore the top two commits).

Cheers,

Richard

Patch

diff --git a/meta/classes/sanity.bbclass b/meta/classes/sanity.bbclass
index 3c70a7b..744e30d 100644
--- a/meta/classes/sanity.bbclass
+++ b/meta/classes/sanity.bbclass
@@ -382,11 +382,10 @@  def check_sanity(sanity_data):
 
     messages = ""
 
-    # Check the Python version, we now use Python 2.6 features in
-    # various classes
+    # Check the Python version, we now have a minimum of Python 2.7.3
     import sys
-    if sys.hexversion < 0x020600F0:
-        messages = messages + 'The system requires at least Python 2.6 to run. Please update your Python interpreter.\n'
+    if sys.hexversion < 0x020703F0:
+        messages = messages + 'The system requires at least Python 2.7.3 to run. Please update your Python interpreter.\n'
     # Check the python install is complete. glib-2.0-natives requries
     # xml.parsers.expat
     try:
diff --git a/scripts/oe-buildenv-internal b/scripts/oe-buildenv-internal
index a33698c..40d95b7 100755
--- a/scripts/oe-buildenv-internal
+++ b/scripts/oe-buildenv-internal
@@ -43,9 +43,9 @@  fi
 # Similarly, we now have code that doesn't parse correctly with older
 # versions of Python, and rather than fixing that and being eternally
 # vigilant for any other new feature use, just check the version here.
-py_v26_check=`python -c 'import sys; print sys.version_info >= (2,6,0)'`
+py_v26_check=`python -c 'import sys; print sys.version_info >= (2,7,3)'`
 if [ "$py_v26_check" != "True" ]; then
-	echo "BitBake requires Python 2.6 or later"
+	echo "BitBake requires Python 2.7.3 or later"
 	exit 1
 fi