Patchwork scripts/oe-buildenv-internal bitbake: Migrate python version checks

login
register
mail settings
Submitter Richard Purdie
Date June 7, 2013, 5:16 p.m.
Message ID <1370625401.6864.60.camel@ted>
Download mbox | patch
Permalink /patch/51365/
State Accepted
Commit ec7d9359b46b5058c52e2283a7235d2b9c89152a
Headers show

Comments

Richard Purdie - June 7, 2013, 5:16 p.m.
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---

Patch

diff --git a/scripts/bitbake b/scripts/bitbake
index a8c67bb..dde61c4 100755
--- a/scripts/bitbake
+++ b/scripts/bitbake
@@ -27,26 +27,6 @@  done
 [ $needpseudo = "0" ] && break
 done
 
-# Make sure we're not using python v3.x. This check can't go into
-# sanity.bbclass because bitbake's source code doesn't even pass
-# parsing stage when used with python v3, so we catch it here so we
-# can offer a meaningful error message.
-py_v3_check=`/usr/bin/env python --version 2>&1 | grep "Python 3"`
-if [ "$py_v3_check" != "" ]; then
-	echo "Bitbake is not compatible with python v3"
-	echo "Please set up python v2 as your default python interpreter"
-	exit 1
-fi
-
-# Similarly, we now have code that doesn't parse correctly with older
-# versions of Python, and rather than fixing that and being eternally
-# vigilant for any other new feature use, just check the version here.
-py_v26_check=`python -c 'import sys; print sys.version_info >= (2,6,0)'`
-if [ "$py_v26_check" != "True" ]; then
-	echo "BitBake requires Python 2.6 or later"
-	exit 1
-fi
-
 if [ ! -e conf/bblayers.conf ] ; then
     BDPRINT=""
     [ -n "$BUILDDIR" ] && BDPRINT=": $BUILDDIR"
diff --git a/scripts/oe-buildenv-internal b/scripts/oe-buildenv-internal
index 644df8f..a33698c 100755
--- a/scripts/oe-buildenv-internal
+++ b/scripts/oe-buildenv-internal
@@ -29,6 +29,26 @@  if [ ! -z "$OECORE_SDK_VERSION" ]; then
     return 1
 fi
 
+# Make sure we're not using python v3.x. This check can't go into
+# sanity.bbclass because bitbake's source code doesn't even pass
+# parsing stage when used with python v3, so we catch it here so we
+# can offer a meaningful error message.
+py_v3_check=`/usr/bin/env python --version 2>&1 | grep "Python 3"`
+if [ "$py_v3_check" != "" ]; then
+	echo "Bitbake is not compatible with python v3"
+	echo "Please set up python v2 as your default python interpreter"
+	exit 1
+fi
+
+# Similarly, we now have code that doesn't parse correctly with older
+# versions of Python, and rather than fixing that and being eternally
+# vigilant for any other new feature use, just check the version here.
+py_v26_check=`python -c 'import sys; print sys.version_info >= (2,6,0)'`
+if [ "$py_v26_check" != "True" ]; then
+	echo "BitBake requires Python 2.6 or later"
+	exit 1
+fi
+
 if [ "x$BDIR" = "x" ]; then
     if [ "x$1" = "x" ]; then
         BDIR="build"