Patchwork [bitbake-devel] bitbake: Bump minimum python version to 2.7.3

login
register
mail settings
Submitter Richard Purdie
Date June 7, 2013, 5:14 p.m.
Message ID <1370625286.6864.57.camel@ted>
Download mbox | patch
Permalink /patch/51359/
State New
Headers show

Comments

Richard Purdie - June 7, 2013, 5:14 p.m.
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
Alex Damian - June 10, 2013, 11:14 a.m.
On 06/07/2013 06:14 PM, Richard Purdie wrote:
> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
> ---
> diff --git a/bitbake/lib/bb/__init__.py b/bitbake/lib/bb/__init__.py
> index 3110c85..64491ff 100644
> --- a/bitbake/lib/bb/__init__.py
> +++ b/bitbake/lib/bb/__init__.py
> @@ -24,8 +24,8 @@
>   __version__ = "1.19.1"
>   
>   import sys
> -if sys.version_info < (2, 6, 0):
> -    raise RuntimeError("Sorry, python 2.6.0 or later is required for this version of bitbake")
> +if sys.version_info < (2, 7, 3):
> +    raise RuntimeError("Sorry, python 2.7.3 or later is required for this version of bitbake")

When this gets in, a bunch of messy code from xmlrpc will have to 
finally get its final rest.

Alex
>   
>   
>   class BBHandledException(Exception):
>
>
> _______________________________________________
> bitbake-devel mailing list
> bitbake-devel@lists.openembedded.org
> http://lists.openembedded.org/mailman/listinfo/bitbake-devel

Patch

diff --git a/bitbake/lib/bb/__init__.py b/bitbake/lib/bb/__init__.py
index 3110c85..64491ff 100644
--- a/bitbake/lib/bb/__init__.py
+++ b/bitbake/lib/bb/__init__.py
@@ -24,8 +24,8 @@ 
 __version__ = "1.19.1"
 
 import sys
-if sys.version_info < (2, 6, 0):
-    raise RuntimeError("Sorry, python 2.6.0 or later is required for this version of bitbake")
+if sys.version_info < (2, 7, 3):
+    raise RuntimeError("Sorry, python 2.7.3 or later is required for this version of bitbake")
 
 
 class BBHandledException(Exception):