Patchwork base/useradd/sstate: Ensure do_package setscene has correct fakeroot dependencies

login
register
mail settings
Submitter Richard Purdie
Date June 7, 2013, 4:51 p.m.
Message ID <1370623904.6864.49.camel@ted>
Download mbox | patch
Permalink /patch/51343/
State Accepted
Commit 0810ea2a72bdea67a3d8002c4e12fb20f45cf1d5
Headers show

Comments

Richard Purdie - June 7, 2013, 4:51 p.m.
The do_package_setscene task needs to depend on fakeroot in order to correctly
install its files.

We can whitelist the dependency in the sstate handling code for some
performance improvements since we only need this if we're installing the
package from sstate.

Also use an append operator in base.bbclass for clarity.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---

Patch

diff --git a/meta/classes/base.bbclass b/meta/classes/base.bbclass
index b1642a2..8af104f 100644
--- a/meta/classes/base.bbclass
+++ b/meta/classes/base.bbclass
@@ -501,6 +501,7 @@  python () {
         d.setVarFlag('do_package', 'fakeroot', 1)
         d.setVarFlag('do_package', 'umask', 022)
         d.setVarFlag('do_package_setscene', 'fakeroot', 1)
+        d.appendVarFlag('do_package_setscene', 'depends', ' virtual/fakeroot-native:do_populate_sysroot')
         d.setVarFlag('do_devshell', 'fakeroot', 1)
         d.appendVarFlag('do_devshell', 'depends', ' virtual/fakeroot-native:do_populate_sysroot')
     source_mirror_fetch = d.getVar('SOURCE_MIRROR_FETCH', 0)
diff --git a/meta/classes/sstate.bbclass b/meta/classes/sstate.bbclass
index 950be55..e74c642 100644
--- a/meta/classes/sstate.bbclass
+++ b/meta/classes/sstate.bbclass
@@ -711,7 +711,7 @@  def setscene_depvalid(task, taskdependees, notneeded, d):
 
         # This is due to the [depends] in useradd.bbclass complicating matters
         # The logic *is* reversed here due to the way hard setscene dependencies are injected
-        if taskdependees[task][1] == 'do_package' and taskdependees[dep][0].endswith(('shadow-native', 'shadow-sysroot', 'base-passwd')) and taskdependees[dep][1] == 'do_populate_sysroot':
+        if taskdependees[task][1] == 'do_package' and taskdependees[dep][0].endswith(('shadow-native', 'shadow-sysroot', 'base-passwd', 'pseudo-native')) and taskdependees[dep][1] == 'do_populate_sysroot':
             continue
 
         # Safe fallthrough default
diff --git a/meta/classes/useradd.bbclass b/meta/classes/useradd.bbclass
index fd61019..e50c889 100644
--- a/meta/classes/useradd.bbclass
+++ b/meta/classes/useradd.bbclass
@@ -150,7 +150,7 @@  USERADDSETSCENEDEPS = "${MLPREFIX}base-passwd:do_populate_sysroot_setscene shado
 USERADDSETSCENEDEPS_virtclass-cross = ""
 USERADDSETSCENEDEPS_class-native = ""
 USERADDSETSCENEDEPS_class-nativesdk = ""
-do_package_setscene[depends] = "${USERADDSETSCENEDEPS}"
+do_package_setscene[depends] += "${USERADDSETSCENEDEPS}"
 
 # Recipe parse-time sanity checks
 def update_useradd_after_parse(d):