Patchwork [meta-fsl-arm] amd-gpu-x11-bin: depends on libxrender

login
register
mail settings
Submitter Eric BENARD
Date May 26, 2013, 6:42 p.m.
Message ID <1369593747-3359-1-git-send-email-eric@eukrea.com>
Download mbox | patch
Permalink /patch/50551/
State Accepted
Delegated to: Otavio Salvador
Headers show

Comments

Eric BENARD - May 26, 2013, 6:42 p.m.
libEGL is linked against libxrender so we must depend on libxrender
else linking against libEGL may fail.

Signed-off-by: Eric Bénard <eric@eukrea.com>
---
 recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Otavio Salvador - May 28, 2013, 12:48 p.m.
On Sun, May 26, 2013 at 3:42 PM, Eric Bénard <eric@eukrea.com> wrote:

> libEGL is linked against libxrender so we must depend on libxrender
> else linking against libEGL may fail.
>
> Signed-off-by: Eric Bénard <eric@eukrea.com>
>

Applied in master, dylan-next and danny-next.

Patch

diff --git a/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb
index 1d54782..2dee47a 100644
--- a/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb
+++ b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb
@@ -8,7 +8,7 @@  PR = "r12"
 
 # FIXME: Replace for correct AMD license
 LIC_FILES_CHKSUM = "file://usr/include/VG/openvg.h;endline=30;md5=b0109611dd76961057d4c45ae6519802"
-DEPENDS = "virtual/libx11"
+DEPENDS = "virtual/libx11 libxrender"
 
 PROVIDES = "virtual/egl virtual/libgles1 virtual/libgles2"