Patchwork glib-2.0: drop dependency on python-argparse

login
register
mail settings
Submitter Ross Burton
Date May 13, 2013, 3:27 p.m.
Message ID <1368458850-5309-1-git-send-email-ross.burton@intel.com>
Download mbox | patch
Permalink /patch/49861/
State New
Headers show

Comments

Ross Burton - May 13, 2013, 3:27 p.m.
Since 2.20 the use of argparse was removed, so we don't need these dependencies
anymore.

Signed-off-by: Ross Burton <ross.burton@intel.com>
---
 meta/recipes-core/glib-2.0/glib-2.0_2.36.0.bb |    6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
Colin Walters - May 15, 2013, 6:36 p.m.
On Mon, 2013-05-13 at 16:27 +0100, Ross Burton wrote:
> Since 2.20 the use of argparse was removed, so we don't need these dependencies
> anymore.

You mean 2.30.  Other than that,

Reviewed-by: Colin Walters <walters@verbum.org>

Patch

diff --git a/meta/recipes-core/glib-2.0/glib-2.0_2.36.0.bb b/meta/recipes-core/glib-2.0/glib-2.0_2.36.0.bb
index a042972..0afb73b 100644
--- a/meta/recipes-core/glib-2.0/glib-2.0_2.36.0.bb
+++ b/meta/recipes-core/glib-2.0/glib-2.0_2.36.0.bb
@@ -2,9 +2,9 @@  require glib.inc
 
 PE = "1"
 
-DEPENDS += "libffi python-argparse-native zlib"
-DEPENDS_class-native += "libffi-native python-argparse-native"
-DEPENDS_class-nativesdk += "nativesdk-libffi python-argparse-native nativesdk-zlib ${BPN}-native"
+DEPENDS += "libffi zlib"
+DEPENDS_class-native += "libffi-native"
+DEPENDS_class-nativesdk += "nativesdk-libffi nativesdk-zlib ${BPN}-native"
 
 SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"