Patchwork [meta-fsl-arm] xserver-xorg: don't fail if files to remove are missing

login
register
mail settings
Submitter Eric BENARD
Date May 7, 2013, 10:07 a.m.
Message ID <1367921263-15582-1-git-send-email-eric@eukrea.com>
Download mbox | patch
Permalink /patch/49421/
State Rejected
Delegated to: Otavio Salvador
Headers show

Comments

Eric BENARD - May 7, 2013, 10:07 a.m.
Signed-off-by: Eric Bénard <eric@eukrea.com>
---
 recipes-graphics/xorg-xserver/xserver-xorg_1.11.4.bb |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Otavio Salvador - May 7, 2013, 1:20 p.m.
On Tue, May 7, 2013 at 7:07 AM, Eric Bénard <eric@eukrea.com> wrote:
> Signed-off-by: Eric Bénard <eric@eukrea.com>

I am worring about how you ended without the dri.h here. You weren't
suppose to lack this fine as we build with DRI enabled.

Did you change something in your local.conf?

--
Otavio Salvador                             O.S. Systems
E-mail: otavio@ossystems.com.br  http://www.ossystems.com.br
Mobile: +55 53 9981-7854              http://projetos.ossystems.com.br
Eric BENARD - May 7, 2013, 1:31 p.m.
Le Tue, 7 May 2013 10:20:43 -0300,
Otavio Salvador <otavio@ossystems.com.br> a écrit :

> On Tue, May 7, 2013 at 7:07 AM, Eric Bénard <eric@eukrea.com> wrote:
> > Signed-off-by: Eric Bénard <eric@eukrea.com>
> 
> I am worring about how you ended without the dri.h here. You weren't
> suppose to lack this fine as we build with DRI enabled.
> 
> Did you change something in your local.conf?
> 
nothing I'm on a plain config with oe-core + meta-oe + meta-fsl-arm*
all on dylan/HEAD

Eric
Eric BENARD - May 7, 2013, 1:36 p.m.
Le Tue, 7 May 2013 10:20:43 -0300,
Otavio Salvador <otavio@ossystems.com.br> a écrit :

> On Tue, May 7, 2013 at 7:07 AM, Eric Bénard <eric@eukrea.com> wrote:
> > Signed-off-by: Eric Bénard <eric@eukrea.com>
> 
> I am worring about how you ended without the dri.h here. You weren't
> suppose to lack this fine as we build with DRI enabled.
> 
> Did you change something in your local.conf?
> 
OK I miss opengl in DISTRO_FEATURES (I started with a base oe-core
configuration ;-)

Eric
Otavio Salvador - May 7, 2013, 1:36 p.m.
On Tue, May 7, 2013 at 10:31 AM, Eric Bénard <eric@eukrea.com> wrote:
> Le Tue, 7 May 2013 10:20:43 -0300,
> Otavio Salvador <otavio@ossystems.com.br> a écrit :
>
>> On Tue, May 7, 2013 at 7:07 AM, Eric Bénard <eric@eukrea.com> wrote:
>> > Signed-off-by: Eric Bénard <eric@eukrea.com>
>>
>> I am worring about how you ended without the dri.h here. You weren't
>> suppose to lack this fine as we build with DRI enabled.
>>
>> Did you change something in your local.conf?
>>
> nothing I'm on a plain config with oe-core + meta-oe + meta-fsl-arm*
> all on dylan/HEAD

Right, the key here is OE-Core. It does not provide the 'opengl'
DISTRO_FEATURE by default thus you end with it disabed.

--
Otavio Salvador                             O.S. Systems
E-mail: otavio@ossystems.com.br  http://www.ossystems.com.br
Mobile: +55 53 9981-7854              http://projetos.ossystems.com.br
Otavio Salvador - May 7, 2013, 1:37 p.m.
On Tue, May 7, 2013 at 10:36 AM, Eric Bénard <eric@eukrea.com> wrote:
> Le Tue, 7 May 2013 10:20:43 -0300,
> Otavio Salvador <otavio@ossystems.com.br> a écrit :
>
>> On Tue, May 7, 2013 at 7:07 AM, Eric Bénard <eric@eukrea.com> wrote:
>> > Signed-off-by: Eric Bénard <eric@eukrea.com>
>>
>> I am worring about how you ended without the dri.h here. You weren't
>> suppose to lack this fine as we build with DRI enabled.
>>
>> Did you change something in your local.conf?
>>
> OK I miss opengl in DISTRO_FEATURES (I started with a base oe-core
> configuration ;-)

I wonder what we should do here. In case it lacks opengl feature. What
you think?

--
Otavio Salvador                             O.S. Systems
E-mail: otavio@ossystems.com.br  http://www.ossystems.com.br
Mobile: +55 53 9981-7854              http://projetos.ossystems.com.br
Eric BENARD - May 7, 2013, 2:58 p.m.
Hi,

Le Tue, 7 May 2013 10:37:48 -0300,
Otavio Salvador <otavio@ossystems.com.br> a écrit :

> On Tue, May 7, 2013 at 10:36 AM, Eric Bénard <eric@eukrea.com> wrote:
> > Le Tue, 7 May 2013 10:20:43 -0300,
> > Otavio Salvador <otavio@ossystems.com.br> a écrit :
> >
> >> On Tue, May 7, 2013 at 7:07 AM, Eric Bénard <eric@eukrea.com> wrote:
> >> > Signed-off-by: Eric Bénard <eric@eukrea.com>
> >>
> >> I am worring about how you ended without the dri.h here. You weren't
> >> suppose to lack this fine as we build with DRI enabled.
> >>
> >> Did you change something in your local.conf?
> >>
> > OK I miss opengl in DISTRO_FEATURES (I started with a base oe-core
> > configuration ;-)
> 
> I wonder what we should do here. In case it lacks opengl feature. What
> you think?
> 
at least maybe we should write it in the README

Eric
Otavio Salvador - May 7, 2013, 3:10 p.m.
On Tue, May 7, 2013 at 11:58 AM, Eric Bénard <eric@eukrea.com> wrote:
> Hi,
>
> Le Tue, 7 May 2013 10:37:48 -0300,
> Otavio Salvador <otavio@ossystems.com.br> a écrit :
>
>> On Tue, May 7, 2013 at 10:36 AM, Eric Bénard <eric@eukrea.com> wrote:
>> > Le Tue, 7 May 2013 10:20:43 -0300,
>> > Otavio Salvador <otavio@ossystems.com.br> a écrit :
>> >
>> >> On Tue, May 7, 2013 at 7:07 AM, Eric Bénard <eric@eukrea.com> wrote:
>> >> > Signed-off-by: Eric Bénard <eric@eukrea.com>
>> >>
>> >> I am worring about how you ended without the dri.h here. You weren't
>> >> suppose to lack this fine as we build with DRI enabled.
>> >>
>> >> Did you change something in your local.conf?
>> >>
>> > OK I miss opengl in DISTRO_FEATURES (I started with a base oe-core
>> > configuration ;-)
>>
>> I wonder what we should do here. In case it lacks opengl feature. What
>> you think?
>>
> at least maybe we should write it in the README

I think we could handle it properly in the xserver-xorg package, it
could not remove the these files and not depends on the DRI things.

--
Otavio Salvador                             O.S. Systems
E-mail: otavio@ossystems.com.br  http://www.ossystems.com.br
Mobile: +55 53 9981-7854              http://projetos.ossystems.com.br
Gary Thomas - May 7, 2013, 3:16 p.m.
On 2013-05-07 09:10, Otavio Salvador wrote:
> On Tue, May 7, 2013 at 11:58 AM, Eric Bénard <eric@eukrea.com> wrote:
>> Hi,
>>
>> Le Tue, 7 May 2013 10:37:48 -0300,
>> Otavio Salvador <otavio@ossystems.com.br> a écrit :
>>
>>> On Tue, May 7, 2013 at 10:36 AM, Eric Bénard <eric@eukrea.com> wrote:
>>>> Le Tue, 7 May 2013 10:20:43 -0300,
>>>> Otavio Salvador <otavio@ossystems.com.br> a écrit :
>>>>
>>>>> On Tue, May 7, 2013 at 7:07 AM, Eric Bénard <eric@eukrea.com> wrote:
>>>>>> Signed-off-by: Eric Bénard <eric@eukrea.com>
>>>>>
>>>>> I am worring about how you ended without the dri.h here. You weren't
>>>>> suppose to lack this fine as we build with DRI enabled.
>>>>>
>>>>> Did you change something in your local.conf?
>>>>>
>>>> OK I miss opengl in DISTRO_FEATURES (I started with a base oe-core
>>>> configuration ;-)
>>>
>>> I wonder what we should do here. In case it lacks opengl feature. What
>>> you think?
>>>
>> at least maybe we should write it in the README
>
> I think we could handle it properly in the xserver-xorg package, it
> could not remove the these files and not depends on the DRI things.

While you are fixing this, can you please make this a .bbappend instead of
overriding/replacing the main recipe from OE-core?
Eric BENARD - May 7, 2013, 3:18 p.m.
Le Tue, 7 May 2013 12:10:00 -0300,
Otavio Salvador <otavio@ossystems.com.br> a écrit :

> On Tue, May 7, 2013 at 11:58 AM, Eric Bénard <eric@eukrea.com> wrote:
> > Hi,
> >
> > Le Tue, 7 May 2013 10:37:48 -0300,
> > Otavio Salvador <otavio@ossystems.com.br> a écrit :
> >
> >> On Tue, May 7, 2013 at 10:36 AM, Eric Bénard <eric@eukrea.com> wrote:
> >> > Le Tue, 7 May 2013 10:20:43 -0300,
> >> > Otavio Salvador <otavio@ossystems.com.br> a écrit :
> >> >
> >> >> On Tue, May 7, 2013 at 7:07 AM, Eric Bénard <eric@eukrea.com> wrote:
> >> >> > Signed-off-by: Eric Bénard <eric@eukrea.com>
> >> >>
> >> >> I am worring about how you ended without the dri.h here. You weren't
> >> >> suppose to lack this fine as we build with DRI enabled.
> >> >>
> >> >> Did you change something in your local.conf?
> >> >>
> >> > OK I miss opengl in DISTRO_FEATURES (I started with a base oe-core
> >> > configuration ;-)
> >>
> >> I wonder what we should do here. In case it lacks opengl feature. What
> >> you think?
> >>
> > at least maybe we should write it in the README
> 
> I think we could handle it properly in the xserver-xorg package, it
> could not remove the these files and not depends on the DRI things.
> 
well the README will at least tell people to enable that in a pure
oe-core configuration so that they get the 3D graphic drivers.

Eric
Otavio Salvador - May 7, 2013, 3:22 p.m.
On Tue, May 7, 2013 at 12:16 PM, Gary Thomas <gary@mlbassoc.com> wrote:
> On 2013-05-07 09:10, Otavio Salvador wrote:
>>
>> On Tue, May 7, 2013 at 11:58 AM, Eric Bénard <eric@eukrea.com> wrote:
>>>
>>> Hi,
>>>
>>> Le Tue, 7 May 2013 10:37:48 -0300,
>>> Otavio Salvador <otavio@ossystems.com.br> a écrit :
>>>
>>>> On Tue, May 7, 2013 at 10:36 AM, Eric Bénard <eric@eukrea.com> wrote:
>>>>>
>>>>> Le Tue, 7 May 2013 10:20:43 -0300,
>>>>> Otavio Salvador <otavio@ossystems.com.br> a écrit :
>>>>>
>>>>>> On Tue, May 7, 2013 at 7:07 AM, Eric Bénard <eric@eukrea.com> wrote:
>>>>>>>
>>>>>>> Signed-off-by: Eric Bénard <eric@eukrea.com>
>>>>>>
>>>>>>
>>>>>> I am worring about how you ended without the dri.h here. You weren't
>>>>>> suppose to lack this fine as we build with DRI enabled.
>>>>>>
>>>>>> Did you change something in your local.conf?
>>>>>>
>>>>> OK I miss opengl in DISTRO_FEATURES (I started with a base oe-core
>>>>> configuration ;-)
>>>>
>>>>
>>>> I wonder what we should do here. In case it lacks opengl feature. What
>>>> you think?
>>>>
>>> at least maybe we should write it in the README
>>
>>
>> I think we could handle it properly in the xserver-xorg package, it
>> could not remove the these files and not depends on the DRI things.
>
>
> While you are fixing this, can you please make this a .bbappend instead of
> overriding/replacing the main recipe from OE-core?

Not easy as we're  downgrading the version in use. So we need to have
the specific patches and like.

--
Otavio Salvador                             O.S. Systems
E-mail: otavio@ossystems.com.br  http://www.ossystems.com.br
Mobile: +55 53 9981-7854              http://projetos.ossystems.com.br
Otavio Salvador - May 7, 2013, 3:23 p.m.
On Tue, May 7, 2013 at 12:18 PM, Eric Bénard <eric@eukrea.com> wrote:
> Le Tue, 7 May 2013 12:10:00 -0300,
> Otavio Salvador <otavio@ossystems.com.br> a écrit :
>
>> On Tue, May 7, 2013 at 11:58 AM, Eric Bénard <eric@eukrea.com> wrote:
>> > Hi,
>> >
>> > Le Tue, 7 May 2013 10:37:48 -0300,
>> > Otavio Salvador <otavio@ossystems.com.br> a écrit :
>> >
>> >> On Tue, May 7, 2013 at 10:36 AM, Eric Bénard <eric@eukrea.com> wrote:
>> >> > Le Tue, 7 May 2013 10:20:43 -0300,
>> >> > Otavio Salvador <otavio@ossystems.com.br> a écrit :
>> >> >
>> >> >> On Tue, May 7, 2013 at 7:07 AM, Eric Bénard <eric@eukrea.com> wrote:
>> >> >> > Signed-off-by: Eric Bénard <eric@eukrea.com>
>> >> >>
>> >> >> I am worring about how you ended without the dri.h here. You weren't
>> >> >> suppose to lack this fine as we build with DRI enabled.
>> >> >>
>> >> >> Did you change something in your local.conf?
>> >> >>
>> >> > OK I miss opengl in DISTRO_FEATURES (I started with a base oe-core
>> >> > configuration ;-)
>> >>
>> >> I wonder what we should do here. In case it lacks opengl feature. What
>> >> you think?
>> >>
>> > at least maybe we should write it in the README
>>
>> I think we could handle it properly in the xserver-xorg package, it
>> could not remove the these files and not depends on the DRI things.
>>
> well the README will at least tell people to enable that in a pure
> oe-core configuration so that they get the 3D graphic drivers.

Could you please send the patch for the README?

While you're on it, are you willing to rework the xserver-xorg to work
without opengl?

--
Otavio Salvador                             O.S. Systems
E-mail: otavio@ossystems.com.br  http://www.ossystems.com.br
Mobile: +55 53 9981-7854              http://projetos.ossystems.com.br
Gary Thomas - May 7, 2013, 3:29 p.m.
On 2013-05-07 09:22, Otavio Salvador wrote:
> On Tue, May 7, 2013 at 12:16 PM, Gary Thomas <gary@mlbassoc.com> wrote:
>> On 2013-05-07 09:10, Otavio Salvador wrote:
>>>
>>> On Tue, May 7, 2013 at 11:58 AM, Eric Bénard <eric@eukrea.com> wrote:
>>>>
>>>> Hi,
>>>>
>>>> Le Tue, 7 May 2013 10:37:48 -0300,
>>>> Otavio Salvador <otavio@ossystems.com.br> a écrit :
>>>>
>>>>> On Tue, May 7, 2013 at 10:36 AM, Eric Bénard <eric@eukrea.com> wrote:
>>>>>>
>>>>>> Le Tue, 7 May 2013 10:20:43 -0300,
>>>>>> Otavio Salvador <otavio@ossystems.com.br> a écrit :
>>>>>>
>>>>>>> On Tue, May 7, 2013 at 7:07 AM, Eric Bénard <eric@eukrea.com> wrote:
>>>>>>>>
>>>>>>>> Signed-off-by: Eric Bénard <eric@eukrea.com>
>>>>>>>
>>>>>>>
>>>>>>> I am worring about how you ended without the dri.h here. You weren't
>>>>>>> suppose to lack this fine as we build with DRI enabled.
>>>>>>>
>>>>>>> Did you change something in your local.conf?
>>>>>>>
>>>>>> OK I miss opengl in DISTRO_FEATURES (I started with a base oe-core
>>>>>> configuration ;-)
>>>>>
>>>>>
>>>>> I wonder what we should do here. In case it lacks opengl feature. What
>>>>> you think?
>>>>>
>>>> at least maybe we should write it in the README
>>>
>>>
>>> I think we could handle it properly in the xserver-xorg package, it
>>> could not remove the these files and not depends on the DRI things.
>>
>>
>> While you are fixing this, can you please make this a .bbappend instead of
>> overriding/replacing the main recipe from OE-core?
>
> Not easy as we're  downgrading the version in use. So we need to have
> the specific patches and like.

Yes I see that now - sorry for the noise, but there may need to be a patch
for this one as well as xkbcomp currently goes missing in the images because
of a change in OE-core.
Otavio Salvador - May 7, 2013, 3:34 p.m.
On Tue, May 7, 2013 at 12:29 PM, Gary Thomas <gary@mlbassoc.com> wrote:
> On 2013-05-07 09:22, Otavio Salvador wrote:
>>
>> On Tue, May 7, 2013 at 12:16 PM, Gary Thomas <gary@mlbassoc.com> wrote:
>>>
>>> On 2013-05-07 09:10, Otavio Salvador wrote:
>>>>
>>>>
>>>> On Tue, May 7, 2013 at 11:58 AM, Eric Bénard <eric@eukrea.com> wrote:
>>>>>
>>>>>
>>>>> Hi,
>>>>>
>>>>> Le Tue, 7 May 2013 10:37:48 -0300,
>>>>> Otavio Salvador <otavio@ossystems.com.br> a écrit :
>>>>>
>>>>>> On Tue, May 7, 2013 at 10:36 AM, Eric Bénard <eric@eukrea.com> wrote:
>>>>>>>
>>>>>>>
>>>>>>> Le Tue, 7 May 2013 10:20:43 -0300,
>>>>>>> Otavio Salvador <otavio@ossystems.com.br> a écrit :
>>>>>>>
>>>>>>>> On Tue, May 7, 2013 at 7:07 AM, Eric Bénard <eric@eukrea.com> wrote:
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> Signed-off-by: Eric Bénard <eric@eukrea.com>
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> I am worring about how you ended without the dri.h here. You weren't
>>>>>>>> suppose to lack this fine as we build with DRI enabled.
>>>>>>>>
>>>>>>>> Did you change something in your local.conf?
>>>>>>>>
>>>>>>> OK I miss opengl in DISTRO_FEATURES (I started with a base oe-core
>>>>>>> configuration ;-)
>>>>>>
>>>>>>
>>>>>>
>>>>>> I wonder what we should do here. In case it lacks opengl feature. What
>>>>>> you think?
>>>>>>
>>>>> at least maybe we should write it in the README
>>>>
>>>>
>>>>
>>>> I think we could handle it properly in the xserver-xorg package, it
>>>> could not remove the these files and not depends on the DRI things.
>>>
>>>
>>>
>>> While you are fixing this, can you please make this a .bbappend instead
>>> of
>>> overriding/replacing the main recipe from OE-core?
>>
>>
>> Not easy as we're  downgrading the version in use. So we need to have
>> the specific patches and like.
>
>
> Yes I see that now - sorry for the noise, but there may need to be a patch
> for this one as well as xkbcomp currently goes missing in the images because
> of a change in OE-core.

I didn't follow you, can you elaborate it a bit more?

--
Otavio Salvador                             O.S. Systems
E-mail: otavio@ossystems.com.br  http://www.ossystems.com.br
Mobile: +55 53 9981-7854              http://projetos.ossystems.com.br

Patch

diff --git a/recipes-graphics/xorg-xserver/xserver-xorg_1.11.4.bb b/recipes-graphics/xorg-xserver/xserver-xorg_1.11.4.bb
index 59a751b..b2e14e5 100644
--- a/recipes-graphics/xorg-xserver/xserver-xorg_1.11.4.bb
+++ b/recipes-graphics/xorg-xserver/xserver-xorg_1.11.4.bb
@@ -17,7 +17,7 @@  PR = "${INC_PR}.0"
 
 do_install_append_mx6 () {
     # FIXME: This is a workaround to ensure we use Vivante DRI
-    rm ${D}${includedir}/xorg/dri.h \
+    rm -f ${D}${includedir}/xorg/dri.h \
        ${D}${includedir}/xorg/sarea.h \
        ${D}${includedir}/xorg/dristruct.h
 }