Patchwork [meta-fsl-arm,v2,6/6] xf86-video-imxfb-vivante: Add rdepends on libvivante-dri-mx6

login
register
mail settings
Submitter Otavio Salvador
Date April 22, 2013, 12:30 p.m.
Message ID <1366633835-17563-6-git-send-email-otavio@ossystems.com.br>
Download mbox | patch
Permalink /patch/48639/
State Accepted
Delegated to: Otavio Salvador
Headers show

Comments

Otavio Salvador - April 22, 2013, 12:30 p.m.
The driver try to dynamically load the DRI support code and it needs
to be available in rootfs for use in Xorg driver.

Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
---
Changes in v2: None

 recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_1.1.0.bb | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
Gary Thomas - April 23, 2013, 3:09 p.m.
On 2013-04-22 06:30, Otavio Salvador wrote:
> The driver try to dynamically load the DRI support code and it needs
> to be available in rootfs for use in Xorg driver.
>
> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
> ---
> Changes in v2: None
>
>   recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_1.1.0.bb | 5 ++++-
>   1 file changed, 4 insertions(+), 1 deletion(-)
>
> diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_1.1.0.bb b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_1.1.0.bb
> index 22e8d6e..36f56f2 100644
> --- a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_1.1.0.bb
> +++ b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_1.1.0.bb
> @@ -36,7 +36,10 @@ do_install_append () {
>   	find ${D}${includedir} -type f -exec chmod 660 {} \;
>   }
>
> -RDEPENDS_${PN} += "xserver-xorg-module-exa mesa-driver-swrast xf86-dri-vivante"
> +RDEPENDS_${PN} += "libvivante-dri-mx6 \
> +                   xserver-xorg-module-exa \
> +                   mesa-driver-swrast \
> +                   xf86-dri-vivante"
>
>   # Add the ABI dependency at package generation time, as otherwise bitbake will
>   # attempt to find a provider for it (and fail) when it does the parse.
>

I'm still seeing what seem to be DRI related errors even after this change.
When I start the X server, I get this:

(EE) Failed to load module "extmod" (module does not exist, 0)
(EE) Failed to load module "dbe" (module does not exist, 0)
[drm] Initialized drm 1.1.0 20060810
[drm] Initialized vivante 1.0.0 20120216 on minor 0
(EE) AIGLX error: vivante exports no extensions (/usr/lib/dri/vivante_dri.so: undefined symbol: __driDriverExtensions)

Are these errors something to worry about?
He Zheng - April 23, 2013, 4:48 p.m.
Gary,

From my understanding, this error is just fine.
You still can get HW acceleration with this error since it is related to
server side.

Thanks,
He


On Tue, Apr 23, 2013 at 8:09 AM, Gary Thomas <gary@mlbassoc.com> wrote:

> On 2013-04-22 06:30, Otavio Salvador wrote:
>
>> The driver try to dynamically load the DRI support code and it needs
>> to be available in rootfs for use in Xorg driver.
>>
>> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
>> ---
>> Changes in v2: None
>>
>>   recipes-graphics/xorg-driver/x**f86-video-imxfb-vivante_1.1.0.**bb<http://xf86-video-imxfb-vivante_1.1.0.bb>| 5 ++++-
>>   1 file changed, 4 insertions(+), 1 deletion(-)
>>
>> diff --git a/recipes-graphics/xorg-**driver/xf86-video-imxfb-**
>> vivante_1.1.0.bb <http://xf86-video-imxfb-vivante_1.1.0.bb>b/recipes-graphics/xorg-
>> **driver/xf86-video-imxfb-**vivante_1.1.0.bb<http://xf86-video-imxfb-vivante_1.1.0.bb>
>> index 22e8d6e..36f56f2 100644
>> --- a/recipes-graphics/xorg-**driver/xf86-video-imxfb-**vivante_1.1.0.bb<http://xf86-video-imxfb-vivante_1.1.0.bb>
>> +++ b/recipes-graphics/xorg-**driver/xf86-video-imxfb-**vivante_1.1.0.bb<http://xf86-video-imxfb-vivante_1.1.0.bb>
>> @@ -36,7 +36,10 @@ do_install_append () {
>>         find ${D}${includedir} -type f -exec chmod 660 {} \;
>>   }
>>
>> -RDEPENDS_${PN} += "xserver-xorg-module-exa mesa-driver-swrast
>> xf86-dri-vivante"
>> +RDEPENDS_${PN} += "libvivante-dri-mx6 \
>> +                   xserver-xorg-module-exa \
>> +                   mesa-driver-swrast \
>> +                   xf86-dri-vivante"
>>
>>   # Add the ABI dependency at package generation time, as otherwise
>> bitbake will
>>   # attempt to find a provider for it (and fail) when it does the parse.
>>
>>
> I'm still seeing what seem to be DRI related errors even after this change.
> When I start the X server, I get this:
>
> (EE) Failed to load module "extmod" (module does not exist, 0)
> (EE) Failed to load module "dbe" (module does not exist, 0)
> [drm] Initialized drm 1.1.0 20060810
> [drm] Initialized vivante 1.0.0 20120216 on minor 0
> (EE) AIGLX error: vivante exports no extensions
> (/usr/lib/dri/vivante_dri.so: undefined symbol: __driDriverExtensions)
>
> Are these errors something to worry about?
>
> --
> ------------------------------**------------------------------
> Gary Thomas                 |  Consulting for the
> MLB Associates              |    Embedded world
> ------------------------------**------------------------------
>
> ______________________________**_________________
> meta-freescale mailing list
> meta-freescale@yoctoproject.**org <meta-freescale@yoctoproject.org>
> https://lists.yoctoproject.**org/listinfo/meta-freescale<https://lists.yoctoproject.org/listinfo/meta-freescale>
>
Gary Thomas - April 25, 2013, 3:19 p.m.
On 2013-04-23 10:48, He Zheng wrote:
> Gary,
>
>  From my understanding, this error is just fine.
> You still can get HW acceleration with this error since it is related to server side.

I don't think so - there was an additional error I missed before:
   (EE) AIGLX: reverting to software rendering

Sounds to me like the hardware acceleration is not being used.

> On Tue, Apr 23, 2013 at 8:09 AM, Gary Thomas <gary@mlbassoc.com <mailto:gary@mlbassoc.com>> wrote:
>
>     On 2013-04-22 06:30, Otavio Salvador wrote:
>
>         The driver try to dynamically load the DRI support code and it needs
>         to be available in rootfs for use in Xorg driver.
>
>         Signed-off-by: Otavio Salvador <otavio@ossystems.com.br <mailto:otavio@ossystems.com.br>>
>         ---
>         Changes in v2: None
>
>            recipes-graphics/xorg-driver/x__f86-video-imxfb-vivante_1.1.0.__bb <http://xf86-video-imxfb-vivante_1.1.0.bb> | 5 ++++-
>            1 file changed, 4 insertions(+), 1 deletion(-)
>
>         diff --git a/recipes-graphics/xorg-__driver/xf86-video-imxfb-__vivante_1.1.0.bb <http://xf86-video-imxfb-vivante_1.1.0.bb>
>         b/recipes-graphics/xorg-__driver/xf86-video-imxfb-__vivante_1.1.0.bb <http://xf86-video-imxfb-vivante_1.1.0.bb>
>         index 22e8d6e..36f56f2 100644
>         --- a/recipes-graphics/xorg-__driver/xf86-video-imxfb-__vivante_1.1.0.bb <http://xf86-video-imxfb-vivante_1.1.0.bb>
>         +++ b/recipes-graphics/xorg-__driver/xf86-video-imxfb-__vivante_1.1.0.bb <http://xf86-video-imxfb-vivante_1.1.0.bb>
>         @@ -36,7 +36,10 @@ do_install_append () {
>                  find ${D}${includedir} -type f -exec chmod 660 {} \;
>            }
>
>         -RDEPENDS_${PN} += "xserver-xorg-module-exa mesa-driver-swrast xf86-dri-vivante"
>         +RDEPENDS_${PN} += "libvivante-dri-mx6 \
>         +                   xserver-xorg-module-exa \
>         +                   mesa-driver-swrast \
>         +                   xf86-dri-vivante"
>
>            # Add the ABI dependency at package generation time, as otherwise bitbake will
>            # attempt to find a provider for it (and fail) when it does the parse.
>
>
>     I'm still seeing what seem to be DRI related errors even after this change.
>     When I start the X server, I get this:
>
>     (EE) Failed to load module "extmod" (module does not exist, 0)
>     (EE) Failed to load module "dbe" (module does not exist, 0)
>     [drm] Initialized drm 1.1.0 20060810
>     [drm] Initialized vivante 1.0.0 20120216 on minor 0
>     (EE) AIGLX error: vivante exports no extensions (/usr/lib/dri/vivante_dri.so: undefined symbol: __driDriverExtensions)
>
>     Are these errors something to worry about?
>
>     --
>     ------------------------------__------------------------------
>     Gary Thomas                 |  Consulting for the
>     MLB Associates              |    Embedded world
>     ------------------------------__------------------------------
>
>     _________________________________________________
>     meta-freescale mailing list
>     meta-freescale@yoctoproject.__org <mailto:meta-freescale@yoctoproject.org>
>     https://lists.yoctoproject.__org/listinfo/meta-freescale <https://lists.yoctoproject.org/listinfo/meta-freescale>
>
>
He Zheng - April 25, 2013, 6:53 p.m.
Have you run any benchmarks after getting those errors?


On Fri, Apr 26, 2013 at 12:19 AM, Gary Thomas <gary@mlbassoc.com> wrote:

> On 2013-04-23 10:48, He Zheng wrote:
>
>> Gary,
>>
>>  From my understanding, this error is just fine.
>> You still can get HW acceleration with this error since it is related to
>> server side.
>>
>
> I don't think so - there was an additional error I missed before:
>   (EE) AIGLX: reverting to software rendering
>
> Sounds to me like the hardware acceleration is not being used.
>
>  On Tue, Apr 23, 2013 at 8:09 AM, Gary Thomas <gary@mlbassoc.com <mailto:
>> gary@mlbassoc.com>> wrote:
>>
>>     On 2013-04-22 06:30, Otavio Salvador wrote:
>>
>>         The driver try to dynamically load the DRI support code and it
>> needs
>>         to be available in rootfs for use in Xorg driver.
>>
>>         Signed-off-by: Otavio Salvador <otavio@ossystems.com.br <mailto:
>> otavio@ossystems.com.**br <otavio@ossystems.com.br>>>
>>
>>         ---
>>         Changes in v2: None
>>
>>            recipes-graphics/xorg-driver/**x__f86-video-imxfb-vivante_1.**1.0.__bb
>> <http://xf86-video-imxfb-**vivante_1.1.0.bb<http://xf86-video-imxfb-vivante_1.1.0.bb>>
>> | 5 ++++-
>>
>>            1 file changed, 4 insertions(+), 1 deletion(-)
>>
>>         diff --git a/recipes-graphics/xorg-__**driver/xf86-video-imxfb-__
>> **vivante_1.1.0.bb <http://xf86-video-imxfb-__vivante_1.1.0.bb> <
>> http://xf86-video-imxfb-**vivante_1.1.0.bb<http://xf86-video-imxfb-vivante_1.1.0.bb>
>> >
>>         b/recipes-graphics/xorg-__**driver/xf86-video-imxfb-__**
>> vivante_1.1.0.bb <http://xf86-video-imxfb-__vivante_1.1.0.bb> <
>> http://xf86-video-imxfb-**vivante_1.1.0.bb<http://xf86-video-imxfb-vivante_1.1.0.bb>
>> >
>>         index 22e8d6e..36f56f2 100644
>>         --- a/recipes-graphics/xorg-__**driver/xf86-video-imxfb-__**
>> vivante_1.1.0.bb <http://xf86-video-imxfb-__vivante_1.1.0.bb> <
>> http://xf86-video-imxfb-**vivante_1.1.0.bb<http://xf86-video-imxfb-vivante_1.1.0.bb>
>> >
>>         +++ b/recipes-graphics/xorg-__**driver/xf86-video-imxfb-__**
>> vivante_1.1.0.bb <http://xf86-video-imxfb-__vivante_1.1.0.bb> <
>> http://xf86-video-imxfb-**vivante_1.1.0.bb<http://xf86-video-imxfb-vivante_1.1.0.bb>
>> >
>>
>>         @@ -36,7 +36,10 @@ do_install_append () {
>>                  find ${D}${includedir} -type f -exec chmod 660 {} \;
>>            }
>>
>>         -RDEPENDS_${PN} += "xserver-xorg-module-exa mesa-driver-swrast
>> xf86-dri-vivante"
>>         +RDEPENDS_${PN} += "libvivante-dri-mx6 \
>>         +                   xserver-xorg-module-exa \
>>         +                   mesa-driver-swrast \
>>         +                   xf86-dri-vivante"
>>
>>            # Add the ABI dependency at package generation time, as
>> otherwise bitbake will
>>            # attempt to find a provider for it (and fail) when it does
>> the parse.
>>
>>
>>     I'm still seeing what seem to be DRI related errors even after this
>> change.
>>     When I start the X server, I get this:
>>
>>     (EE) Failed to load module "extmod" (module does not exist, 0)
>>     (EE) Failed to load module "dbe" (module does not exist, 0)
>>     [drm] Initialized drm 1.1.0 20060810
>>     [drm] Initialized vivante 1.0.0 20120216 on minor 0
>>     (EE) AIGLX error: vivante exports no extensions
>> (/usr/lib/dri/vivante_dri.so: undefined symbol: __driDriverExtensions)
>>
>>     Are these errors something to worry about?
>>
>>     --
>>     ------------------------------**__----------------------------**--
>>
>>     Gary Thomas                 |  Consulting for the
>>     MLB Associates              |    Embedded world
>>     ------------------------------**__----------------------------**--
>>
>>     ______________________________**___________________
>>     meta-freescale mailing list
>>     meta-freescale@yoctoproject.__**org <mailto:meta-freescale@**
>> yoctoproject.org <meta-freescale@yoctoproject.org>>
>>     https://lists.yoctoproject.__**org/listinfo/meta-freescale <
>> https://lists.yoctoproject.**org/listinfo/meta-freescale<https://lists.yoctoproject.org/listinfo/meta-freescale>
>> >
>>
>>
>>
> --
> ------------------------------**------------------------------
> Gary Thomas                 |  Consulting for the
> MLB Associates              |    Embedded world
> ------------------------------**------------------------------
>

Patch

diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_1.1.0.bb b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_1.1.0.bb
index 22e8d6e..36f56f2 100644
--- a/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_1.1.0.bb
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb-vivante_1.1.0.bb
@@ -36,7 +36,10 @@  do_install_append () {
 	find ${D}${includedir} -type f -exec chmod 660 {} \;
 }
 
-RDEPENDS_${PN} += "xserver-xorg-module-exa mesa-driver-swrast xf86-dri-vivante"
+RDEPENDS_${PN} += "libvivante-dri-mx6 \
+                   xserver-xorg-module-exa \
+                   mesa-driver-swrast \
+                   xf86-dri-vivante"
 
 # Add the ABI dependency at package generation time, as otherwise bitbake will
 # attempt to find a provider for it (and fail) when it does the parse.