[v3,2/5] python3-blivet: use setuptools_legacy

Message ID 20220307170104.3671129-2-ross.burton@arm.com
State New
Headers show
Series [v3,1/5] python3-blivetgui: use setuptools_legacy | expand

Commit Message

Ross Burton March 7, 2022, 5:01 p.m. UTC
The setup.py installs to arbitrary target paths, so can't use the new
bdist_wheel installation method.

Reverts daba6521f which was a sympton of the bad usage.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 .../python-blivet/python3-blivet_3.4.3.bb                 | 8 +-------
 1 file changed, 1 insertion(+), 7 deletions(-)

Patch

diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb
index 1d2add87a0..bd57604f26 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb
@@ -19,16 +19,10 @@  SRC_URI += "\
 "
 SRC_URI[sha256sum] = "1b05b77f3ee35d82c7a577a168c9ba0204d3e9a87eb1975e5f9af47700eeff48"
 
-inherit pypi features_check systemd setuptools3
+inherit pypi features_check systemd setuptools3_legacy
 
 REQUIRED_DISTRO_FEATURES = "systemd"
 
-do_install:append() {
-    mv ${D}${PYTHON_SITEPACKAGES_DIR}${exec_prefix}/* ${D}${exec_prefix}
-    mv ${D}${PYTHON_SITEPACKAGES_DIR}${sysconfdir} ${D}
-    mv ${D}${PYTHON_SITEPACKAGES_DIR}${nonarch_base_libdir} ${D}
-}
-
 RDEPENDS:${PN} += "python3-pykickstart python3-pyudev \
                   parted python3-pyparted multipath-tools \
                   lsof cryptsetup libblockdev \