Patchwork [2/7] update-alternatives: Ensure DEPENDS is correct in multilib case

login
register
mail settings
Submitter Richard Purdie
Date April 15, 2013, 11:07 a.m.
Message ID <1366024028-24911-3-git-send-email-richard.purdie@linuxfoundation.org>
Download mbox | patch
Permalink /patch/48209/
State Accepted
Commit b45615a6ad713728b817697104421f6c90dfd782
Headers show

Comments

Richard Purdie - April 15, 2013, 11:07 a.m.
Ensure that the DEPENDS we're adding is correct in the multilib case by
including MLPREFIX, fixing unnecessary dependencies in those images.

Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
---
 meta/classes/update-alternatives.bbclass |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/meta/classes/update-alternatives.bbclass b/meta/classes/update-alternatives.bbclass
index f7ad4d4..45f4291 100644
--- a/meta/classes/update-alternatives.bbclass
+++ b/meta/classes/update-alternatives.bbclass
@@ -169,7 +169,7 @@  def gen_updatealternativesvardeps(d):
 
 def ua_extend_depends(d):
     if not 'virtual/update-alternatives' in d.getVar('PROVIDES', True):
-        d.appendVar('DEPENDS', ' virtual/update-alternatives')
+        d.appendVar('DEPENDS', ' virtual/${MLPREFIX}update-alternatives')
 
 python __anonymous() {
     # Update Alternatives only works on target packages...