[2/2] python3-blivet: use setuptools_legacy

Message ID 20220307121112.1844760-2-ross.burton@arm.com
State New
Headers show
Series [1/2] python3-blivetgui: use setuptools_legacy | expand

Commit Message

Ross Burton March 7, 2022, 12:11 p.m. UTC
The setup.py installs to arbitrary target paths, so can't use the new
bdist_wheel installation method.

Reverts daba6521f which was a sympton of the bad usage.

Signed-off-by: Ross Burton <ross.burton@arm.com>
---
 .../python-blivet/python3-blivet_3.4.3.bb                 | 8 +-------
 1 file changed, 1 insertion(+), 7 deletions(-)

Comments

Khem Raj March 7, 2022, 4:43 p.m. UTC | #1
please rebase on master-next

On Mon, Mar 7, 2022 at 4:11 AM Ross Burton <ross@burtonini.com> wrote:
>
> The setup.py installs to arbitrary target paths, so can't use the new
> bdist_wheel installation method.
>
> Reverts daba6521f which was a sympton of the bad usage.
>
> Signed-off-by: Ross Burton <ross.burton@arm.com>
> ---
>  .../python-blivet/python3-blivet_3.4.3.bb                 | 8 +-------
>  1 file changed, 1 insertion(+), 7 deletions(-)
>
> diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb
> index fcadf130c9..bd57604f26 100644
> --- a/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb
> +++ b/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb
> @@ -19,16 +19,10 @@ SRC_URI += "\
>  "
>  SRC_URI[sha256sum] = "1b05b77f3ee35d82c7a577a168c9ba0204d3e9a87eb1975e5f9af47700eeff48"
>
> -inherit pypi features_check systemd setuptools3
> +inherit pypi features_check systemd setuptools3_legacy
>
>  REQUIRED_DISTRO_FEATURES = "systemd"
>
> -do_install:append() {
> -    mv ${D}${PYTHON_SITEPACKAGES_DIR}${exec_prefix}/* ${D}${exec_prefix}
> -    mv ${D}${PYTHON_SITEPACKAGES_DIR}${sysconfdir} ${D}
> -    mv ${D}${PYTHON_SITEPACKAGES_DIR}${base_libdir} ${D}
> -}
> -
>  RDEPENDS:${PN} += "python3-pykickstart python3-pyudev \
>                    parted python3-pyparted multipath-tools \
>                    lsof cryptsetup libblockdev \
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#95848): https://lists.openembedded.org/g/openembedded-devel/message/95848
> Mute This Topic: https://lists.openembedded.org/mt/89610238/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>

Patch

diff --git a/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb b/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb
index fcadf130c9..bd57604f26 100644
--- a/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb
+++ b/meta-python/recipes-extended/python-blivet/python3-blivet_3.4.3.bb
@@ -19,16 +19,10 @@  SRC_URI += "\
 "
 SRC_URI[sha256sum] = "1b05b77f3ee35d82c7a577a168c9ba0204d3e9a87eb1975e5f9af47700eeff48"
 
-inherit pypi features_check systemd setuptools3
+inherit pypi features_check systemd setuptools3_legacy
 
 REQUIRED_DISTRO_FEATURES = "systemd"
 
-do_install:append() {
-    mv ${D}${PYTHON_SITEPACKAGES_DIR}${exec_prefix}/* ${D}${exec_prefix}
-    mv ${D}${PYTHON_SITEPACKAGES_DIR}${sysconfdir} ${D}
-    mv ${D}${PYTHON_SITEPACKAGES_DIR}${base_libdir} ${D}
-}
-
 RDEPENDS:${PN} += "python3-pykickstart python3-pyudev \
                   parted python3-pyparted multipath-tools \
                   lsof cryptsetup libblockdev \