Patchwork alsa-tools: Update autotools.patch

login
register
mail settings
Submitter Cristian Iorga
Date March 13, 2013, 11:02 a.m.
Message ID <969F26A8BAB325438E7EB80D3C3134FB16216497@IRSMSX102.ger.corp.intel.com>
Download mbox | patch
Permalink /patch/46139/
State New
Headers show

Comments

Cristian Iorga - March 13, 2013, 11:02 a.m.
Hello Nobuhiro-san,

Can you please explain your patch?
As far as I know, the alsa-tools present as targets were all buildable.
This was verified by me at last update.

Regards,
Cristian

-----Original Message-----
From: Nobuhiro Iwamatsu [mailto:iwamatsu@nigauri.org] On Behalf Of Nobuhiro Iwamatsu
Sent: Wednesday, March 13, 2013 4:09 AM
To: openembedded-core@lists.openembedded.org
Cc: Iorga, Cristian; Nobuhiro Iwamatsu
Subject: [PATCH] alsa-tools: Update autotools.patch

envy24control, rmedigicontrol and echomixer require gtk+-2.0.
Remove envy24control rmedigicontrol and echomixer from list of tools.

CC: Cristian Iorga <cristian.iorga@intel.com>
Signed-off-by: Nobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>
---
 .../alsa/alsa-tools/autotools.patch                |    6 +++---
 .../recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb |    2 +-
 2 files changed, 4 insertions(+), 4 deletions(-)
Nobuhiro Iwamatsu - March 14, 2013, 1:43 a.m.
Hi,

When I build alsa-tools, I could not build this with following error:
----
checking for i586-oe-linux-pkg-config... no
checking for pkg-config...
/home/iwamatsu/yocto/alsa/tmp-eglibc/sysroots/x86_64-linux/usr/bin/pkg-config
configure: WARNING: using cross tools not prefixed with host triplet
checking pkg-config is at least version 0.9.0... yes
checking for ENVY24CONTROL... no
configure: error: Package requirements (gtk+-2.0 alsa >= 0.9.0) were not met:

No package 'gtk+-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables ENVY24CONTROL_CFLAGS
and ENVY24CONTROL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
make: *** [all] Error 1
----

The original patch is deleted from the list in the software depending on gtk.
However, envy24control etc. are dependent on gtk.
The patch which I created deletes these from a list.
I checked with openembedded-core (375ed2eaef10dd7d8f46badca6d779708724e5f6).

Does my environment have a problem?

Best regards,
  Nobuhiro

On Wed, Mar 13, 2013 at 8:02 PM, Iorga, Cristian
<cristian.iorga@intel.com> wrote:
> Hello Nobuhiro-san,
>
> Can you please explain your patch?
> As far as I know, the alsa-tools present as targets were all buildable.
> This was verified by me at last update.
>
> Regards,
> Cristian
>
> -----Original Message-----
> From: Nobuhiro Iwamatsu [mailto:iwamatsu@nigauri.org] On Behalf Of Nobuhiro Iwamatsu
> Sent: Wednesday, March 13, 2013 4:09 AM
> To: openembedded-core@lists.openembedded.org
> Cc: Iorga, Cristian; Nobuhiro Iwamatsu
> Subject: [PATCH] alsa-tools: Update autotools.patch
>
> envy24control, rmedigicontrol and echomixer require gtk+-2.0.
> Remove envy24control rmedigicontrol and echomixer from list of tools.
>
> CC: Cristian Iorga <cristian.iorga@intel.com>
> Signed-off-by: Nobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>
> ---
>  .../alsa/alsa-tools/autotools.patch                |    6 +++---
>  .../recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb |    2 +-
>  2 files changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/meta/recipes-multimedia/alsa/alsa-tools/autotools.patch b/meta/recipes-multimedia/alsa/alsa-tools/autotools.patch
> index 294e970..08dd9de 100644
> --- a/meta/recipes-multimedia/alsa/alsa-tools/autotools.patch
> +++ b/meta/recipes-multimedia/alsa/alsa-tools/autotools.patch
> @@ -26,9 +26,9 @@ diff -ruN alsa-tools-1.0.24.1-orig//Makefile alsa-tools-1.0.24.1/Makefile
>  -        mixartloader pcxhrloader rmedigicontrol sb16_csp seq sscape_ctl \
>  -        us428control usx2yloader vxloader echomixer ld10k1 qlo10k1 \
>  -        hwmixvolume hdajackretask hda-verb
> -+SUBDIRS = ac3dec as10k1 envy24control \
> -+        mixartloader pcxhrloader rmedigicontrol sb16_csp seq sscape_ctl \
> -+        us428control usx2yloader vxloader echomixer \
> ++SUBDIRS = ac3dec as10k1 \
> ++        mixartloader pcxhrloader sb16_csp seq sscape_ctl \
> ++        us428control usx2yloader vxloader \
>  +        hwmixvolume hda-verb
>
>   all:
> diff --git a/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb b/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
> index 0fe4bee..4b4f29b 100644
> --- a/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
> +++ b/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
> @@ -5,7 +5,7 @@ SECTION = "console/utils"
>  LICENSE = "GPLv2 & LGPLv2+"
>  DEPENDS = "alsa-lib ncurses"
>
> -PR = "r0"
> +PR = "r1"
>
>  LIC_FILES_CHKSUM = "file://hdsploader/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
>                      file://ld10k1/COPYING.LIB;md5=7fbc338309ac38fefcd64b04bb903e34"
> --
> 1.7.9.5
>
>
> _______________________________________________
> Openembedded-core mailing list
> Openembedded-core@lists.openembedded.org
> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-core
Saul Wold - March 16, 2013, 11:04 p.m.
On 03/13/2013 06:43 PM, Nobuhiro Iwamatsu wrote:
> Hi,
>
> When I build alsa-tools, I could not build this with following error:
> ----
> checking for i586-oe-linux-pkg-config... no
> checking for pkg-config...
> /home/iwamatsu/yocto/alsa/tmp-eglibc/sysroots/x86_64-linux/usr/bin/pkg-config
> configure: WARNING: using cross tools not prefixed with host triplet
> checking pkg-config is at least version 0.9.0... yes
> checking for ENVY24CONTROL... no
> configure: error: Package requirements (gtk+-2.0 alsa >= 0.9.0) were not met:
>
> No package 'gtk+-2.0' found
>
What kind of image/packages are you building, it's possible that your 
image does not have gtk+ included and it looks like alsa-tools should 
depend on gtk+.

It might be better to add a PACKAGECONFIG with gtk+ for these instead of 
just removing them.

You can see python-smartpm_1.4.1.bb as example of how it's done.

Sau!


> Consider adjusting the PKG_CONFIG_PATH environment variable if you
> installed software in a non-standard prefix.
>
> Alternatively, you may set the environment variables ENVY24CONTROL_CFLAGS
> and ENVY24CONTROL_LIBS to avoid the need to call pkg-config.
> See the pkg-config man page for more details.
> make: *** [all] Error 1
> ----
>
> The original patch is deleted from the list in the software depending on gtk.
> However, envy24control etc. are dependent on gtk.
> The patch which I created deletes these from a list.
> I checked with openembedded-core (375ed2eaef10dd7d8f46badca6d779708724e5f6).
>
> Does my environment have a problem?
>
> Best regards,
>    Nobuhiro
>
> On Wed, Mar 13, 2013 at 8:02 PM, Iorga, Cristian
> <cristian.iorga@intel.com> wrote:
>> Hello Nobuhiro-san,
>>
>> Can you please explain your patch?
>> As far as I know, the alsa-tools present as targets were all buildable.
>> This was verified by me at last update.
>>
>> Regards,
>> Cristian
>>
>> -----Original Message-----
>> From: Nobuhiro Iwamatsu [mailto:iwamatsu@nigauri.org] On Behalf Of Nobuhiro Iwamatsu
>> Sent: Wednesday, March 13, 2013 4:09 AM
>> To: openembedded-core@lists.openembedded.org
>> Cc: Iorga, Cristian; Nobuhiro Iwamatsu
>> Subject: [PATCH] alsa-tools: Update autotools.patch
>>
>> envy24control, rmedigicontrol and echomixer require gtk+-2.0.
>> Remove envy24control rmedigicontrol and echomixer from list of tools.
>>
>> CC: Cristian Iorga <cristian.iorga@intel.com>
>> Signed-off-by: Nobuhiro Iwamatsu <nobuhiro.iwamatsu.yj@renesas.com>
>> ---
>>   .../alsa/alsa-tools/autotools.patch                |    6 +++---
>>   .../recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb |    2 +-
>>   2 files changed, 4 insertions(+), 4 deletions(-)
>>
>> diff --git a/meta/recipes-multimedia/alsa/alsa-tools/autotools.patch b/meta/recipes-multimedia/alsa/alsa-tools/autotools.patch
>> index 294e970..08dd9de 100644
>> --- a/meta/recipes-multimedia/alsa/alsa-tools/autotools.patch
>> +++ b/meta/recipes-multimedia/alsa/alsa-tools/autotools.patch
>> @@ -26,9 +26,9 @@ diff -ruN alsa-tools-1.0.24.1-orig//Makefile alsa-tools-1.0.24.1/Makefile
>>   -        mixartloader pcxhrloader rmedigicontrol sb16_csp seq sscape_ctl \
>>   -        us428control usx2yloader vxloader echomixer ld10k1 qlo10k1 \
>>   -        hwmixvolume hdajackretask hda-verb
>> -+SUBDIRS = ac3dec as10k1 envy24control \
>> -+        mixartloader pcxhrloader rmedigicontrol sb16_csp seq sscape_ctl \
>> -+        us428control usx2yloader vxloader echomixer \
>> ++SUBDIRS = ac3dec as10k1 \
>> ++        mixartloader pcxhrloader sb16_csp seq sscape_ctl \
>> ++        us428control usx2yloader vxloader \
>>   +        hwmixvolume hda-verb
>>
>>    all:
>> diff --git a/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb b/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
>> index 0fe4bee..4b4f29b 100644
>> --- a/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
>> +++ b/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
>> @@ -5,7 +5,7 @@ SECTION = "console/utils"
>>   LICENSE = "GPLv2 & LGPLv2+"
>>   DEPENDS = "alsa-lib ncurses"
>>
>> -PR = "r0"
>> +PR = "r1"
>>
>>   LIC_FILES_CHKSUM = "file://hdsploader/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
>>                       file://ld10k1/COPYING.LIB;md5=7fbc338309ac38fefcd64b04bb903e34"
>> --
>> 1.7.9.5
>>
>>
>> _______________________________________________
>> Openembedded-core mailing list
>> Openembedded-core@lists.openembedded.org
>> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-core
>
>
>
Nobuhiro Iwamatsu - March 18, 2013, 6:31 a.m.
Hi,

On Sun, Mar 17, 2013 at 8:04 AM, Saul Wold <sgw@linux.intel.com> wrote:
> On 03/13/2013 06:43 PM, Nobuhiro Iwamatsu wrote:
>>
>> Hi,
>>
>> When I build alsa-tools, I could not build this with following error:
>> ----
>> checking for i586-oe-linux-pkg-config... no
>> checking for pkg-config...
>>
>> /home/iwamatsu/yocto/alsa/tmp-eglibc/sysroots/x86_64-linux/usr/bin/pkg-config
>> configure: WARNING: using cross tools not prefixed with host triplet
>> checking pkg-config is at least version 0.9.0... yes
>> checking for ENVY24CONTROL... no
>> configure: error: Package requirements (gtk+-2.0 alsa >= 0.9.0) were not
>> met:
>>
>> No package 'gtk+-2.0' found
>>
> What kind of image/packages are you building, it's possible that your image
> does not have gtk+ included and it looks like alsa-tools should depend on
> gtk+.
>
> It might be better to add a PACKAGECONFIG with gtk+ for these instead of
> just removing them.
>
> You can see python-smartpm_1.4.1.bb as example of how it's done.
>
> Sau!
>

Thank you for your point.
I misunderstood.

Best regards,
  Nobuhiro
Trevor Woerner - March 29, 2013, 1:18 p.m.
I'm seeing this exact same error when I perform a "bitbake world", and
have been for the last couple days

On Wed, Mar 13, 2013 at 9:43 PM, Nobuhiro Iwamatsu
<nobuhiro.iwamatsu.yj@renesas.com> wrote:
> ----
> checking for i586-oe-linux-pkg-config... no
> checking for pkg-config...
> /home/iwamatsu/yocto/alsa/tmp-eglibc/sysroots/x86_64-linux/usr/bin/pkg-config
> configure: WARNING: using cross tools not prefixed with host triplet
> checking pkg-config is at least version 0.9.0... yes
> checking for ENVY24CONTROL... no
> configure: error: Package requirements (gtk+-2.0 alsa >= 0.9.0) were not met:
>
> No package 'gtk+-2.0' found
>
> Consider adjusting the PKG_CONFIG_PATH environment variable if you
> installed software in a non-standard prefix.
>
> Alternatively, you may set the environment variables ENVY24CONTROL_CFLAGS
> and ENVY24CONTROL_LIBS to avoid the need to call pkg-config.
> See the pkg-config man page for more details.
> make: *** [all] Error 1

Is the proposed patch from this email suitable for merging to master?
It allows my build of alsa-tools to complete without error.
Saul Wold - April 2, 2013, 3:59 p.m.
On 03/29/2013 06:18 AM, Trevor Woerner wrote:
> I'm seeing this exact same error when I perform a "bitbake world", and
> have been for the last couple days
>
I believe this is a real problem, and I suggested to Nobuhiro that using 
PACKAGECONFIG with gtk+ would be a better solution, but have not see a 
follow-up patch for this.

Patches welcome!

Sau!



> On Wed, Mar 13, 2013 at 9:43 PM, Nobuhiro Iwamatsu
> <nobuhiro.iwamatsu.yj@renesas.com> wrote:
>> ----
>> checking for i586-oe-linux-pkg-config... no
>> checking for pkg-config...
>> /home/iwamatsu/yocto/alsa/tmp-eglibc/sysroots/x86_64-linux/usr/bin/pkg-config
>> configure: WARNING: using cross tools not prefixed with host triplet
>> checking pkg-config is at least version 0.9.0... yes
>> checking for ENVY24CONTROL... no
>> configure: error: Package requirements (gtk+-2.0 alsa >= 0.9.0) were not met:
>>
>> No package 'gtk+-2.0' found
>>
>> Consider adjusting the PKG_CONFIG_PATH environment variable if you
>> installed software in a non-standard prefix.
>>
>> Alternatively, you may set the environment variables ENVY24CONTROL_CFLAGS
>> and ENVY24CONTROL_LIBS to avoid the need to call pkg-config.
>> See the pkg-config man page for more details.
>> make: *** [all] Error 1
>
> Is the proposed patch from this email suitable for merging to master?
> It allows my build of alsa-tools to complete without error.
>
> _______________________________________________
> Openembedded-core mailing list
> Openembedded-core@lists.openembedded.org
> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-core
>
>
Otavio Salvador - April 2, 2013, 5:46 p.m.
On Tue, Apr 2, 2013 at 12:59 PM, Saul Wold <saul.wold@intel.com> wrote:
> On 03/29/2013 06:18 AM, Trevor Woerner wrote:
>>
>> I'm seeing this exact same error when I perform a "bitbake world", and
>> have been for the last couple days
>>
> I believe this is a real problem, and I suggested to Nobuhiro that using
> PACKAGECONFIG with gtk+ would be a better solution, but have not see a
> follow-up patch for this.
>
> Patches welcome!

Rogerio (added to Cc) was working in a patch for this; I think he
should have it ready for submitting it soon.

--
Otavio Salvador                             O.S. Systems
E-mail: otavio@ossystems.com.br  http://www.ossystems.com.br
Mobile: +55 53 9981-7854              http://projetos.ossystems.com.br

Patch

diff --git a/meta/recipes-multimedia/alsa/alsa-tools/autotools.patch b/meta/recipes-multimedia/alsa/alsa-tools/autotools.patch
index 294e970..08dd9de 100644
--- a/meta/recipes-multimedia/alsa/alsa-tools/autotools.patch
+++ b/meta/recipes-multimedia/alsa/alsa-tools/autotools.patch
@@ -26,9 +26,9 @@  diff -ruN alsa-tools-1.0.24.1-orig//Makefile alsa-tools-1.0.24.1/Makefile
 -	  mixartloader pcxhrloader rmedigicontrol sb16_csp seq sscape_ctl \
 -	  us428control usx2yloader vxloader echomixer ld10k1 qlo10k1 \
 -	  hwmixvolume hdajackretask hda-verb
-+SUBDIRS = ac3dec as10k1 envy24control \
-+	  mixartloader pcxhrloader rmedigicontrol sb16_csp seq sscape_ctl \
-+	  us428control usx2yloader vxloader echomixer \
++SUBDIRS = ac3dec as10k1 \
++	  mixartloader pcxhrloader sb16_csp seq sscape_ctl \
++	  us428control usx2yloader vxloader \
 +	  hwmixvolume hda-verb
  
  all:
diff --git a/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb b/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
index 0fe4bee..4b4f29b 100644
--- a/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
+++ b/meta/recipes-multimedia/alsa/alsa-tools_1.0.26.1.bb
@@ -5,7 +5,7 @@  SECTION = "console/utils"
 LICENSE = "GPLv2 & LGPLv2+"
 DEPENDS = "alsa-lib ncurses"
 
-PR = "r0"
+PR = "r1"
 
 LIC_FILES_CHKSUM = "file://hdsploader/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
                     file://ld10k1/COPYING.LIB;md5=7fbc338309ac38fefcd64b04bb903e34"