Patchwork sane-toolchain.inc: Prefer libtool version 2.4 with sysroot.

login
register
mail settings
Submitter Khem Raj
Date Dec. 10, 2010, 12:54 a.m.
Message ID <1291942482-24901-1-git-send-email-raj.khem@gmail.com>
Download mbox | patch
Permalink /patch/46/
State Accepted
Headers show

Comments

Khem Raj - Dec. 10, 2010, 12:54 a.m.
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 conf/distro/include/sane-toolchain.inc |    7 +++++++
 1 files changed, 7 insertions(+), 0 deletions(-)
Martin Jansa - Dec. 10, 2010, 6:37 a.m.
On Thu, Dec 09, 2010 at 04:54:42PM -0800, Khem Raj wrote:
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> ---
>  conf/distro/include/sane-toolchain.inc |    7 +++++++
>  1 files changed, 7 insertions(+), 0 deletions(-)

Acked-by: Martin Jansa <Martin.Jansa@gmail.com>

> 
> diff --git a/conf/distro/include/sane-toolchain.inc b/conf/distro/include/sane-toolchain.inc
> index 6653f73..c0a4021 100644
> --- a/conf/distro/include/sane-toolchain.inc
> +++ b/conf/distro/include/sane-toolchain.inc
> @@ -10,6 +10,8 @@ PREFERRED_BINUTILS_VERSION           ?= "2.20.1"
>  PREFERRED_UCLIBC_VERSION             ?= "git"
>  PREFERRED_EGLIBC_VERSION             ?= "2.12"
>  PREFERRED_GLIBC_VERSION              ?= "2.10.1"
> +PREFERRED_LIBTOOL_VERSION            ?= "2.4"
> +LIBTOOL_HAS_SYSROOT                  ?= "yes"
>  
>  # Prefer glibc 2.6 and uclibc 0.9.30, these have had the most testing.
>  PREFERRED_VERSION_glibc              ?= "${PREFERRED_GLIBC_VERSION}"
> @@ -57,6 +59,11 @@ PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}g++              = "gcc-cross"
>  
>  # Others
>  PREFERRED_PROVIDER_linux-libc-headers = "linux-libc-headers"
> +PREFERRED_VERSION_libtool = "${PREFERRED_LIBTOOL_VERSION}"
> +PREFERRED_VERSION_libtool-cross = "${PREFERRED_LIBTOOL_VERSION}"
> +PREFERRED_VERSION_libtool-native = "${PREFERRED_LIBTOOL_VERSION}"
> +PREFERRED_VERSION_libtool-sdk = "${PREFERRED_LIBTOOL_VERSION}"
> +PREFERRED_VERSION_libtool-nativesdk = "${PREFERRED_LIBTOOL_VERSION}"
>  
>  #############################################################################
>  # TOOLCHAIN CUSTOMIZATION
> -- 
> 1.7.0.4
> 
> 
> _______________________________________________
> Openembedded-devel mailing list
> Openembedded-devel@lists.openembedded.org
> http://lists.linuxtogo.org/cgi-bin/mailman/listinfo/openembedded-devel

Patch

diff --git a/conf/distro/include/sane-toolchain.inc b/conf/distro/include/sane-toolchain.inc
index 6653f73..c0a4021 100644
--- a/conf/distro/include/sane-toolchain.inc
+++ b/conf/distro/include/sane-toolchain.inc
@@ -10,6 +10,8 @@  PREFERRED_BINUTILS_VERSION           ?= "2.20.1"
 PREFERRED_UCLIBC_VERSION             ?= "git"
 PREFERRED_EGLIBC_VERSION             ?= "2.12"
 PREFERRED_GLIBC_VERSION              ?= "2.10.1"
+PREFERRED_LIBTOOL_VERSION            ?= "2.4"
+LIBTOOL_HAS_SYSROOT                  ?= "yes"
 
 # Prefer glibc 2.6 and uclibc 0.9.30, these have had the most testing.
 PREFERRED_VERSION_glibc              ?= "${PREFERRED_GLIBC_VERSION}"
@@ -57,6 +59,11 @@  PREFERRED_PROVIDER_virtual/${TARGET_PREFIX}g++              = "gcc-cross"
 
 # Others
 PREFERRED_PROVIDER_linux-libc-headers = "linux-libc-headers"
+PREFERRED_VERSION_libtool = "${PREFERRED_LIBTOOL_VERSION}"
+PREFERRED_VERSION_libtool-cross = "${PREFERRED_LIBTOOL_VERSION}"
+PREFERRED_VERSION_libtool-native = "${PREFERRED_LIBTOOL_VERSION}"
+PREFERRED_VERSION_libtool-sdk = "${PREFERRED_LIBTOOL_VERSION}"
+PREFERRED_VERSION_libtool-nativesdk = "${PREFERRED_LIBTOOL_VERSION}"
 
 #############################################################################
 # TOOLCHAIN CUSTOMIZATION