Patchwork [2/3] build-appliance-image: ethernet connection type is now bridged

login
register
mail settings
Submitter Cristian Iorga
Date March 11, 2013, 11:24 a.m.
Message ID <1363001062-18854-3-git-send-email-cristian.iorga@intel.com>
Download mbox | patch
Permalink /patch/45917/
State Accepted
Commit 24ec421e1a76d6263677a98a85b489c35cbe7761
Headers show

Comments

Cristian Iorga - March 11, 2013, 11:24 a.m.
For network/internet connectivity, Build Appliance uses
a NAT virtual network adapter. While using NAT, inside
Build Appliance network proxies won't provide a network
connection to the outside world.

Basically, connectivity is not provided if network proxies
are needed in order to acces the internet.

The solution is to use bridged ethernet connection type.

Fixes [YOCTO #3998].

Signed-off-by: Cristian Iorga <cristian.iorga@intel.com>
---
 .../images/build-appliance-image/Yocto_Build_Appliance.vmx           |    2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Patch

diff --git a/meta/recipes-core/images/build-appliance-image/Yocto_Build_Appliance.vmx b/meta/recipes-core/images/build-appliance-image/Yocto_Build_Appliance.vmx
index b38127a..b04a1b6 100644
--- a/meta/recipes-core/images/build-appliance-image/Yocto_Build_Appliance.vmx
+++ b/meta/recipes-core/images/build-appliance-image/Yocto_Build_Appliance.vmx
@@ -41,7 +41,7 @@  scsi0.virtualDev = "lsilogic"
 scsi0.present = "TRUE"
 ethernet0.present = "TRUE"
 ethernet0.virtualDev = "e1000"
-ethernet0.connectionType = "nat"
+ethernet0.connectionType = "bridged"
 ethernet0.startConnected = "TRUE"
 ethernet0.addressType = "generated"
 sound.present = "TRUE"